]> git.pld-linux.org Git - packages/mpich.git/blob - mpich.spec
- control blcr checkpointing support by bcond not libcr presence
[packages/mpich.git] / mpich.spec
1 #
2 # Conditional build:
3 %bcond_with     blcr    # blcr application checkpointing support (no support for recent kernels)
4 #
5 Summary:        Portable MPI Model Implementation
6 Summary(pl.UTF-8):      Przenośna implementacja standardu MPI
7 Name:           mpich
8 Version:        3.1.3
9 Release:        3
10 License:        BSD-like
11 Group:          Development/Libraries
12 Source0:        http://www.mpich.org/static/downloads/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  93cb17f91ac758cbf9174ecb03563778
14 Patch0:         %{name}-sh.patch
15 Patch1:         %{name}-opalink.patch
16 Patch2:         x32-misdetected-as-i386.patch
17 URL:            http://www.mpich.org/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.12.3
20 %{?with_blcr:BuildRequires:     blcr-devel}
21 BuildRequires:  ftb-devel
22 BuildRequires:  gcc-fortran
23 BuildRequires:  hwloc-devel >= 1.9.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  openpa-devel
27 Requires:       hwloc-libs >= 1.9.0
28 Provides:       mpi
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 MPICH is a high-performance and widely portable implementation of the
33 MPI-3.0 standard from the Argonne National Laboratory. This release
34 has all MPI 3.0 functions and features required by the standard with
35 the exception of support for the "external32" portable I/O format and
36 user-defined data representations for I/O.
37
38 This package contains MPICH shared libraries and runtime utilities,
39 including Hydra PM.
40
41 %description -l pl.UTF-8
42 MPICH to wysoko wydajna i przenośna implementacja standardu MPI-3.0
43 pochodząca z Argonne National Laboratory. To wydanie zawiera całą
44 funkcjonalność i możliwości MPI 3.0 wymagane przez standard z
45 wyjątkiem obsługi przenośnego formatu we-wy "external32" oraz
46 definiowanych przez użytkownika reprezentacji danych dla we/wy.
47
48 Ten pakiet zawiera biblioteki współdzielone MPICH oraz narzędzia
49 uruchomieniowe, w tym Hydra PM.
50
51 %package devel
52 Summary:        MPICH header files and development tools
53 Summary(pl.UTF-8):      Pliki nagłówkowe oraz narzędzia programistyczne MPICH
54 Group:          Development
55 Requires:       %{name} = %{version}-%{release}
56 Provides:       mpi-devel
57
58 %description devel
59 MPICH header files and development tools.
60
61 %description devel
62 Pliki nagłówkowe oraz narzędzia programistyczne MPICH.
63
64 %package static
65 Summary:        MPICH static libraries
66 Summary(pl.UTF-8):      Biblioteki statyczne MPICH
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69 Provides:       mpi-static
70
71 %description static
72 MPICH static libraries.
73
74 %description static -l pl.UTF-8
75 Biblioteki statyczne MPICH.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I confdb
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --disable-silent-rules \
91         %{?with_blcr:--enable-checkpointing} \
92         --with-hwloc-prefix=system \
93         %{!?with_blcr:--with-hydra-ckpointlib=none} \
94         --with-openpa-prefix=system
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
106 %{__rm} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/{cpi,cpi.o,examples.sln}
107
108 # see openpa.spec
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libopa.so
110
111 # PDFs packaged as %doc
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mpich
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc CHANGES COPYRIGHT README README.envvar RELEASE_NOTES doc/{installguide/install.pdf,logging/logging.pdf,userguide/user.pdf}
123 %attr(755,root,root) %{_bindir}/hydra_nameserver
124 %attr(755,root,root) %{_bindir}/hydra_persist
125 %attr(755,root,root) %{_bindir}/hydra_pmi_proxy
126 %attr(755,root,root) %{_bindir}/mpichversion
127 %attr(755,root,root) %{_bindir}/mpiexec
128 %attr(755,root,root) %{_bindir}/mpiexec.hydra
129 %attr(755,root,root) %{_bindir}/mpirun
130 %attr(755,root,root) %{_bindir}/mpivars
131 %attr(755,root,root) %{_bindir}/parkill
132 %attr(755,root,root) %{_libdir}/libmpi.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libmpi.so.12
134 %attr(755,root,root) %{_libdir}/libmpicxx.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libmpicxx.so.12
136 %attr(755,root,root) %{_libdir}/libmpifort.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libmpifort.so.12
138 %{_mandir}/man1/hydra_nameserver.1*
139 %{_mandir}/man1/hydra_persist.1*
140 %{_mandir}/man1/hydra_pmi_proxy.1*
141 %{_mandir}/man1/mpiexec.1*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/mpic++
146 %attr(755,root,root) %{_bindir}/mpicc
147 %attr(755,root,root) %{_bindir}/mpicxx
148 %attr(755,root,root) %{_bindir}/mpif77
149 %attr(755,root,root) %{_bindir}/mpif90
150 %attr(755,root,root) %{_bindir}/mpifort
151 %attr(755,root,root) %{_libdir}/libmpi.so
152 %attr(755,root,root) %{_libdir}/libmpicxx.so
153 %attr(755,root,root) %{_libdir}/libmpifort.so
154 %attr(755,root,root) %{_libdir}/libfmpich.so
155 %attr(755,root,root) %{_libdir}/libmpich.so
156 %attr(755,root,root) %{_libdir}/libmpichcxx.so
157 %attr(755,root,root) %{_libdir}/libmpichf90.so
158 %attr(755,root,root) %{_libdir}/libmpl.so
159 %{_libdir}/libmpi.la
160 %{_libdir}/libmpicxx.la
161 %{_libdir}/libmpifort.la
162 %{_includedir}/mpi*.h
163 %{_includedir}/mpi*.mod
164 %{_pkgconfigdir}/mpich.pc
165 %{_mandir}/man1/mpicc.1*
166 %{_mandir}/man1/mpicxx.1*
167 %{_mandir}/man1/mpif77.1*
168 %{_mandir}/man1/mpifort.1*
169 %{_mandir}/man3/MPIX_*.3*
170 %{_mandir}/man3/MPI_*.3*
171 %{_examplesdir}/%{name}-%{version}
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libmpi.a
176 %{_libdir}/libmpicxx.a
177 %{_libdir}/libmpifort.a
This page took 0.060557 seconds and 3 git commands to generate.