]> git.pld-linux.org Git - packages/mozjs60.git/blob - mozjs60.spec
Init commit
[packages/mozjs60.git] / mozjs60.spec
1 Summary:        SpiderMonkey 60 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 60 - implementacja języka JavaScript
3 Name:           mozjs60
4 Version:        60.1.0
5 Release:        1
6 License:        MPL v2.0
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-%{version}.tar.bz2
9 # Source0-md5:  202f71313e53d9b92e7c578107541539
10 Patch0:         copy-headers.patch
11 Patch1:         system-virtualenv.patch
12 Patch2:         include-configure-script.patch
13 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
14 BuildRequires:  autoconf2_13
15 BuildRequires:  libstdc++-devel >= 6:4.4
16 BuildRequires:  nspr-devel >= 4.9.2
17 BuildRequires:  perl-base >= 1:5.6
18 BuildRequires:  pkgconfig
19 BuildRequires:  python >= 1:2.5
20 BuildRequires:  python-virtualenv >= 1.9.1-4
21 BuildRequires:  readline-devel
22 BuildRequires:  rpm-perlprov
23 BuildRequires:  rpmbuild(macros) >= 1.294
24 BuildRequires:  zlib-devel >= 1.2.3
25 Requires:       nspr >= 4.9.2
26 Requires:       zlib >= 1.2.3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 JavaScript Reference Implementation (codename SpiderMonkey). The
31 package contains JavaScript runtime (compiler, interpreter,
32 decompiler, garbage collector, atom manager, standard classes) and
33 small "shell" program that can be used interactively and with .js
34 files to run scripts.
35
36 %description -l pl.UTF-8
37 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
38 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
39 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
40 która może być używana interaktywnie lub z plikami .js do uruchamiania
41 skryptów.
42
43 %package devel
44 Summary:        Header files for JavaScript reference library
45 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel
49 Requires:       nspr-devel >= 4.9.2
50
51 %description devel
52 Header files for JavaScript reference library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe do biblioteki JavaScript.
56
57 %prep
58 %setup -q -n mozjs-%{version}
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62
63 %build
64 export PYTHON="%{__python}"
65 export AUTOCONF="%{_bindir}/autoconf2_13"
66 export SHELL="/bin/sh"
67 cd js/src
68 mkdir obj
69 cd obj
70
71 %define configuredir ".."
72 %configure2_13 \
73         --enable-readline \
74         --enable-threadsafe \
75         --enable-shared-js \
76         --enable-gcgenerational \
77         --with-system-nspr \
78         --with-system-icu \
79         --with-system-zlib \
80         --with-intl-api \
81         --disable-jemalloc
82
83 %{__make} \
84         HOST_OPTIMIZE_FLAGS= \
85         MODULE_OPTIMIZE_FLAGS= \
86         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
87         MOZ_PGO_OPTIMIZE_FLAGS= \
88         MOZILLA_VERSION=%{version}
89
90 cd ../../..
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 cd js/src/obj
96
97 %{__make} -C js/src install \
98     DESTDIR=$RPM_BUILD_ROOT \
99     MOZILLA_VERSION=%{version}
100
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc js/src/README.html
112 %attr(755,root,root) %{_bindir}/js60
113 %attr(755,root,root) %{_libdir}/libmozjs-60.so
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/js60-config
118 %{_includedir}/mozjs-60
119 %{_pkgconfigdir}/mozjs-60.pc
This page took 0.069815 seconds and 3 git commands to generate.