]> git.pld-linux.org Git - packages/mozjs52.git/blob - mozjs52.spec
a44ee10538202cf96faa0bc65bb5c82d8320e667
[packages/mozjs52.git] / mozjs52.spec
1 Summary:        SpiderMonkey 52 - JavaScript implementation
2 Summary(pl.UTF-8):      SpiderMonkey 52 - implementacja języka JavaScript
3 Name:           mozjs52
4 Version:        52.7.4
5 Release:        9
6 License:        MPL v2.0
7 Group:          Libraries
8 #Source0:       https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
9 # instructions to get: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/52
10 Source0:        https://queue.taskcluster.net/v1/task/U1nRqVKNRj29NR92pluyxA/runs/0/artifacts/public/build/mozjs-%{version}.tar.bz2
11 # Source0-md5:  0c025f7ddd2c03880fd738692c0659dd
12 Patch0:         copy-headers.patch
13 Patch1:         disable-mozglue.patch
14 Patch2:         system-virtualenv.patch
15 Patch3:         include-configure-script.patch
16 Patch4:         %{name}-x32.patch
17 Patch5:         %{name}-cpp.patch
18 Patch6:         sysctl_h.patch
19 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
20 BuildRequires:  autoconf2_13
21 BuildRequires:  libstdc++-devel >= 6:4.4
22 BuildRequires:  nspr-devel >= 4.9.2
23 BuildRequires:  perl-base >= 1:5.6
24 BuildRequires:  pkgconfig
25 BuildRequires:  python >= 1:2.5
26 BuildRequires:  python-virtualenv >= 1.9.1-4
27 BuildRequires:  readline-devel
28 BuildRequires:  rpm-perlprov
29 BuildRequires:  rpmbuild(macros) >= 1.294
30 BuildRequires:  zlib-devel >= 1.2.3
31 Requires:       nspr >= 4.9.2
32 Requires:       zlib >= 1.2.3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 JavaScript Reference Implementation (codename SpiderMonkey). The
37 package contains JavaScript runtime (compiler, interpreter,
38 decompiler, garbage collector, atom manager, standard classes) and
39 small "shell" program that can be used interactively and with .js
40 files to run scripts.
41
42 %description -l pl.UTF-8
43 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
44 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
45 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
46 która może być używana interaktywnie lub z plikami .js do uruchamiania
47 skryptów.
48
49 %package devel
50 Summary:        Header files for JavaScript reference library
51 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libstdc++-devel
55 Requires:       nspr-devel >= 4.9.2
56
57 %description devel
58 Header files for JavaScript reference library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe do biblioteki JavaScript.
62
63 %prep
64 %setup -q -n mozjs-%{version}
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69 %ifarch x32
70 %patch4 -p1
71 %endif
72 %patch5 -p1
73 %patch6 -p1
74
75 %build
76 export PYTHON="%{__python}"
77 export AUTOCONF="%{_bindir}/autoconf2_13"
78 export SHELL="/bin/sh"
79 cd js/src
80
81 autoconf2_13
82 %configure2_13 \
83         --enable-readline \
84         --enable-threadsafe \
85         --enable-shared-js \
86         --enable-gcgenerational \
87         --with-system-nspr \
88         --with-system-icu \
89         --with-system-zlib \
90         --with-intl-api
91
92 %{__make} \
93         HOST_OPTIMIZE_FLAGS= \
94         MODULE_OPTIMIZE_FLAGS= \
95         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
96         MOZ_PGO_OPTIMIZE_FLAGS= \
97         MOZILLA_VERSION=%{version}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} -C js/src install \
103     DESTDIR=$RPM_BUILD_ROOT \
104     MOZILLA_VERSION=%{version}
105
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc js/src/README.html
117 %attr(755,root,root) %{_bindir}/js52
118 %attr(755,root,root) %{_libdir}/libmozjs-52.so
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/js52-config
123 %{_includedir}/mozjs-52
124 %{_pkgconfigdir}/mozjs-52.pc
This page took 0.087432 seconds and 2 git commands to generate.