]> git.pld-linux.org Git - packages/mozilla-thunderbird.git/blob - mozilla-thunderbird.spec
- updated to 24.5.0, sync with icedove
[packages/mozilla-thunderbird.git] / mozilla-thunderbird.spec
1 # NOTE: PLD distributes icedove instead
2 #
3 # TODO:
4 # - separate spec for enigmail
5 # - build with system mozldap
6 #
7 # Conditional builds
8 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
9 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
10 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
11 %bcond_without  lightning       # disable Sunbird/Lightning calendar
12 %bcond_with     xulrunner       # system xulrunner
13 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
14
15 %if 0%{?_enable_debug_packages} != 1
16 %undefine       crashreporter
17 %endif
18
19 %define         enigmail_ver    1.6
20 %define         nspr_ver        4.10.2
21 %define         nss_ver         3.15.4
22
23 %define         xulrunner_ver   2:24.0
24
25 %if %{without xulrunner}
26 # The actual sqlite version (see RHBZ#480989):
27 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
28 %endif
29
30 Summary:        Thunderbird Community Edition - email client
31 Summary(pl.UTF-8):      Thunderbird Community Edition - klient poczty
32 Name:           mozilla-thunderbird
33 Version:        24.5.0
34 Release:        1
35 License:        MPL v2.0
36 Group:          X11/Applications/Mail
37 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
38 # Source0-md5:  dbe164c48e42c04b4959910eda2e52ca
39 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
40 # Source1-md5:  4a2bbcb020bdb282a660fda8c70d5608
41 Source2:        %{name}.png
42 Source4:        %{name}.desktop
43 Source5:        %{name}.sh
44 Patch1:         %{name}-enigmail-shared.patch
45 Patch2:         %{name}-sh.patch
46 Patch3:         %{name}-fonts.patch
47 Patch6:         %{name}-prefs.patch
48 Patch7:         %{name}-system-mozldap.patch
49 Patch8:         %{name}-makefile.patch
50 Patch12:        %{name}-no-subshell.patch
51 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
52 Patch13:        %{name}-system-virtualenv.patch
53 Patch14:        %{name}-gyp-slashism.patch
54 Patch15:        %{name}-enable-addons.patch
55 URL:            http://www.mozilla.org/projects/thunderbird/
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  alsa-lib-devel
58 BuildRequires:  automake
59 BuildRequires:  bzip2-devel
60 BuildRequires:  cairo-devel >= 1.10
61 BuildRequires:  dbus-glib-devel >= 0.60
62 BuildRequires:  freetype-devel >= 1:2.1.8
63 BuildRequires:  glib2-devel >= 2.0
64 BuildRequires:  gstreamer0.10-devel
65 BuildRequires:  gstreamer0.10-plugins-base-devel
66 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.14}
67 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
68 BuildRequires:  hunspell-devel
69 BuildRequires:  libIDL-devel >= 0.8.0
70 BuildRequires:  libevent-devel
71 BuildRequires:  libiw-devel
72 # requires libjpeg-turbo implementing at least libjpeg 6b API
73 BuildRequires:  libjpeg-devel >= 6b
74 BuildRequires:  libjpeg-turbo-devel
75 BuildRequires:  libpng-devel >= 1.4.1
76 BuildRequires:  libstdc++-devel
77 BuildRequires:  mozldap-devel
78 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
79 BuildRequires:  nss-devel >= 1:%{nss_ver}
80 BuildRequires:  pango-devel >= 1:1.14.0
81 BuildRequires:  perl-base >= 1:5.6
82 BuildRequires:  python-virtualenv
83 BuildRequires:  pkgconfig
84 BuildRequires:  python >= 1:2.5
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  sqlite3-devel >= 3.7.17
87 BuildRequires:  startup-notification-devel >= 0.8
88 BuildRequires:  libvpx-devel >= 1.0.0
89 BuildRequires:  xorg-lib-libXext-devel
90 BuildRequires:  xorg-lib-libXinerama-devel
91 BuildRequires:  xorg-lib-libXt-devel
92 BuildRequires:  yasm
93 BuildRequires:  zip
94 %if %{with xulrunner}
95 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
96 BuildRequires:  xulrunner-devel < 2:25
97 %else
98 %{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
99 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
100 Requires:       myspell-common
101 Requires:       nspr >= 1:%{nspr_ver}
102 Requires:       nss >= 1:%{nss_ver}
103 Requires:       sqlite3 >= %{sqlite_build_version}
104 %endif
105 Requires(post): mktemp >= 1.5-18
106 %if %{with xulrunner}
107 %requires_eq_to xulrunner xulrunner-devel
108 %endif
109 Requires:       libjpeg-turbo
110 Obsoletes:      mozilla-thunderbird-dictionary-en-US
111 Conflicts:      mozilla-thunderbird-lang-resources < %{version}
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # don't satisfy other packages (don't use %{name} here)
117 %define         _noautoprovfiles        %{_libdir}/mozilla-thunderbird/components
118 %if %{without xulrunner}
119 # we don't want these to satisfy packages depending on xulrunner
120 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
121 # and as we don't provide them, don't require either
122 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
123 %endif
124
125 %define         topdir          %{_builddir}/%{name}-%{version}
126 %define         objdir          %{topdir}/obj-%{_target_cpu}
127
128 %description
129 Thunderbird Community Edition is an open-source,fast and portable
130 email client.
131
132 %description -l pl.UTF-8
133 Thunderbird Community Edition jest open sourcowym, szybkim i
134 przenośnym klientem poczty.
135
136 %package addon-lightning
137 Summary:        An integrated calendar for Mozilla Thunderbird
138 Summary(pl.UTF-8):      Zintegrowany kalendarz dla klienta Mozilla Thunderbird
139 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
140 Group:          Applications/Networking
141 Requires:       %{name} = %{version}-%{release}
142
143 %description addon-lightning
144 Lightning is an calendar extension to Mozilla Thunderbird email
145 client.
146
147 %description addon-lightning -l pl.UTF-8
148 Lightning to rozszerzenie do klienta poczty Mozilla Thunderbird
149 dodające funkcjonalność kalendarza.
150
151 %package addon-enigmail
152 Summary:        Extension for the authentication and encryption features provided by GnuPG
153 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
154 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
155 Group:          Applications/Networking
156 URL:            http://enigmail.mozdev.org/
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       gnupg
159
160 %description addon-enigmail
161 Enigmail is an extension to the mail client of Mozilla Thunderbird
162 which allows users to access the authentication and encryption
163 features provided by GnuPG.
164
165 Main Features:
166 - Encrypt/sign mail when sending, decrypt/authenticate received mail
167 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
168 - Per-Account based encryption and signing defaults
169 - Per-Recipient rules for automated key selection, and
170   enabling/disabling encryption and signing
171 - OpenPGP key management interface
172
173 %description addon-enigmail -l pl.UTF-8
174 Enigmail to rozszerzenie klienta pocztowego Mozilla Thunderbird
175 pozwalające użytkownikom na dostęp do uwierzytelniania i szyfrowania
176 zapewnianego przez GnuPG.
177
178 Główne możliwości:
179 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
180   odszyfrowywanie/uwierzytelnianie poczty odebranej
181 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
182 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
183 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
184   podpisywania dla każdego adresata
185 - interfejs do zarządzania kluczami OpenPGP
186
187 %prep
188 %setup -qc
189 mv comm-esr24 mozilla
190 cd mozilla
191 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} xf - -C mailnews/extensions}
192 %{?with_enigmail:%patch1 -p1}
193 %patch2 -p1
194 %patch3 -p1
195 %patch6 -p1
196 %patch7 -p1
197 %patch8 -p2
198 %patch12 -p1
199 %patch13 -p1
200 %patch14 -p1
201 %patch15 -p1
202
203 %build
204 cd mozilla
205 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
206 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
207 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
208
209 cat << EOF > .mozconfig
210 mk_add_options MOZ_OBJDIR=%{objdir}
211
212 export CFLAGS="%{rpmcflags}"
213 export CXXFLAGS="%{rpmcflags}"
214
215 %if %{with crashreporter}
216 export MOZ_DEBUG_SYMBOLS=1
217 %endif
218
219 # Options for 'configure' (same as command-line options).
220 ac_add_options --prefix=%{_prefix}
221 ac_add_options --exec-prefix=%{_exec_prefix}
222 ac_add_options --bindir=%{_bindir}
223 ac_add_options --sbindir=%{_sbindir}
224 ac_add_options --sysconfdir=%{_sysconfdir}
225 ac_add_options --datadir=%{_datadir}
226 ac_add_options --includedir=%{_includedir}
227 ac_add_options --libdir=%{_libdir}
228 ac_add_options --libexecdir=%{_libexecdir}
229 ac_add_options --localstatedir=%{_localstatedir}
230 ac_add_options --sharedstatedir=%{_sharedstatedir}
231 ac_add_options --mandir=%{_mandir}
232 ac_add_options --infodir=%{_infodir}
233 %if %{?debug:1}0
234 ac_add_options --disable-optimize
235 ac_add_options --enable-debug
236 ac_add_options --enable-debug-modules
237 ac_add_options --enable-debugger-info-modules
238 ac_add_options --enable-crash-on-assert
239 %else
240 ac_add_options --disable-debug
241 ac_add_options --disable-debug-modules
242 ac_add_options --disable-logging
243 ac_add_options --enable-optimize="%{rpmcflags} -Os"
244 %endif
245 ac_add_options --disable-strip
246 ac_add_options --disable-strip-libs
247 %if %{with tests}
248 ac_add_options --enable-tests
249 %else
250 ac_add_options --disable-tests
251 %endif
252 %if %{with lightning}
253 ac_add_options --enable-calendar
254 %else
255 ac_add_options --disable-calendar
256 %endif
257 %if %{with crashreporter}
258 ac_add_options --enable-crashreporter
259 %else
260 ac_add_options --disable-crashreporter
261 %endif
262 ac_add_options --disable-elf-dynstr-gc
263 ac_add_options --disable-gnomeui
264 ac_add_options --disable-gnomevfs
265 ac_add_options --disable-installer
266 ac_add_options --disable-javaxpcom
267 ac_add_options --disable-profilesharing
268 ac_add_options --disable-updater
269 ac_add_options --disable-xterm-updates
270 ac_add_options --enable-application=mail
271 ac_add_options --enable-crypto
272 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
273 ac_add_options --enable-gio
274 %if %{with ldap}
275 ac_add_options --enable-ldap
276 ac_add_options --with-system-ldap
277 %else
278 ac_add_options --disable-ldap
279 %endif
280 ac_add_options --enable-libxul
281 ac_add_options --enable-pango
282 ac_add_options --enable-postscript
283 ac_add_options --enable-shared-js
284 ac_add_options --enable-single-profile
285 ac_add_options --enable-startup-notification
286 ac_add_options --enable-system-cairo
287 ac_add_options --enable-system-hunspell
288 ac_add_options --enable-system-sqlite
289 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
290 ac_add_options --with-distribution-id=org.pld-linux
291 %if %{with xulrunner}
292 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
293 ac_add_options --with-system-libxul
294 %endif
295 ac_add_options --with-pthreads
296 ac_add_options --with-system-bz2
297 ac_add_options --with-system-ffi
298 ac_add_options --with-system-jpeg
299 ac_add_options --with-system-libevent
300 ac_add_options --with-system-libvpx
301 ac_add_options --with-system-nspr
302 ac_add_options --with-system-nss
303 ac_add_options --with-system-png
304 ac_add_options --with-system-zlib
305 EOF
306
307 mkdir -p %{objdir}/config
308 ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
309
310 %{__make} -j1 -f client.mk build \
311         STRIP="/bin/true" \
312         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
313         installdir=%{_libdir}/%{name} \
314         XLIBS="-lX11 -lXt" \
315         CC="%{__cc}" \
316         CXX="%{__cxx}"
317
318 %if %{with crashreporter}
319 # create debuginfo for crash-stats.mozilla.com
320 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
321 %endif
322
323 %if %{with enigmail}
324 cd mailnews/extensions/enigmail
325 ./makemake -r -o %{objdir}
326 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
327         STRIP="/bin/true" \
328         CC="%{__cc}" \
329         CXX="%{__cxx}"
330
331 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
332         STRIP="/bin/true" \
333         CC="%{__cc}" \
334         CXX="%{__cxx}"
335 %endif
336
337 %install
338 rm -rf $RPM_BUILD_ROOT
339 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
340
341 cd %{objdir}
342 %{__make} -C mail/installer stage-package \
343         DESTDIR=$RPM_BUILD_ROOT \
344         installdir=%{_libdir}/%{name} \
345         PKG_SKIP_STRIP=1
346
347 cp -a mozilla/dist/thunderbird/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
348  
349 %if %{with xulrunner}
350 # needed to find mozilla runtime
351 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
352 %endif
353  
354 # Enable crash reporter for Thunderbird application
355 %if %{with crashreporter}
356 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
357
358 # Add debuginfo for crash-stats.mozilla.com
359 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
360 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
361 %endif
362
363 # copy manually lightning files, somewhy they are not installed by make
364 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
365         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
366
367 # move arch independant ones to datadir
368 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
369 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
370
371 # dir for arch independant extensions besides arch dependant extensions
372 # see mozilla/xpcom/build/nsXULAppAPI.h
373 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
374 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
375
376 %if %{without xulrunner}
377 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
378 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
379 %endif
380
381 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
382 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
383
384 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
385 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-thunderbird.png
386
387 # files created by regxpcom -register in post
388 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
389 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
390 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
391 #!/bin/sh
392 umask 022
393 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
394 # dangerous if you run this with sudo with keep_env += HOME
395 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
396 t=$(mktemp -d)
397 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
398 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/thunderbird -register
399 rm -rf $t
400 EOF
401 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
402
403 %if %{with enigmail}
404 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
405 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
406 cd mozilla/dist/bin
407 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
408 cp -rfLp components/enig* $ext_dir/components
409 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
410 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
411 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
412 cd -
413 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
414 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
415 %endif
416
417 # mozldap
418 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
419 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %pretrans
425 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
426         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
427 fi
428 for d in chrome defaults icons isp modules res searchplugins; do
429         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
430                 install -d %{_datadir}/%{name}
431                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
432         fi
433 done
434 exit 0
435
436 %post
437 %{_libdir}/%{name}/register || :
438
439 %files
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
442 %attr(755,root,root) %{_bindir}/thunderbird
443 %dir %{_libdir}/%{name}
444 %{_libdir}/%{name}/application.ini
445 %{_libdir}/%{name}/blocklist.xml
446 %{_libdir}/%{name}/chrome.manifest
447 %dir %{_libdir}/%{name}/components
448 %{_libdir}/%{name}/components/components.manifest
449 %attr(755,root,root) %{_libdir}/%{name}/*.sh
450 %attr(755,root,root) %{_libdir}/%{name}/*-bin
451 %attr(755,root,root) %{_libdir}/%{name}/thunderbird
452 %attr(755,root,root) %{_libdir}/%{name}/register
453 %{_libdir}/%{name}/omni.ja
454 %if %{without xulrunner}
455 %{_libdir}/%{name}/dependentlibs.list
456 %{_libdir}/%{name}/platform.ini
457 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
458 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
459 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
460 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
461 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
462 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
463 %endif
464
465 # symlinks
466 %{_libdir}/%{name}/chrome
467 %{_libdir}/%{name}/defaults
468 %{_libdir}/%{name}/isp
469 %{_libdir}/%{name}/searchplugins
470 %if %{with xulrunner}
471 %{_libdir}/%{name}/xulrunner
472 %else
473 %{_libdir}/%{name}/dictionaries
474 %endif
475
476 %{_pixmapsdir}/mozilla-thunderbird.png
477 %{_desktopdir}/mozilla-thunderbird.desktop
478
479 %dir %{_datadir}/%{name}
480 %{_datadir}/%{name}/extensions
481 %{_datadir}/%{name}/searchplugins
482
483 %if %{with crashreporter}
484 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
485 %{_libdir}/%{name}/crashreporter.ini
486 %{_libdir}/%{name}/Throbber-small.gif
487 %endif
488
489 %dir %{_libdir}/%{name}/extensions
490 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
491
492 # files created by regxpcom -register
493 %ghost %{_libdir}/%{name}/components/compreg.dat
494 %ghost %{_libdir}/%{name}/components/xpti.dat
495
496 %if %{with lightning}
497 %files addon-lightning
498 %defattr(644,root,root,755)
499 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
500 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
501 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
502 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
503 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
504 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
505 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
506 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
507 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
508 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
509 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
510 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
511 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
512 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
513 %endif
514
515 %if %{with enigmail}
516 %files addon-enigmail
517 %defattr(644,root,root,755)
518 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
519 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
520 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
521 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
522 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
523 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
524 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
525 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
526 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
527 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
528 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
529 %endif
This page took 0.084287 seconds and 3 git commands to generate.