]> git.pld-linux.org Git - packages/mozilla-thunderbird.git/blob - mozilla-thunderbird.spec
04505d2bb9d09d941dc22da55ccb200ee868a3ac
[packages/mozilla-thunderbird.git] / mozilla-thunderbird.spec
1 # NOTE: PLD distributes icedove instead
2 #
3 # TODO:
4 # - separate spec for enigmail
5 # - build with system mozldap
6 #
7 # Conditional builds
8 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnome           # alias for gnomeui
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable Sunbird/Lightning calendar
13 %bcond_with     xulrunner       # system xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %endif
19
20 %if 0%{?_enable_debug_packages} != 1
21 %undefine       crashreporter
22 %endif
23
24 %define         enigmail_ver    1.5.1
25 %define         nspr_ver        4.9.3
26 %define         nss_ver         3.14.1
27
28 %define         xulrunner_ver   2:17.0
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Thunderbird Community Edition - email client
36 Summary(pl.UTF-8):      Thunderbird Community Edition - klient poczty
37 Name:           mozilla-thunderbird
38 Version:        17.0.3
39 Release:        1
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  180f7768f6419182ea78eeb80da7f588
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  3e71f84ed2c11471282412ebe4f5eb2d
46 Source2:        %{name}.png
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch1:         %{name}-enigmail-shared.patch
50 Patch3:         %{name}-fonts.patch
51 Patch4:         %{name}-install.patch
52 Patch5:         %{name}-hunspell.patch
53 Patch6:         %{name}-prefs.patch
54 Patch7:         %{name}-system-mozldap.patch
55 Patch8:         %{name}-makefile.patch
56 Patch9:         %{name}-system-cairo.patch
57 Patch11:        %{name}-crashreporter.patch
58 Patch12:        %{name}-no-subshell.patch
59 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
60 Patch13:        %{name}-system-virtualenv.patch
61 Patch14:        %{name}-gyp-slashism.patch
62 URL:            http://www.mozilla.org/projects/thunderbird/
63 BuildRequires:  GConf2-devel >= 1.2.1
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  cairo-devel >= 1.10
68 BuildRequires:  dbus-glib-devel >= 0.60
69 BuildRequires:  freetype-devel >= 1:2.1.8
70 BuildRequires:  glib2-devel >= 2.0
71 BuildRequires:  gtk+2-devel >= 2:2.10.0
72 BuildRequires:  hunspell-devel
73 BuildRequires:  libIDL-devel >= 0.8.0
74 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
75 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
76 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
77 BuildRequires:  libiw-devel
78 # requires libjpeg-turbo implementing at least libjpeg 6b API
79 BuildRequires:  libjpeg-devel >= 6b
80 BuildRequires:  libjpeg-turbo-devel
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.14.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
100 BuildRequires:  xulrunner-devel < 2:18
101 %else
102 Requires:       myspell-common
103 Requires:       nspr >= 1:%{nspr_ver}
104 Requires:       nss >= 1:%{nss_ver}
105 Requires:       sqlite3 >= %{sqlite_build_version}
106 %endif
107 Requires(post): mktemp >= 1.5-18
108 %if %{with xulrunner}
109 %requires_eq_to xulrunner xulrunner-devel
110 %endif
111 Requires:       libjpeg-turbo
112 Obsoletes:      mozilla-thunderbird-dictionary-en-US
113 Conflicts:      mozilla-thunderbird-lang-resources < %{version}
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
117
118 # don't satisfy other packages (don't use %{name} here)
119 %define         _noautoprovfiles        %{_libdir}/mozilla-thunderbird/components
120 %if %{without xulrunner}
121 # we don't want these to satisfy packages depending on xulrunner
122 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
123 # and as we don't provide them, don't require either
124 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
125 %endif
126
127 %define         topdir          %{_builddir}/%{name}-%{version}
128 %define         objdir          %{topdir}/obj-%{_target_cpu}
129
130 %description
131 Thunderbird Community Edition is an open-source,fast and portable
132 email client.
133
134 %description -l pl.UTF-8
135 Thunderbird Community Edition jest open sourcowym, szybkim i
136 przenośnym klientem poczty.
137
138 %package addon-lightning
139 Summary:        An integrated calendar for Mozilla Thunderbird
140 Summary(pl.UTF-8):      Zintegrowany kalendarz dla klienta Mozilla Thunderbird
141 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
142 Group:          Applications/Networking
143 Requires:       %{name} = %{version}-%{release}
144
145 %description addon-lightning
146 Lightning is an calendar extension to Mozilla Thunderbird email
147 client.
148
149 %description addon-lightning -l pl.UTF-8
150 Lightning to rozszerzenie do klienta poczty Mozilla Thunderbird
151 dodające funkcjonalność kalendarza.
152
153 %package addon-enigmail
154 Summary:        Extension for the authentication and encryption features provided by GnuPG
155 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
156 License:        MPL/LGPL
157 Group:          Applications/Networking
158 URL:            http://enigmail.mozdev.org/
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       gnupg
161
162 %description addon-enigmail
163 Enigmail is an extension to the mail client of Mozilla Thunderbird
164 which allows users to access the authentication and encryption
165 features provided by GnuPG.
166
167 Main Features:
168 - Encrypt/sign mail when sending, decrypt/authenticate received mail
169 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
170 - Per-Account based encryption and signing defaults
171 - Per-Recipient rules for automated key selection, and
172   enabling/disabling encryption and signing
173 - OpenPGP key management interface
174
175 %description addon-enigmail -l pl.UTF-8
176 Enigmail to rozszerzenie klienta pocztowego Mozilla Thunderbird
177 pozwalające użytkownikom na dostęp do uwierzytelniania i szyfrowania
178 zapewnianego przez GnuPG.
179
180 Główne możliwości:
181 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
182   odszyfrowywanie/uwierzytelnianie poczty odebranej
183 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
184 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
185 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
186   podpisywania dla każdego adresata
187 - interfejs do zarządzania kluczami OpenPGP
188
189 %prep
190 %setup -q -c
191 mv comm-esr17 mozilla
192 cd mozilla
193 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} xf - -C mailnews/extensions}
194 %{?with_enigmail:%patch1 -p1}
195 %patch3 -p1
196 %patch4 -p1
197 %patch6 -p1
198 %patch7 -p1
199 %patch8 -p2
200 %patch9 -p1
201 %patch11 -p2
202 %patch12 -p1
203 %patch13 -p1
204 %patch14 -p1
205
206 %build
207 cd mozilla
208 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
209 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
210 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
211
212 cat << EOF > .mozconfig
213 mk_add_options MOZ_OBJDIR=%{objdir}
214
215 export CFLAGS="%{rpmcflags}"
216 export CXXFLAGS="%{rpmcflags}"
217
218 %if %{with crashreporter}
219 export MOZ_DEBUG_SYMBOLS=1
220 %endif
221
222 # Options for 'configure' (same as command-line options).
223 ac_add_options --prefix=%{_prefix}
224 ac_add_options --exec-prefix=%{_exec_prefix}
225 ac_add_options --bindir=%{_bindir}
226 ac_add_options --sbindir=%{_sbindir}
227 ac_add_options --sysconfdir=%{_sysconfdir}
228 ac_add_options --datadir=%{_datadir}
229 ac_add_options --includedir=%{_includedir}
230 ac_add_options --libdir=%{_libdir}
231 ac_add_options --libexecdir=%{_libexecdir}
232 ac_add_options --localstatedir=%{_localstatedir}
233 ac_add_options --sharedstatedir=%{_sharedstatedir}
234 ac_add_options --mandir=%{_mandir}
235 ac_add_options --infodir=%{_infodir}
236 %if %{?debug:1}0
237 ac_add_options --disable-optimize
238 ac_add_options --enable-debug
239 ac_add_options --enable-debug-modules
240 ac_add_options --enable-debugger-info-modules
241 ac_add_options --enable-crash-on-assert
242 %else
243 ac_add_options --disable-debug
244 ac_add_options --disable-debug-modules
245 ac_add_options --disable-logging
246 ac_add_options --enable-optimize="%{rpmcflags} -Os"
247 %endif
248 ac_add_options --disable-strip
249 ac_add_options --disable-strip-libs
250 %if %{with tests}
251 ac_add_options --enable-tests
252 %else
253 ac_add_options --disable-tests
254 %endif
255 ac_add_options --enable-gio
256 %if %{with gnomeui}
257 ac_add_options --enable-gnomeui
258 %else
259 ac_add_options --disable-gnomeui
260 %endif
261 ac_add_options --disable-gnomevfs
262 %if %{with ldap}
263 ac_add_options --enable-ldap
264 ac_add_options --with-system-ldap
265 %else
266 ac_add_options --disable-ldap
267 %endif
268 %if %{with crashreporter}
269 ac_add_options --enable-crashreporter
270 %else
271 ac_add_options --disable-crashreporter
272 %endif
273 ac_add_options --disable-xterm-updates
274 ac_add_options --enable-postscript
275 %if %{with lightning}
276 ac_add_options --enable-calendar
277 %else
278 ac_add_options --disable-calendar
279 %endif
280 ac_add_options --disable-installer
281 ac_add_options --disable-updater
282 ac_add_options --disable-xprint
283 ac_add_options --disable-permissions
284 ac_add_options --disable-pref-extensions
285 ac_add_options --enable-canvas
286 ac_add_options --enable-crypto
287 ac_add_options --enable-mathml
288 ac_add_options --enable-pango
289 ac_add_options --enable-reorder
290 ac_add_options --enable-startup-notification
291 ac_add_options --enable-svg
292 ac_add_options --enable-system-cairo
293 ac_add_options --enable-system-hunspell
294 ac_add_options --enable-system-sqlite
295 ac_add_options --enable-xft
296 ac_add_options --enable-application=mail
297 ac_add_options --enable-default-toolkit=cairo-gtk2
298 ac_add_options --enable-xinerama
299 ac_add_options --with-distribution-id=org.pld-linux
300 %if %{with xulrunner}
301 ac_add_options --enable-shared-js
302 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
303 ac_add_options --with-system-libxul
304 %endif
305 ac_add_options --with-pthreads
306 ac_add_options --with-system-bz2
307 ac_add_options --with-system-jpeg
308 ac_add_options --with-system-nspr
309 ac_add_options --with-system-nss
310 ac_add_options --with-system-png
311 ac_add_options --with-system-zlib
312 ac_add_options --enable-single-profile
313 ac_add_options --disable-profilesharing
314 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
315 EOF
316
317 %{__make} -j1 -f client.mk build \
318         STRIP="/bin/true" \
319         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
320         XLIBS="-lX11 -lXt" \
321         CC="%{__cc}" \
322         CXX="%{__cxx}"
323
324 %if %{with crashreporter}
325 # create debuginfo for crash-stats.mozilla.com
326 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
327 %endif
328
329 %if %{with enigmail}
330 cd mailnews/extensions/enigmail
331 ./makemake -r -o %{objdir}
332 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
333         STRIP="/bin/true" \
334         CC="%{__cc}" \
335         CXX="%{__cxx}"
336
337 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
338         STRIP="/bin/true" \
339         CC="%{__cc}" \
340         CXX="%{__cxx}"
341 %endif
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
346
347 cd %{objdir}
348 %{__make} -C mail/installer stage-package \
349         DESTDIR=$RPM_BUILD_ROOT \
350         MOZ_PKG_DIR=%{_libdir}/%{name} \
351         PKG_SKIP_STRIP=1
352
353 %if %{with xulrunner}
354 # needed to find mozilla runtime
355 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
356 %endif
357  
358 # Enable crash reporter for Thunderbird application
359 %if %{with crashreporter}
360 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
361
362 # Add debuginfo for crash-stats.mozilla.com
363 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
364 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
365 %endif
366
367 # copy manually lightning files, somewhy they are not installed by make
368 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
369         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
370         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
371
372 # move arch independant ones to datadir
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
375 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
377 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
378 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
379 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
380 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
381 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
382 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
383 %if %{without xulrunner}
384 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
385 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
386 %endif
387
388 # dir for arch independant extensions besides arch dependant extensions
389 # see mozilla/xpcom/build/nsXULAppAPI.h
390 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
391 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
392
393 %if %{without xulrunner}
394 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
395 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
396 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
397 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
398 %endif
399
400 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
401 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
402
403 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
404 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-thunderbird.png
405
406 # files created by regxpcom -register in post
407 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
408 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
409 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
410 #!/bin/sh
411 umask 022
412 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
413 # dangerous if you run this with sudo with keep_env += HOME
414 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
415 t=$(mktemp -d)
416 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
417 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/thunderbird -register
418 rm -rf $t
419 EOF
420 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
421
422 %if %{with enigmail}
423 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
424 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
425 cd mozilla/dist/bin
426 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
427 cp -rfLp components/enig* $ext_dir/components
428 cp -rfLp components/libenigmime.so $ext_dir/components
429 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
430 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
431 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
432 cd -
433 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
434 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
435 %endif
436
437 # never package these. always remove
438 # nss
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
440 # nspr
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
442 # mozldap
443 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
444 # testpilot quiz
445 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %pretrans
451 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
452         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
453 fi
454 for d in chrome defaults icons isp modules res searchplugins; do
455         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
456                 install -d %{_datadir}/%{name}
457                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
458         fi
459 done
460 exit 0
461
462 %post
463 %{_libdir}/%{name}/register || :
464
465 %files
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
468 %attr(755,root,root) %{_bindir}/thunderbird
469 %dir %{_libdir}/%{name}
470 %{_libdir}/%{name}/application.ini
471 %{_libdir}/%{name}/blocklist.xml
472 %{_libdir}/%{name}/chrome.manifest
473 %dir %{_libdir}/%{name}/components
474 %{_libdir}/%{name}/components/*.js
475 %{_libdir}/%{name}/components/*.xpt
476 %{_libdir}/%{name}/components/components.manifest
477 %{_libdir}/%{name}/components/interfaces.manifest
478 %attr(755,root,root) %{_libdir}/%{name}/*.sh
479 %attr(755,root,root) %{_libdir}/%{name}/*-bin
480 %attr(755,root,root) %{_libdir}/%{name}/thunderbird
481 %attr(755,root,root) %{_libdir}/%{name}/register
482 %if %{without xulrunner}
483 %{_libdir}/%{name}/dependentlibs.list
484 %{_libdir}/%{name}/platform.ini
485 %{_libdir}/%{name}/greprefs.js
486 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
487 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
488 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
489 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
490 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
491 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
492 %endif
493
494 # symlinks
495 %{_libdir}/%{name}/chrome
496 %{_libdir}/%{name}/defaults
497 %{_libdir}/%{name}/isp
498 %{_libdir}/%{name}/modules
499 %{_libdir}/%{name}/searchplugins
500 %if %{with xulrunner}
501 %{_libdir}/%{name}/xulrunner
502 %else
503 %{_libdir}/%{name}/dictionaries
504 %{_libdir}/%{name}/hyphenation
505 %{_libdir}/%{name}/res
506 %endif
507
508 %{_pixmapsdir}/mozilla-thunderbird.png
509 %{_desktopdir}/mozilla-thunderbird.desktop
510
511 %dir %{_datadir}/%{name}
512 %{_datadir}/%{name}/chrome
513 %{_datadir}/%{name}/defaults
514 %{_datadir}/%{name}/extensions
515 %{_datadir}/%{name}/isp
516 %{_datadir}/%{name}/modules
517 %if %{with enigmail}
518 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
519 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
520 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
521 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
522 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
523 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
524 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
525 %endif
526 %{_datadir}/%{name}/searchplugins
527 %if %{without xulrunner}
528 %{_datadir}/%{name}/res
529 %endif
530
531 %if %{with crashreporter}
532 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
533 %{_libdir}/%{name}/crashreporter.ini
534 %{_libdir}/%{name}/Throbber-small.gif
535 %endif
536
537 %dir %{_libdir}/%{name}/extensions
538 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
539
540 # files created by regxpcom -register
541 %ghost %{_libdir}/%{name}/components/compreg.dat
542 %ghost %{_libdir}/%{name}/components/xpti.dat
543
544 %if %{with lightning}
545 %files addon-lightning
546 %defattr(644,root,root,755)
547 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
548 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
549 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
550 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
551 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
552 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
553 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
554 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
555 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
556 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
557 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
558 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
559 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
560 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
561 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
562 %endif
563
564 %if %{with enigmail}
565 %files addon-enigmail
566 %defattr(644,root,root,755)
567 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
568 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
569 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
570 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
571 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
572 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
573 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
574 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
575 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
576 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
577 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
578 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
579 %endif
This page took 0.299789 seconds and 2 git commands to generate.