]> git.pld-linux.org Git - packages/mozilla-addon-gnome-keyring.git/blob - mozilla-addon-gnome-keyring.spec
8f2dfacd002ca90e3778694c81b09d9c958e4031
[packages/mozilla-addon-gnome-keyring.git] / mozilla-addon-gnome-keyring.spec
1 %define         extension gnome-keyring
2 Summary:        Extension that enables Gnome Keyring integration
3 Name:           mozilla-addon-%{extension}
4 Version:        0.6.9
5 Release:        2
6 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
7 Group:          X11/Applications/Networking
8 Source0:        https://github.com/infinity0/mozilla-gnome-keyring/archive/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  eedd226a6f866ae3091ca79b3bdeabad
10 URL:            https://github.com/infinity0/mozilla-gnome-keyring/
11 BuildRequires:  libgnome-keyring-devel >= 3.4.0
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  pkg-config
14 BuildRequires:  xulrunner-devel
15 BuildRequires:  zip
16 Requires:       libgnome-keyring >= 3.4.0
17 ExclusiveArch:  %{x8664} %{ix86}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # this comes from install.rdf
21 %define         extension_id    \{6f9d85e0-794d-11dd-ad8b-0800200c9a66\}
22 %define         extensionsdir   %{_libdir}/mozilla/extensions
23
24 # https://developer.mozilla.org/en/XPCOM_ABI#ABI_Naming
25 %define         platform                unknown
26 %ifarch %{ix86}
27 %define         platform                Linux_x86-gcc3
28 %endif
29 %ifarch %{x8664}
30 %define         platform                Linux_x86_64-gcc3
31 %endif
32
33 %description
34 This extension replaces the default password manager in both Firefox
35 and Thunderbird with an implementation which stores the passwords in
36 Gnome keyring.
37
38 This allows for safe storage of passwords without prompting for
39 password after Firefox or Thunderbird has been started.
40
41 %prep
42 %setup -qn mozilla-gnome-keyring-%{version}
43
44 %{__sed} -i -e '/^CXXFLAGS/ s/$/ $(OPTFLAGS)/' Makefile
45
46 %build
47 # build ext for current arch only
48 %{__make} build-xpi \
49         PLATFORM=%{platform} \
50         VERSION=%{version} \
51         XUL_VER_MIN=17.0 \
52         CXX="%{__cxx}" \
53         LDFLAGS="%{rpmldflags}" \
54         OPTFLAGS="%{rpmcxxflags} -fpermissive"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 # Install Gecko extension
59 install -d $RPM_BUILD_ROOT%{extensionsdir}/%{extension_id}
60 cp -a xpi/* $RPM_BUILD_ROOT%{extensionsdir}/%{extension_id}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %dir %{extensionsdir}/%{extension_id}
68 %{extensionsdir}/%{extension_id}/chrome
69 %{extensionsdir}/%{extension_id}/chrome.manifest
70 %{extensionsdir}/%{extension_id}/defaults
71 %{extensionsdir}/%{extension_id}/install.rdf
72 %dir %{extensionsdir}/%{extension_id}/platform
73 %dir %{extensionsdir}/%{extension_id}/platform/%{platform}
74 %dir %{extensionsdir}/%{extension_id}/platform/%{platform}/components
75 %attr(755,root,root) %{extensionsdir}/%{extension_id}/platform/%{platform}/components/libgnomekeyring.so
This page took 0.097653 seconds and 2 git commands to generate.