]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
85879dab8b6f710b6f8d2f255e61c5b6b7dfa136
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Mosh mobile shell
8 Summary(pl.UTF-8):      Mosh - przenośna powłoka
9 Name:           mosh
10 Version:        1.3.2
11 Release:        6
12 License:        GPL v3+
13 Group:          Applications/Networking
14 Source0:        https://mosh.org/%{name}-%{version}.tar.gz
15 # Source0-md5:  5122f4d2b973ab7c38dcdac8c35cb61e
16 Patch0:         https://github.com/keithw/mosh/pull/583.patch
17 Patch1:         %{name}-Werror.patch
18 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
19 Patch2:         %{name}-gcc8.patch
20 URL:            https://mosh.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake
23 BuildRequires:  binutils >= 2.20.51.0.2
24 BuildRequires:  libstdc++-devel >= 5:4.0
25 BuildRequires:  libtool
26 BuildRequires:  libutempter-devel
27 BuildRequires:  ncurses-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  patchutils
30 BuildRequires:  perl-base >= 1:5.14
31 BuildRequires:  pkgconfig
32 BuildRequires:  protobuf >= %{protobuf_ver}
33 BuildRequires:  protobuf-devel >= %{protobuf_ver}
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  zlib-devel
37 Requires:       protobuf-libs >= %{protobuf_ver}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # PLD stack protector flags are weaker than upstream, filter them out
41 # https://github.com/keithw/mosh/issues/203
42 %define         _ssp_cflags     %{nil}
43
44 %define         specflags       -Wno-error=non-virtual-dtor
45
46 %description
47 Remote terminal application that allows roaming, supports intermittent
48 connectivity, and provides intelligent local echo and line editing of
49 user keystrokes.
50
51 Mosh is a replacement for SSH. It's more robust and responsive,
52 especially over Wi-Fi, cellular, and long-distance links.
53
54 %description -l pl.UTF-8
55 Zdalna aplikacja terminala, pozwalająca na przemieszczanie,
56 obsługująca przerywaną łączność i zapewniająca inteligentne lokalne
57 echo oraz edycję linii.
58
59 Mosh to zamiennik SSH. Jest potężniejszy i responsywny, w
60 szczególności po połączeniach Wi-Fi, komórkowych i długodystansowych.
61
62 %prep
63 %setup -q
64 %if %{with agent}
65 %patch0 -p1
66 %endif
67 %patch1 -p1
68 %patch2 -p1
69 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
70
71 %build
72 %{__libtoolize}
73 %{__aclocal} -I m4
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure \
78         --disable-silent-rules \
79         --enable-compile-warnings=error
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS ChangeLog NEWS THANKS
94 %attr(755,root,root) %{_bindir}/%{name}
95 %attr(755,root,root) %{_bindir}/%{name}-client
96 %attr(755,root,root) %{_bindir}/%{name}-server
97 %{_mandir}/man1/%{name}.1*
98 %{_mandir}/man1/%{name}-client.1*
99 %{_mandir}/man1/%{name}-server.1*
This page took 0.057662 seconds and 2 git commands to generate.