]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
build with --disable-silent-rules
[packages/mosh.git] / mosh.spec
1
2 # force gcc4 for ac
3 %if "%{pld_release}" == "ac"
4 # add suffix, but allow ccache, etc in ~/.rpmmacros
5 %{expand:%%define       __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
6 %{expand:%%define       __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
7 %{expand:%%define       __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
8 %endif
9
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Mosh mobile shell
12 Name:           mosh
13 Version:        1.2.4
14 Release:        3
15 License:        GPL v3+
16 Group:          X11/Applications
17 Source0:        http://mosh.mit.edu/%{name}-%{version}.tar.gz
18 # Source0-md5:  c2d918f4d91fdc32546e2e089f9281b2
19 URL:            http://mosh.mit.edu/
20 BuildRequires:  binutils >= 2.20.51.0.2
21 BuildRequires:  libstdc++-devel >= 5:4.0
22 BuildRequires:  libutempter-devel
23 BuildRequires:  ncurses-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  protobuf
27 BuildRequires:  protobuf-devel
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  zlib-devel
31 # gcc4 might be installed, but not current __cc
32 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
33 BuildRequires:  __cc >= 4.0
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # PLD stack protector flags are weaker than upstream, filter them out
38 # https://github.com/keithw/mosh/issues/203
39 %define         _ssp_cflags     %{nil}
40
41 %description
42 Remote terminal application that allows roaming, supports intermittent
43 connectivity, and provides intelligent local echo and line editing of
44 user keystrokes.
45
46 Mosh is a replacement for SSH. It's more robust and responsive,
47 especially over Wi-Fi, cellular, and long-distance links.
48
49 %prep
50 %setup -q
51 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh
52
53 %build
54 CPPFLAGS="-I/usr/include/ncurses"
55 %configure \
56         --disable-silent-rules \
57         --enable-compile-warnings=error
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog NEWS THANKS
71 %attr(755,root,root) %{_bindir}/%{name}
72 %attr(755,root,root) %{_bindir}/%{name}-client
73 %attr(755,root,root) %{_bindir}/%{name}-server
74 %{_mandir}/man1/%{name}.1*
75 %{_mandir}/man1/%{name}-client.1*
76 %{_mandir}/man1/%{name}-server.1*
This page took 0.033515 seconds and 3 git commands to generate.