]> git.pld-linux.org Git - packages/mopidy.git/blob - mopidy.spec
fad0a95b80baae00c488535870959616e42f2b69
[packages/mopidy.git] / mopidy.spec
1 %define         module          mopidy
2 %define         egg_name        Mopidy
3 Summary:        Music server with MPD and Spotify support
4 Name:           mopidy
5 Version:        2.0.0
6 Release:        0.2
7 License:        Apache v2.0
8 Group:          Development/Libraries
9 Source0:        https://github.com/mopidy/mopidy/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  ada9471fe369a7c70c2d4cb3f0e10abc
11 Source1:        %{name}.conf
12 Source2:        %{name}.service
13 URL:            http://www.mopidy.com/
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       python-backports-ssl_match_hostname
17 Requires:       python-certifi
18 Requires:       python-dbus
19 Requires:       python-gstreamer
20 Requires:       python-pygobject
21 Requires:       python-pykka
22 Requires:       python-requests
23 Requires:       python-tornado
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Mopidy is a Python application that runs in a terminal or in the
29 background on Linux computers or Macs that have network connectivity
30 and audio output. Out of the box, Mopidy is an MPD and HTTP server.
31 Additional frontends for controlling Mopidy can be installed from
32 extensions.
33
34 %prep
35 %setup -q
36
37 %build
38 %py_build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %py_install
43 %py_postclean
44
45 # install mopidy config file
46 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
47 cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
48
49 # install mopidy service file
50 install -d $RPM_BUILD_ROOT%{systemdunitdir}
51 cp %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %dir %{_sysconfdir}/%{name}
59 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
60 %{systemdunitdir}/%{name}.service
61 %attr(755,root,root) %{_bindir}/mopidy
62 %{py_sitescriptdir}/%{module}
63 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.081945 seconds and 2 git commands to generate.