]> git.pld-linux.org Git - packages/monyog.git/blob - monyog.spec
setup dir to be used as mysql user
[packages/monyog.git] / monyog.spec
1 # TODO
2 # - pldize initscript
3 Summary:        MONyog MySQL Monitoring Tool
4 Name:           monyog
5 Version:        6.1.0
6 Release:        0.9
7 License:        Webyog Inc.
8 Group:          Applications/Databases
9 Source0:        https://static.webyog.com/downloads/MONyog-%{version}-0.i386.tar.gz
10 # NoSource0-md5:        adadfca45532b163d4f1f24f9cdff9c0
11 NoSource:       0
12 Source1:        https://static.webyog.com/downloads/MONyog-%{version}-0.x86_64.tar.gz
13 # NoSource1-md5:        4cc3950bca955474b73baa57c4c4d9d7
14 NoSource:       1
15 URL:            https://www.webyog.com/product/monyog
16 ExclusiveArch:  %{ix86} %{x8664}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _appdir %{_libdir}/%{name}
20
21 # monyog: file '/usr/sbin/monyog' has size=498000 instead of 29952257
22 %define         _noautostrip            .*%{_appdir}/bin/monyog
23
24 %description
25 MONyog is a monitoring and advisory tool for MySQL Community, MySQL
26 Enterprise and MariaDB.
27
28 MONyog helps MySQL Database Administrators to manage more servers,
29 tune their MySQL servers and fix problems with MySQL database
30 applications. MONyog is agent-less, and does not require anything to
31 be installed on the MySQL servers. MONyog helps monitor enterprise
32 database environments and provides expert advice on how even those new
33 to MySQL can tighten security, optimize performance and reduce
34 downtime of their MySQL powered systems.
35
36 %prep
37 %ifarch %{ix86}
38 %setup -qcT -a0
39 %endif
40 %ifarch %{x8664}
41 %setup -qcT -a1
42 %endif
43
44 mv MONyog/* .
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_appdir}/bin,/etc/{rc.d/init.d,logrotate.d}}
49 cp -a MONyog.lua MONyog.mib res $RPM_BUILD_ROOT%{_appdir}
50 install -p bin/MONyog $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
51 install -p bin/MONyog-bin $RPM_BUILD_ROOT%{_appdir}/bin/%{name}
52
53 # home directory that is usable for mysql user (not to run the daemon as root)
54 # bin dir needs to be writable, as ssh temp files are created there
55 install -d $RPM_BUILD_ROOT/var/lib/%{name}/bin
56 ln -s %{_appdir}/res $RPM_BUILD_ROOT/var/lib/%{name}
57 ln -s %{_appdir}/bin/%{name} $RPM_BUILD_ROOT/var/lib/%{name}/bin
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 %banner -e -o %{name} <<EOF
64
65 ===========================================================================
66 Point your browser to http://<YOUR_HOST>:<MONYOG_PORT>/ to monitor MySQL servers.
67 Please refer to https://www.webyog.com/webyog/monyogDocs for online documentation.
68 ===========================================================================
69
70 EOF
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README
75 %attr(754,root,root) /etc/rc.d/init.d/monyog
76 %dir %{_appdir}
77 %{_appdir}/MONyog.lua
78 %{_appdir}/MONyog.mib
79 %{_appdir}/res
80 %dir %{_appdir}/bin
81 %attr(755,root,root) %{_appdir}/bin/monyog
82
83 %dir %attr(770,root,mysql) /var/lib/%{name}
84 %dir %attr(770,root,mysql) /var/lib/%{name}/bin
85 /var/lib/%{name}/res
86 /var/lib/%{name}/bin/%{name}
This page took 0.119846 seconds and 3 git commands to generate.