]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
fd9a5d22dd7c1870dd5a7afb63df4f234958d720
[packages/monodevelop.git] / monodevelop.spec
1 %define         monoversion     1.1.5
2 Summary:        Mono IDE
3 Summary(pl):    IDE dla Mono
4 Name:           monodevelop
5 Version:        0.6
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://mono2.ximian.com/archive/%{monoversion}/%{name}-%{version}.tar.gz
10 # Source0-md5:  0cf7524360913394ea7fa1bc434b7f0c
11 Patch0:         %{name}-MOZILLA_FIVE_HOME.patch
12 Patch1:         %{name}-locale_names.patch
13 Patch2:         %{name}-libdir.patch
14 Patch3:         %{name}-desktop.patch
15 URL:            http://www.monodevelop.com/
16 BuildRequires:  ORBit2-devel >= 2.8.3
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1:1.7
19 BuildRequires:  dotnet-gtk-sharp-devel >= 1.0
20 BuildRequires:  dotnet-gtksourceview-sharp-devel >= 0.5
21 BuildRequires:  intltool
22 BuildRequires:  libtool
23 BuildRequires:  mono-csharp >= 1.0
24 BuildRequires:  monodoc >= 1.0
25 BuildRequires:  dotnet-gecko-sharp-devel >= 0.5
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  shared-mime-info
28 Requires:       mono
29 Requires:       monodoc
30 Requires:       mozilla-embedded
31 Requires:       dotnet-gtksourceview-sharp
32 Requires:       dotnet-gecko-sharp
33 Requires:       dotnet-gtk-sharp
34 Requires(post,postun):  shared-mime-info
35 Obsoletes:      MonoDevelop
36 ExcludeArch:    alpha
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Mono IDE, in the very early stages of development right now, and
41 progressing quickly. MonoDevelop has many features. Some of these
42 include:
43 - Class Management
44   MonoDevelop has a class viewer which allows you to list the classes
45   in your project, their methods, and properties. Your namespaces are
46   also kept track of to keep the classes separated. When you add
47   something to your project, it will automatically be added to the
48   class viewer, even if they're namespaces, classes, methods, or even
49   variables.
50 - Code Completion
51   With the .NET and Gtk# frameworks put together, it can be
52   challenging to remember all the classes, methods, or properties that
53   are at your disposal. MonoDevelop's intelligent code completion
54   attempts to complete what you're typing. If it finds a match, just
55   hit tab and MonoDevelop will do the typing for you.
56 - Project Support
57   MonoDevelop comes with built in projects that help get you started
58   with your console, Gnome# or Gtk# application.
59
60 %description -l pl
61 MonoDevelop to IDE (zintegrowane ¶rodowisko programisty) dla Mono we
62 wczesnym, ale szybko postêpuj±cym stadium rozwoju. Ma wiele
63 mo¿liwo¶ci, a w¶ród nich:
64 - zarz±dzanie klasami
65   MonoDevelop ma przegl±darkê klas pozwalaj±c± wy¶wietlaæ klasy w
66   projekcie, ich metody oraz w³asno¶ci. Przestrzenie nazw s±
67   uwzglêdniane, aby zachowaæ separacjê klas. Przy dodawaniu czego¶ do
68   projektu jest to automatycznie dodawane do przegl±darki klas, nawet
69   je¶li s± to przestrzenie nazw, klasy, metody, a nawet zmienne.
70 - dope³nianie kodu
71   Przy po³±czeniu szkieletów .NET i Gtk# pamiêtanie samemu wszystkich
72   klas, metod i w³asno¶ci mog³oby byæ nie lada wyzwaniem. MonoDevelop
73   w sposób inteligentny próbuje dope³niaæ to, co siê pisze. Je¶li
74   znajdzie dopasowanie, wystarczy nacisn±æ tabulacjê, aby dokoñczy³
75   pisaæ za nas.
76 - obs³uga projektów
77   MonoDevelop przychodzi z wbudowanymi projektami, pomagaj±cymi zacz±æ
78   tworzyæ aplikacje konsolowe, Gnome# albo Gtk#.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86 # ignore errors from it
87 sed -e 's/update-mime-database/-&/' -i Makefile.am
88
89 mv po/ja{_JP,}.po
90
91 %build
92 rm -rf autom4te.cache
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoheader}
96 %{__automake}
97 %{__autoconf}
98 %configure
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 update-mime-database %{_datadir}/mime
114
115 %postun
116 update-mime-database %{_datadir}/mime
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc README
121 %attr(755,root,root) %{_bindir}/*
122 %{_libdir}/%{name}
123 %{_datadir}/mime/packages/*
124 %{_desktopdir}/*
125 %{_pixmapsdir}/*
This page took 0.10392 seconds and 2 git commands to generate.