]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
e5e2260fdf6d7aa3c9218f017b0fb74451f2467e
[packages/monodevelop.git] / monodevelop.spec
1 # TODO: use system libgit2, libgit2sharp, nunit, mono-addins
2 #
3 # Conditional build:
4 %bcond_without  subversion      # disable subversion backend
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 Summary:        Mono IDE
9 Summary(pl.UTF-8):      IDE dla Mono
10 Name:           monodevelop
11 Version:        5.10.0.871
12 Release:        1
13 # most of code is MIT-licensed, some parts LGPL v2
14 License:        LGPL v2, MIT
15 Group:          Development/Tools
16 Source0:        http://download.mono-project.com/sources/monodevelop/%{name}-%{version}.tar.bz2
17 # Source0-md5:  4722cbbaeb7a518dceea8147e6cb6181
18 Patch0:         %{name}-desktop.patch
19 Patch1:         %{name}-aspnet.patch
20 Patch2:         %{name}-nunit.patch
21 Patch3:         %{name}-avoidgiterrors.patch
22 Patch4:         %{name}-nuget-unbundle.patch
23 Patch5:         %{name}-no-nuget-packages.patch
24 URL:            http://monodevelop.com/
25 BuildRequires:  autoconf >= 2.53
26 BuildRequires:  automake >= 1:1.10
27 # gconf-sharp, gnome-sharp, gnome-vfs-sharp
28 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
29 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.8
30 BuildRequires:  dotnet-newtonsoft-json-devel >= 6.0
31 BuildRequires:  dotnet-nuget-devel
32 BuildRequires:  dotnet-nunit2 >= 2.6.4
33 BuildRequires:  gettext-tools
34 BuildRequires:  mono-csharp >= 3.0.4
35 BuildRequires:  monodoc >= 1.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.311
38 BuildRequires:  sed >= 4.0
39 Requires(post,postun):  desktop-file-utils
40 Requires(post,postun):  gtk-update-icon-cache
41 Requires(post,postun):  hicolor-icon-theme
42 Requires(post,postun):  shared-mime-info
43 Requires:       dotnet-gtk-sharp2 >= 2.12.8
44 Requires:       hicolor-icon-theme
45 Requires:       pkgconfig
46 %{?with_subversion:Requires:    subversion-libs}
47 Requires:       xulrunner-libs
48 Suggests:       ctags
49 Suggests:       mono-compat-links >= 3.0.4
50 Suggests:       mono-csharp >= 3.0.4
51 Suggests:       monodoc >= 1.0
52 Suggests:       xsp
53 Obsoletes:      MonoDevelop
54 ExcludeArch:    alpha i386 sparc sparc64
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _noautoreq      'mono\\(System.Data.Entity\\)' 'mono\\(System.Web.WebPages.Deployment\\)'
58
59 %description
60 Mono IDE, in the very early stages of development right now, and
61 progressing quickly. MonoDevelop has many features. Some of these
62 include:
63 - Class Management MonoDevelop has a class viewer which allows you to
64   list the classes in your project, their methods, and properties. Your
65   namespaces are also kept track of to keep the classes separated. When
66   you add something to your project, it will automatically be added to
67   the class viewer, even if they're namespaces, classes, methods, or
68   even variables.
69 - Code Completion With the .NET and Gtk# frameworks put together, it
70   can be challenging to remember all the classes, methods, or properties
71   that are at your disposal. MonoDevelop's intelligent code completion
72   attempts to complete what you're typing. If it finds a match, just hit
73   tab and MonoDevelop will do the typing for you.
74 - Project Support MonoDevelop comes with built in projects that help
75   get you started with your console, Gnome# or Gtk# application.
76
77 %description -l pl.UTF-8
78 MonoDevelop to IDE (zintegrowane środowisko programisty) dla Mono we
79 wczesnym, ale szybko postępującym stadium rozwoju. Ma wiele
80 możliwości, a wśród nich:
81 - zarządzanie klasami MonoDevelop ma przeglądarkę klas pozwalającą
82   wyświetlać klasy w projekcie, ich metody oraz własności. Przestrzenie
83   nazw są uwzględniane, aby zachować separację klas. Przy dodawaniu
84   czegoś do projektu jest to automatycznie dodawane do przeglądarki
85   klas, nawet jeśli są to przestrzenie nazw, klasy, metody, a nawet
86   zmienne.
87 - dopełnianie kodu Przy połączeniu szkieletów .NET i Gtk# pamiętanie
88   samemu wszystkich klas, metod i własności mogłoby być nie lada
89   wyzwaniem. MonoDevelop w sposób inteligentny próbuje dopełniać to, co
90   się pisze. Jeśli znajdzie dopasowanie, wystarczy nacisnąć tabulację,
91   aby dokończył pisać za nas.
92 - obsługa projektów MonoDevelop przychodzi z wbudowanymi projektami,
93   pomagającymi zacząć tworzyć aplikacje konsolowe, Gnome# albo Gtk#.
94
95 %prep
96 %setup -q -n monodevelop-5.10
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p1
103
104 %{__sed} -i -e 's,\.\./version\.config,version.config,' configure.in
105 # bash is needed because of exec -a; avoid hiding dependency by env
106 %{__sed} -i -e '1s,#!/usr/bin/env bash,#!/bin/bash,' mdtool.in monodevelop.in
107
108 # fake target
109 touch restore-packages
110
111 %build
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --disable-update-mimedb \
117         --disable-update-desktopdb \
118         %{?with_subversion:--enable-subversion}
119
120 cd external/libgit2sharp/Lib/CustomBuildTasks
121 xbuild CustomBuildTasks.csproj /property:Configuration=Release
122 ln -snf bin/Release/CustomBuildTasks.dll .
123 cd ../../../..
124
125 %{__make} -j1
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %if "%{_lib}" != "lib"
135 %{__mv} -f $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_pkgconfigdir}
136 %endif
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_desktop_database_post
145 %update_mime_database
146 %update_icon_cache hicolor
147
148 %postun
149 %update_desktop_database_postun
150 %update_mime_database
151 %update_icon_cache hicolor
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog README
156 %attr(755,root,root) %{_bindir}/mdtool
157 %attr(755,root,root) %{_bindir}/monodevelop
158 %{_prefix}/lib/monodevelop
159 %{_datadir}/mime/packages/monodevelop.xml
160 %{_desktopdir}/monodevelop.desktop
161 %{_pkgconfigdir}/monodevelop-core-addins.pc
162 %{_pkgconfigdir}/monodevelop.pc
163 %{_iconsdir}/hicolor/*x*/apps/monodevelop.png
164 %{_iconsdir}/hicolor/scalable/apps/monodevelop.svg
165 %{_mandir}/man1/mdtool.1*
166 %{_mandir}/man1/monodevelop.1*
This page took 0.090325 seconds and 2 git commands to generate.