]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
d161b1872b756c3d0e15fcb99cc599217a5fa55b
[packages/monodevelop.git] / monodevelop.spec
1 #
2 # Conditional build:
3 %bcond_without  subversion      # disable subversion backend
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 Summary:        Mono IDE
8 Summary(pl.UTF-8):      IDE dla Mono
9 Name:           monodevelop
10 %define mainver 5.0.1
11 %define subver  0
12 Version:        %{mainver}.%{subver}
13 Release:        1
14 # most of code is MIT-licensed, some parts LGPL v2
15 License:        LGPL v2, MIT
16 Group:          Development/Tools
17 Source0:        http://download.mono-project.com/sources/monodevelop/%{name}-%{mainver}-%{subver}.tar.bz2
18 # Source0-md5:  5f68aa384c7aa473fdd36da2f70117b4
19 Patch0:         %{name}-desktop.patch
20 URL:            http://monodevelop.com/
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.10
23 # gconf-sharp, gnome-sharp, gnome-vfs-sharp
24 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.8
26 BuildRequires:  gettext-tools
27 BuildRequires:  mono-csharp >= 3.0.4
28 BuildRequires:  monodoc >= 1.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.311
31 BuildRequires:  sed >= 4.0
32 Requires(post,postun):  desktop-file-utils
33 Requires(post,postun):  gtk-update-icon-cache
34 Requires(post,postun):  hicolor-icon-theme
35 Requires(post,postun):  shared-mime-info
36 Requires:       dotnet-gtk-sharp2 >= 2.12.8
37 Requires:       hicolor-icon-theme
38 Requires:       pkgconfig
39 %{?with_subversion:Requires:    subversion-libs}
40 Requires:       xulrunner-libs
41 Suggests:       ctags
42 Suggests:       mono-compat-links >= 3.0.4
43 Suggests:       mono-csharp >= 3.0.4
44 Suggests:       monodoc >= 1.0
45 Suggests:       xsp
46 Obsoletes:      MonoDevelop
47 ExcludeArch:    alpha i386 sparc sparc64
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _noautoreq      'mono\\(System.Data.Entity\\)' 'mono\\(System.Web.WebPages.Deployment\\)'
51
52 %description
53 Mono IDE, in the very early stages of development right now, and
54 progressing quickly. MonoDevelop has many features. Some of these
55 include:
56 - Class Management MonoDevelop has a class viewer which allows you to
57   list the classes in your project, their methods, and properties. Your
58   namespaces are also kept track of to keep the classes separated. When
59   you add something to your project, it will automatically be added to
60   the class viewer, even if they're namespaces, classes, methods, or
61   even variables.
62 - Code Completion With the .NET and Gtk# frameworks put together, it
63   can be challenging to remember all the classes, methods, or properties
64   that are at your disposal. MonoDevelop's intelligent code completion
65   attempts to complete what you're typing. If it finds a match, just hit
66   tab and MonoDevelop will do the typing for you.
67 - Project Support MonoDevelop comes with built in projects that help
68   get you started with your console, Gnome# or Gtk# application.
69
70 %description -l pl.UTF-8
71 MonoDevelop to IDE (zintegrowane środowisko programisty) dla Mono we
72 wczesnym, ale szybko postępującym stadium rozwoju. Ma wiele
73 możliwości, a wśród nich:
74 - zarządzanie klasami MonoDevelop ma przeglądarkę klas pozwalającą
75   wyświetlać klasy w projekcie, ich metody oraz własności. Przestrzenie
76   nazw są uwzględniane, aby zachować separację klas. Przy dodawaniu
77   czegoś do projektu jest to automatycznie dodawane do przeglądarki
78   klas, nawet jeśli są to przestrzenie nazw, klasy, metody, a nawet
79   zmienne.
80 - dopełnianie kodu Przy połączeniu szkieletów .NET i Gtk# pamiętanie
81   samemu wszystkich klas, metod i własności mogłoby być nie lada
82   wyzwaniem. MonoDevelop w sposób inteligentny próbuje dopełniać to, co
83   się pisze. Jeśli znajdzie dopasowanie, wystarczy nacisnąć tabulację,
84   aby dokończył pisać za nas.
85 - obsługa projektów MonoDevelop przychodzi z wbudowanymi projektami,
86   pomagającymi zacząć tworzyć aplikacje konsolowe, Gnome# albo Gtk#.
87
88 %prep
89 %setup -q -n %{name}-%{mainver}
90 %patch0 -p1
91
92 %{__sed} -i -e 's,\.\./version\.config,version.config,' configure.in
93 # bash is needed because of exec -a; avoid hiding dependency by env
94 %{__sed} -i -e '1s,#!/usr/bin/env bash,#!/bin/bash,' mdtool.in monodevelop.in
95
96 %build
97 %{__aclocal}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --disable-update-mimedb \
102         --disable-update-desktopdb \
103         %{?with_subversion:--enable-subversion}
104
105 %{__make} -j1
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %if "%{_lib}" != "lib"
115 %{__mv} -f $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_pkgconfigdir}
116 %endif
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 %update_desktop_database_post
125 %update_mime_database
126 %update_icon_cache hicolor
127
128 %postun
129 %update_desktop_database_postun
130 %update_mime_database
131 %update_icon_cache hicolor
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog README
136 %attr(755,root,root) %{_bindir}/mdtool
137 %attr(755,root,root) %{_bindir}/monodevelop
138 %{_prefix}/lib/monodevelop
139 %{_datadir}/mime/packages/monodevelop.xml
140 %{_desktopdir}/monodevelop.desktop
141 %{_pkgconfigdir}/monodevelop-core-addins.pc
142 %{_pkgconfigdir}/monodevelop.pc
143 %{_iconsdir}/hicolor/*/apps/monodevelop.png
144 %{_iconsdir}/hicolor/*/apps/monodevelop.svg
145 %{_mandir}/man1/mdtool.1*
146 %{_mandir}/man1/monodevelop.1*
This page took 0.379774 seconds and 2 git commands to generate.