]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
cd56d8fb8dac5add7ad31a2362164cd529d8ed11
[packages/monodevelop.git] / monodevelop.spec
1 # TODO: use system libgit2, libgit2sharp, nunit, mono-addins
2 #
3 # Conditional build:
4 %bcond_without  subversion      # disable subversion backend
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 Summary:        Mono IDE
9 Summary(pl.UTF-8):      IDE dla Mono
10 Name:           monodevelop
11 Version:        5.10.0.871
12 Release:        2
13 # most of code is MIT-licensed, some parts LGPL v2
14 License:        LGPL v2, MIT
15 Group:          Development/Tools
16 Source0:        http://download.mono-project.com/sources/monodevelop/%{name}-%{version}.tar.bz2
17 # Source0-md5:  4722cbbaeb7a518dceea8147e6cb6181
18 Patch0:         %{name}-desktop.patch
19 Patch1:         %{name}-aspnet.patch
20 Patch2:         %{name}-nunit.patch
21 Patch3:         %{name}-avoidgiterrors.patch
22 Patch4:         %{name}-nuget-unbundle.patch
23 Patch5:         %{name}-no-nuget-packages.patch
24 Patch6:         %{name}-json.patch
25 URL:            http://monodevelop.com/
26 BuildRequires:  autoconf >= 2.53
27 BuildRequires:  automake >= 1:1.10
28 # gconf-sharp, gnome-sharp, gnome-vfs-sharp
29 BuildRequires:  dotnet-gconf-sharp-devel
30 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
31 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.8
32 BuildRequires:  dotnet-newtonsoft-json-devel >= 6.0
33 BuildRequires:  dotnet-nuget-devel
34 BuildRequires:  dotnet-nunit2 >= 2.6.4
35 BuildRequires:  gettext-tools
36 BuildRequires:  mono-csharp >= 3.0.4
37 BuildRequires:  monodoc >= 1.0
38 BuildRequires:  pkgconfig
39 BuildRequires:  rpmbuild(macros) >= 1.311
40 BuildRequires:  sed >= 4.0
41 Requires(post,postun):  desktop-file-utils
42 Requires(post,postun):  gtk-update-icon-cache
43 Requires(post,postun):  hicolor-icon-theme
44 Requires(post,postun):  shared-mime-info
45 Requires:       dotnet-gtk-sharp2 >= 2.12.8
46 Requires:       hicolor-icon-theme
47 Requires:       pkgconfig
48 %{?with_subversion:Requires:    subversion-libs}
49 Requires:       xulrunner-libs
50 Suggests:       ctags
51 Suggests:       mono-compat-links >= 3.0.4
52 Suggests:       mono-csharp >= 3.0.4
53 Suggests:       monodoc >= 1.0
54 Suggests:       xsp
55 Obsoletes:      MonoDevelop
56 ExcludeArch:    alpha i386 sparc sparc64
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _noautoreq      'mono\\(System.Data.Entity\\)' 'mono\\(System.Web.WebPages.Deployment\\)'
60
61 %description
62 Mono IDE, in the very early stages of development right now, and
63 progressing quickly. MonoDevelop has many features. Some of these
64 include:
65 - Class Management MonoDevelop has a class viewer which allows you to
66   list the classes in your project, their methods, and properties. Your
67   namespaces are also kept track of to keep the classes separated. When
68   you add something to your project, it will automatically be added to
69   the class viewer, even if they're namespaces, classes, methods, or
70   even variables.
71 - Code Completion With the .NET and Gtk# frameworks put together, it
72   can be challenging to remember all the classes, methods, or properties
73   that are at your disposal. MonoDevelop's intelligent code completion
74   attempts to complete what you're typing. If it finds a match, just hit
75   tab and MonoDevelop will do the typing for you.
76 - Project Support MonoDevelop comes with built in projects that help
77   get you started with your console, Gnome# or Gtk# application.
78
79 %description -l pl.UTF-8
80 MonoDevelop to IDE (zintegrowane środowisko programisty) dla Mono we
81 wczesnym, ale szybko postępującym stadium rozwoju. Ma wiele
82 możliwości, a wśród nich:
83 - zarządzanie klasami MonoDevelop ma przeglądarkę klas pozwalającą
84   wyświetlać klasy w projekcie, ich metody oraz własności. Przestrzenie
85   nazw są uwzględniane, aby zachować separację klas. Przy dodawaniu
86   czegoś do projektu jest to automatycznie dodawane do przeglądarki
87   klas, nawet jeśli są to przestrzenie nazw, klasy, metody, a nawet
88   zmienne.
89 - dopełnianie kodu Przy połączeniu szkieletów .NET i Gtk# pamiętanie
90   samemu wszystkich klas, metod i własności mogłoby być nie lada
91   wyzwaniem. MonoDevelop w sposób inteligentny próbuje dopełniać to, co
92   się pisze. Jeśli znajdzie dopasowanie, wystarczy nacisnąć tabulację,
93   aby dokończył pisać za nas.
94 - obsługa projektów MonoDevelop przychodzi z wbudowanymi projektami,
95   pomagającymi zacząć tworzyć aplikacje konsolowe, Gnome# albo Gtk#.
96
97 %prep
98 %setup -q -n monodevelop-5.10
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103 %patch4 -p1
104 %patch5 -p1
105 %patch6 -p1
106
107 %{__sed} -i -e 's,\.\./version\.config,version.config,' configure.in
108 # bash is needed because of exec -a; avoid hiding dependency by env
109 %{__sed} -i -e '1s,#!/usr/bin/env bash,#!/bin/bash,' mdtool.in monodevelop.in
110
111 # fake target
112 touch restore-packages
113
114 %build
115 %{__aclocal}
116 %{__autoconf}
117 %{__automake}
118 %configure \
119         --disable-update-mimedb \
120         --disable-update-desktopdb \
121         %{?with_subversion:--enable-subversion}
122
123 cd external/libgit2sharp/Lib/CustomBuildTasks
124 xbuild CustomBuildTasks.csproj /property:Configuration=Release
125 ln -snf bin/Release/CustomBuildTasks.dll .
126 cd ../../../..
127
128 %{__make} -j1
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %if "%{_lib}" != "lib"
138 %{__mv} -f $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_pkgconfigdir}
139 %endif
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 %update_desktop_database_post
148 %update_mime_database
149 %update_icon_cache hicolor
150
151 %postun
152 %update_desktop_database_postun
153 %update_mime_database
154 %update_icon_cache hicolor
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog README
159 %attr(755,root,root) %{_bindir}/mdtool
160 %attr(755,root,root) %{_bindir}/monodevelop
161 %{_prefix}/lib/monodevelop
162 %{_datadir}/mime/packages/monodevelop.xml
163 %{_desktopdir}/monodevelop.desktop
164 %{_pkgconfigdir}/monodevelop-core-addins.pc
165 %{_pkgconfigdir}/monodevelop.pc
166 %{_iconsdir}/hicolor/*x*/apps/monodevelop.png
167 %{_iconsdir}/hicolor/scalable/apps/monodevelop.svg
168 %{_mandir}/man1/mdtool.1*
169 %{_mandir}/man1/monodevelop.1*
This page took 0.079074 seconds and 2 git commands to generate.