]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
- added patch update-mime-database
[packages/monodevelop.git] / monodevelop.spec
1 %define         monoversion     1.1.5
2 Summary:        Mono IDE
3 Summary(pl):    IDE dla Mono
4 Name:           monodevelop
5 Version:        0.6
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://mono2.ximian.com/archive/%{monoversion}/%{name}-%{version}.tar.gz
10 # Source0-md5:  0cf7524360913394ea7fa1bc434b7f0c
11 Patch0:         %{name}-MOZILLA_FIVE_HOME.patch
12 Patch1:         %{name}-locale_names.patch
13 #Patch2:                %{name}-libdir.patch
14 Patch3:         %{name}-desktop.patch
15 Patch4:         %{name}-install.patch
16 URL:            http://www.monodevelop.com/
17 BuildRequires:  ORBit2-devel >= 2.8.3
18 BuildRequires:  autoconf
19 BuildRequires:  automake >= 1:1.7
20 BuildRequires:  dotnet-gecko-sharp-devel >= 0.7
21 BuildRequires:  dotnet-gtk-sharp-devel >= 1.9.2
22 BuildRequires:  dotnet-gtksourceview-sharp-devel >= 0.7
23 BuildRequires:  intltool
24 BuildRequires:  libtool
25 BuildRequires:  mono-csharp >= 1.1
26 BuildRequires:  monodoc >= 1.0
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  shared-mime-info
29 Requires:       mono
30 Requires:       monodoc
31 Requires:       mozilla-embedded
32 Requires:       dotnet-gtksourceview-sharp
33 Requires:       dotnet-gecko-sharp
34 Requires:       dotnet-gtk-sharp
35 Requires(post,postun):  shared-mime-info
36 Obsoletes:      MonoDevelop
37 ExcludeArch:    alpha
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Mono IDE, in the very early stages of development right now, and
42 progressing quickly. MonoDevelop has many features. Some of these
43 include:
44 - Class Management
45   MonoDevelop has a class viewer which allows you to list the classes
46   in your project, their methods, and properties. Your namespaces are
47   also kept track of to keep the classes separated. When you add
48   something to your project, it will automatically be added to the
49   class viewer, even if they're namespaces, classes, methods, or even
50   variables.
51 - Code Completion
52   With the .NET and Gtk# frameworks put together, it can be
53   challenging to remember all the classes, methods, or properties that
54   are at your disposal. MonoDevelop's intelligent code completion
55   attempts to complete what you're typing. If it finds a match, just
56   hit tab and MonoDevelop will do the typing for you.
57 - Project Support
58   MonoDevelop comes with built in projects that help get you started
59   with your console, Gnome# or Gtk# application.
60
61 %description -l pl
62 MonoDevelop to IDE (zintegrowane ¶rodowisko programisty) dla Mono we
63 wczesnym, ale szybko postêpuj±cym stadium rozwoju. Ma wiele
64 mo¿liwo¶ci, a w¶ród nich:
65 - zarz±dzanie klasami
66   MonoDevelop ma przegl±darkê klas pozwalaj±c± wy¶wietlaæ klasy w
67   projekcie, ich metody oraz w³asno¶ci. Przestrzenie nazw s±
68   uwzglêdniane, aby zachowaæ separacjê klas. Przy dodawaniu czego¶ do
69   projektu jest to automatycznie dodawane do przegl±darki klas, nawet
70   je¶li s± to przestrzenie nazw, klasy, metody, a nawet zmienne.
71 - dope³nianie kodu
72   Przy po³±czeniu szkieletów .NET i Gtk# pamiêtanie samemu wszystkich
73   klas, metod i w³asno¶ci mog³oby byæ nie lada wyzwaniem. MonoDevelop
74   w sposób inteligentny próbuje dope³niaæ to, co siê pisze. Je¶li
75   znajdzie dopasowanie, wystarczy nacisn±æ tabulacjê, aby dokoñczy³
76   pisaæ za nas.
77 - obs³uga projektów
78   MonoDevelop przychodzi z wbudowanymi projektami, pomagaj±cymi zacz±æ
79   tworzyæ aplikacje konsolowe, Gnome# albo Gtk#.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 #%patch2 -p1
86 %patch3 -p1
87 %patch4 -p1
88 # ignore errors from it
89 #sed -e 's/update-mime-database/-&/' -i Makefile.am
90
91 mv po/ja{_JP,}.po
92
93 %build
94 rm -rf autom4te.cache
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoheader}
98 %{__automake}
99 %{__autoconf}
100 %configure
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %find_lang %{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 update-mime-database %{_datadir}/mime ||:
116
117 %postun
118 update-mime-database %{_datadir}/mime
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc README
123 %attr(755,root,root) %{_bindir}/*
124 %{_libdir}/%{name}
125 %{_datadir}/mime/packages/*
126 %{_desktopdir}/*
127 %{_pixmapsdir}/*
This page took 0.041884 seconds and 3 git commands to generate.