]> git.pld-linux.org Git - packages/mono.git/blob - mono.spec
- 1.1.13
[packages/mono.git] / mono.spec
1 # NOTE: Makefiles are broken, build could stop long time after first fatal error
2 #
3 # Conditional build:
4 %bcond_without  tls             # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
5 %bcond_without  static_libs     # don't build static libraries
6 %bcond_with     bootstrap       # don't require mono-devel to find req/prov
7 %bcond_with     mint            # build mint instead of mono VM (JIT)
8 #
9 %ifnarch %{ix86} %{x8664} sparc sparcv9 sparc64 ppc s390 s390x
10 # JIT not supported on alpha,arm,hppa
11 %define         with_mint       1
12 %endif
13 %define         _glibver        2.4
14 #
15 Summary:        Common Language Infrastructure implementation
16 Summary(pl):    Implementacja Common Language Infrastructure
17 Name:           mono
18 Version:        1.1.13
19 Release:        1
20 License:        GPL/LGPL/MIT
21 Group:          Development/Languages
22 #Source0Download: http://go-mono.com/sources/
23 Source0:        http://www.go-mono.com/sources/mono-1.1/%{name}-%{version}.tar.gz
24 # Source0-md5:  37fe3f191321ab7c426d57d0e1581bfe
25 Patch0:         %{name}-nolibs.patch
26 Patch1:         %{name}-alpha-float.patch
27 Patch2:         %{name}-mint.patch
28 Patch3:         %{name}-sonames.patch
29 Patch4:         %{name}-alpha-atomic.patch
30 Patch5:         %{name}-sparc-exception.patch
31 Patch6:         %{name}-alpha-tls.patch
32 URL:            http://www.mono-project.com/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  glib2-devel >= %{_glibver}
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 BuildRequires:  rpmbuild(macros) >= 1.213
40 BuildRequires:  rpmbuild(monoautodeps)
41 %{!?with_bootstrap:BuildRequires:       mono-devel >= 1.1.8.3-2}
42 ExclusiveArch:  %{ix86} %{x8664} arm hppa ppc s390 s390x
43 # sparc sparcv9 sparc64 not ported to linux (only solaris(?))
44 # alpha still broken, mips/ia64/m68k disabled in configure
45 # plain i386 is not supported; mono uses cmpxchg/xadd which require i486
46 ExcludeArch:    i386
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _rpmlibdir      /usr/lib/rpm
50
51 %if ! %{with bootstrap}
52 %define __mono_provides %{_rpmlibdir}/mono-find-provides
53 %define __mono_requires %{_rpmlibdir}/mono-find-requires
54 %endif
55
56 %description
57 The Common Language Infrastructure platform. Microsoft has created a
58 new development platform. The highlights of this new development
59 platform are:
60 - A runtime environment that provides garbage collection, threading
61   and a virtual machine specification (The Virtual Execution System,
62   VES),
63 - A comprehensive class library,
64 - A new language, C#. Very similar to Java, C# allows programmers to
65   use all the features available on the .NET runtime,
66 - A language specification that compilers can follow if they want to
67   generate classes and code that can interoperate with other programming
68   languages (The Common Language Specification: CLS).
69
70 %{?with_tls:This version was build with TLS __thread.}
71
72 %description -l pl
73 Platforma CLI (Common Language Infrastructure). Microsoft stworzy³
74 now± platformê developersk±. Zalety tej platformy to:
75 - ¶rodowisko, które dostarcza garbage collector, w±tki oraz
76   specyfikacjê maszyny wirtualnej (The Virtual Execution System, VES),
77 - bibliotekê klas,
78 - nowy jêzyk, C#. Bardzo podobny do Javy, C# pozwala programistom na
79   u¿ywanie wszystkich mo¿liwo¶ci dostarczanych przez platformê .NET,
80 - specyfikacja dla kompilatorów, które chc± generowaæ kod
81   wspó³pracuj±cy z innymi jêzykami programowania (The Common Language
82   Specification: CLS).
83
84 %{?with_tls:Ta wersja zosta³a zbudowana z TLS __thread.}
85
86 %package devel
87 Summary:        Development resources for mono
88 Summary(pl):    Zasoby programisty do mono
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       glib2-devel >= %{_glibver}
92
93 %description devel
94 Development resources for mono.
95
96 %description devel -l pl
97 Zasoby programisty dla mono.
98
99 %package basic
100 Summary:        MonoBASIC compiler for mono
101 Summary(pl):    Kompilator MonoBASIC dla mono
102 Group:          Development/Languages
103 Requires:       %{name}-devel = %{version}-%{release}
104
105 %description basic
106 MonoBASIC compiler for mono.
107
108 %description basic -l pl
109 Kompilator MonoBASIC dla mono.
110
111 %package csharp
112 Summary:        C# compiler for mono
113 Summary(pl):    Kompilator C# dla mono
114 Group:          Development/Languages
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description csharp
118 C# compiler for mono.
119
120 %description csharp -l pl
121 Kompilator C# dla mono.
122
123 %package ilasm
124 Summary:        ILasm compiler for mono
125 Summary(pl):    Kompilator ILasm dla mono
126 Group:          Development/Languages
127 Requires:       %{name}-devel = %{version}-%{release}
128 Provides:       ilasm
129 Obsoletes:      pnet-compiler-ilasm
130
131 %description ilasm
132 ILasm compiler for mono.
133
134 %description ilasm -l pl
135 Kompilator ILasm dla mono.
136
137 %package jscript
138 Summary:        jscript compiler for mono
139 Summary(pl):    Kompilator jscript dla mono
140 Group:          Development/Languages
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description jscript
144 jscript compiler for mono.
145
146 %description jscript -l pl
147 Kompilator jscript dla mono.
148
149 %package static
150 Summary:        Static mono library
151 Summary(pl):    Statyczna biblioteka mono
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154
155 %description static
156 Static mono library.
157
158 %description static -l pl
159 Statyczna biblioteka mono.
160
161 %package jay
162 Summary:        Yacc-like parser generator for Java and C#
163 Summary(pl):    Podobny do Yacca generator parserów dla Javy i C#
164 Group:          Development/Tools
165
166 %description jay
167 Yacc-like parser generator for Java and C#.
168
169 %description jay -l pl
170 Podobny do Yacca generator parserów dla Javy i C#.
171
172 %package compat-links
173 Summary:        Mono compatibility links
174 Summary(pl):    Dowi±zania dla kompatybilno¶ci
175 Group:          Development/Languages
176 Requires:       %{name}-devel = %{version}-%{release}
177
178 %description compat-links
179 This package contains links to binaries with names used in .NET and
180 dotGNU.
181
182 %description compat-links -l pl
183 Pakiet ten zawiera dowi±zania do programów o nazwach u¿ywanych w .NET
184 oraz dotGNU.
185
186 %prep
187 %setup -q
188 %patch0 -p1
189 %patch1 -p1
190 %patch2 -p1
191 %patch3 -p1
192 %patch4 -p1
193 %patch5 -p1
194 %patch6 -p1
195
196 # workaround for variable name disallowed by new pkgconfig
197 echo 'm4_pattern_allow(PKG_PATH)' > acinclude.m4
198
199 sed -i -e 's@a=`which "$0"`@a="/usr/bin/dupa"@' scripts/mono-find-provides.in
200 sed -i -e 's@a=`which "$0"`@a="/usr/bin/dupa"@' scripts/mono-find-requires.in
201
202 %build
203 cp -f /usr/share/automake/config.sub .
204 cp -f /usr/share/automake/config.sub libgc
205 %{__libtoolize}
206 %{__aclocal}
207 %{__autoheader}
208 %{__autoconf}
209 %{__automake}
210 cd libgc
211 %{__libtoolize}
212 %{__aclocal}
213 %{__autoconf}
214 %{__automake}
215 cd ..
216
217 CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS"
218 %configure \
219         %{!?with_static_libs:--disable-static} \
220         --enable-fast-install \
221         --with-gc=included \
222         --with-icu=no \
223         --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
224         --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
225         --with-preview=yes \
226         --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
227
228 # mint uses heap to make trampolines, which need to be executable
229 # there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
230 # (ifdef NEED_MPROTECT, which is never defined)
231 # in fact the flag should be "-Wl,-z,execheap" for libmint, but:
232 # -z execheap doesn't seem to do anything currently
233 # -z execstack for library makes only stack executable, but not heap
234 %{__make} \
235         mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239 install -d $RPM_BUILD_ROOT%{_rpmlibdir}
240
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT
243
244 rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
245
246 # this way we can run rpmbuild -bi several times, and directories
247 # have more meaningful name.
248 rm -rf pld-doc
249 mkdir -p pld-doc/{webpage,notes}
250 cp -a web/* pld-doc/webpage
251 cp -a docs/* pld-doc/notes
252 rm -f pld-doc/*/Makefile*
253
254 rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
255
256 mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find* $RPM_BUILD_ROOT%{_rpmlibdir}
257
258 %clean
259 rm -rf $RPM_BUILD_ROOT
260
261 %post   -p /sbin/ldconfig
262 %postun -p /sbin/ldconfig
263
264 %files
265 %defattr(644,root,root,755)
266 %doc AUTHORS ChangeLog NEWS README pld-doc/*
267 %if %{with mint}
268 %attr(755,root,root) %{_bindir}/mint
269 %else
270 %attr(755,root,root) %{_bindir}/mono
271 %endif
272 %attr(755,root,root) %{_bindir}/caspol
273 %attr(755,root,root) %{_bindir}/cert*
274 %attr(755,root,root) %{_bindir}/chktrust*
275 %attr(755,root,root) %{_bindir}/gacutil*
276 %attr(755,root,root) %{_bindir}/makecert*
277 %attr(755,root,root) %{_bindir}/mkbundle*
278 %attr(755,root,root) %{_bindir}/mono-service
279 %attr(755,root,root) %{_bindir}/mozroots
280 %attr(755,root,root) %{_bindir}/secutil*
281 %attr(755,root,root) %{_bindir}/setreg*
282 %attr(755,root,root) %{_bindir}/signcode*
283 %attr(755,root,root) %{_bindir}/sn*
284 %attr(755,root,root) %{_libdir}/lib*.so.*.*
285 %attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
286 %attr(755,root,root) %{_libdir}/libMonoSupportW.so
287 %attr(755,root,root) %{_libdir}/libikvm-native.so
288 %dir %{_prefix}/lib/mono
289 %dir %{_prefix}/lib/mono/1.0
290 %dir %{_prefix}/lib/mono/2.0
291 %attr(755,root,root) %{_prefix}/lib/mono/*.*/*.dll
292 %attr(755,root,root) %{_prefix}/lib/mono/1.0/cert*
293 %attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust*
294 %attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil*
295 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle*
296 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots*
297 %attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil*
298 %attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg*
299 %attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode*
300 %attr(755,root,root) %{_prefix}/lib/mono/1.0/sn*
301 %attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol*
302 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service*
303 %{_prefix}/lib/mono/gac
304 %{_mandir}/man1/cert*.1*
305 %{_mandir}/man1/chktrust.1*
306 %{_mandir}/man1/gacutil.1*
307 %{_mandir}/man1/makecert.1*
308 %{_mandir}/man1/mkbundle.1*
309 %{_mandir}/man1/mint.1*
310 %{_mandir}/man1/mono.1*
311 %{_mandir}/man1/mono-service.1*
312 %{_mandir}/man1/mozroots.1*
313 %{_mandir}/man1/secutil.1*
314 %{_mandir}/man1/setreg.1*
315 %{_mandir}/man1/signcode.1*
316 %{_mandir}/man1/sn.1*
317 %{_mandir}/man1/permview.1*
318 %{_mandir}/man5/mono-config.5*
319 %dir %{_sysconfdir}/mono
320 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
321 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
322 %dir %{_sysconfdir}/mono/1.0
323 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
324 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
325 %dir %{_sysconfdir}/mono/2.0
326 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
327 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
328
329 %exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
330 %exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
331 %exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
332
333 %files jay
334 %defattr(644,root,root,755)
335 %doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
336 %attr(755,root,root) %{_bindir}/jay
337 %dir %{_datadir}/jay
338 %{_datadir}/jay/skeleton*
339 %{_mandir}/man1/jay.1*
340
341 %files jscript
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_bindir}/mjs
344 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs*
345 %{_prefix}/lib/mono/gac/Microsoft.JScript
346 %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
347 %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
348
349 %files compat-links
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/resgen
352
353 %files devel
354 %defattr(644,root,root,755)
355 %attr(755,root,root) %{_bindir}/al*
356 %attr(755,root,root) %{_bindir}/cilc*
357 %attr(755,root,root) %{_bindir}/disco*
358 %attr(755,root,root) %{_bindir}/dtd2xsd
359 %attr(755,root,root) %{_bindir}/genxs*
360 %attr(755,root,root) %{_bindir}/macpack
361 %attr(755,root,root) %{_bindir}/monodiet
362 %attr(755,root,root) %{_bindir}/monodis
363 %attr(755,root,root) %{_bindir}/monograph
364 %attr(755,root,root) %{_bindir}/monop*
365 %attr(755,root,root) %{_bindir}/mono-shlib-cop*
366 %attr(755,root,root) %{_bindir}/nunit-console
367 %attr(755,root,root) %{_bindir}/pedump
368 %attr(755,root,root) %{_bindir}/permview
369 %attr(755,root,root) %{_bindir}/prj2make
370 %attr(755,root,root) %{_bindir}/soapsuds*
371 %attr(755,root,root) %{_bindir}/sqlsharp*
372 %attr(755,root,root) %{_bindir}/wsdl*
373 %attr(755,root,root) %{_bindir}/xbuild
374 %attr(755,root,root) %{_bindir}/xsd*
375 %if %{with mint}
376 %attr(755,root,root) %{_libdir}/libmint.so
377 %else
378 %attr(755,root,root) %{_libdir}/libmono.so
379 %attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
380 %endif
381 %{_libdir}/lib*.la
382 %attr(755,root,root) %{_prefix}/lib/mono/1.0/al*
383 %attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater*
384 %attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc*
385 %attr(755,root,root) %{_prefix}/lib/mono/1.0/CorCompare*
386 %attr(755,root,root) %{_prefix}/lib/mono/1.0/disco*
387 %attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd*
388 %attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs*
389 %attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool*
390 %attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack*
391 %attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert*
392 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-api-*
393 %attr(755,root,root) %{_prefix}/lib/mono/1.0/monop*
394 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-shlib-cop*
395 %attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console*
396 %attr(755,root,root) %{_prefix}/lib/mono/1.0/permview*
397 %attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make*
398 %attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen*
399 %attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds*
400 %attr(755,root,root) %{_prefix}/lib/mono/1.0/sqlsharp*
401 %attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl*
402 %attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd*
403 %attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info*
404 %attr(755,root,root) %{_prefix}/lib/mono/2.0/monop*
405 %attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console*
406 %attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl*
407 %attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild*
408 %{_prefix}/lib/mono/*.*/*.dll.mdb
409 %{_prefix}/lib/mono/xbuild
410 %attr(755,root,root) %{_rpmlibdir}/mono-find*
411 %{_datadir}/%{name}
412 %{_pkgconfigdir}/*.pc
413 %{_includedir}/%{name}
414 %{_mandir}/man1/al.1*
415 %{_mandir}/man1/cilc.1*
416 %{_mandir}/man1/disco.1*
417 %{_mandir}/man1/dtd2xsd.1*
418 %{_mandir}/man1/genxs.1*
419 %{_mandir}/man1/macpack.1*
420 %{_mandir}/man1/monoburg.1*
421 %{_mandir}/man1/monodis.1*
422 %{_mandir}/man1/monop.1*
423 %{_mandir}/man1/mono-shlib-cop.1*
424 %{_mandir}/man1/monostyle.1*
425 %{_mandir}/man1/oldmono.1*
426 %{_mandir}/man1/prj2make.1*
427 %{_mandir}/man1/soapsuds.1*
428 %{_mandir}/man1/sqlsharp.1*
429 %{_mandir}/man1/wsdl.1*
430 %{_mandir}/man1/xsd.1*
431
432 %files csharp
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_bindir}/mcs
435 %attr(755,root,root) %{_bindir}/gmcs
436 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe*
437 %attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe*
438 %{_mandir}/man1/mcs.1*
439
440 %files basic
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_bindir}/mbas
443 %attr(755,root,root) %{_prefix}/lib/mono/1.0/mbas.exe*
444
445 %files ilasm
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_bindir}/ilasm*
448 %attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm*
449 %attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm*
450 %{_mandir}/man1/ilasm.1*
451
452 %if %{with static_libs}
453 %files static
454 %defattr(644,root,root,755)
455 %{_libdir}/lib*.a
456 %endif
This page took 0.055593 seconds and 4 git commands to generate.