]> git.pld-linux.org Git - packages/mma.git/blob - mma.spec
9b417ecfc18105e11918b4994b450513d17759c5
[packages/mma.git] / mma.spec
1 Summary:        MMA - Musical MIDI Accompaniment
2 Name:           mma
3 Version:        16.06
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://www.mellowood.ca/mma/%{name}-bin-%{version}.tar.gz
8 # Source0-md5:  a7e34ec1b9c2ffc36f408314bb184615
9 URL:            http://www.mellowood.ca/mma/downloads.html
10 BuildRequires:  python3-modules
11 BuildRequires:  rpmbuild(macros) >= 1.714
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  sed >= 4.0
14 Requires:       python3-modules
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 MMA — Musical MIDI Accompaniment is an accompaniment generator. It
20 creates MIDI tracks for a soloist to perform over from a user supplied
21 file containing chords and MMA directives.
22
23 MMA is very versatile and generates excellent tracks. It comes with an
24 extensive user-extendable library with a variety of patterns for
25 various popular rhythms, detailed user manuals, and several demo
26 songs.
27
28 MMA is a command line driven program. It creates MIDI files which are
29 then played by a sequencer or MIDI file play program.
30
31 %prep
32 %setup -q -n %{name}-bin-%{version}
33
34 # force our Python 3 for scripts
35 %{__sed} -i -e '1s,^#!.*python,#!%{__python3},' mma.py mma-* util/*.py
36
37 # remove files compiled upstream
38 find . -name '*.py[co]' | xargs rm
39
40 %build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 install -d $RPM_BUILD_ROOT{%{_datadir}/mma,%{_bindir},%{_mandir}/man{1,8}/*,%{_examplesdir}}
46
47 cp -p mma.py mma-* $RPM_BUILD_ROOT%{_datadir}/mma
48 cp -a MMA includes lib plugins util $RPM_BUILD_ROOT%{_datadir}/mma
49
50 ln -sf %{_datadir}/mma/mma.py $RPM_BUILD_ROOT%{_bindir}/mma
51 for n in gb libdoc renum splitrec ; do
52     ln -sf %{_datadir}/mma/mma-$n $RPM_BUILD_ROOT%{_bindir}
53 done
54
55 cp -a egs $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 ln -s %{_examplesdir}/%{name}-%{version} $RPM_BUILD_ROOT%{_datadir}/mma/egs
57
58 cp -a docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
59 cp -a docs/man/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
60
61 rm $RPM_BUILD_ROOT%{_datadir}/mma/util/README.*
62
63 %py3_comp $RPM_BUILD_ROOT%{_datadir}/mma/MMA
64 %py3_comp $RPM_BUILD_ROOT%{_datadir}/mma/plugins
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %{_bindir}/mma -G || :
71
72 %files
73 %defattr(644,root,root,755)
74 %doc docs/html/{chords,lib,logo.png,mma.html,plugins,ref,tut,tut-french}
75 %doc text/* util/README.*
76 %attr(755,root,root) %{_bindir}/mma
77 %attr(755,root,root) %{_bindir}/mma-*
78 %dir %{_datadir}/mma
79 %attr(755,root,root) %{_datadir}/mma/mma.py
80 %attr(755,root,root) %{_datadir}/mma/mma-*
81 %dir %{_datadir}/mma/util
82 %attr(755,root,root) %{_datadir}/mma/util/*.py
83 %{_datadir}/mma/egs
84 %{_datadir}/mma/includes
85 %{_datadir}/mma/lib
86 %{_datadir}/mma/MMA
87 %{_datadir}/mma/plugins
88 %{_mandir}/man1/*.1*
89 %{_mandir}/man8/*.8*
90 %{_examplesdir}/%{name}-%{version}
This page took 0.060628 seconds and 2 git commands to generate.