]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
- release 3
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #
6 Summary:        MLT - open source multimedia framework
7 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
8 Name:           mlt
9 Version:        0.5.2
10 Release:        3
11 License:        GPL
12 Group:          X11/Applications/Multimedia
13 Source0:        http://dl.sourceforge.net/mlt/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d556b11710fc24801e06b893ac5d61b
15 URL:            http://www.mltframework.org/
16 Patch1:         %{name}-linuxppc.patch
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtSvg-devel
19 BuildRequires:  QtXml-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  ffmpeg-devel
22 BuildRequires:  gtk+2-devel
23 #BuildRequires: ladspa-devel
24 #BuildRequires: lame-libs-devel
25 BuildRequires:  libdv-devel >= 0.102
26 #BuildRequires: libmad-devel
27 BuildRequires:  libquicktime-devel
28 BuildRequires:  libsamplerate-devel
29 BuildRequires:  libvorbis-devel >= 1:1.0.1
30 BuildRequires:  libxml2-devel >= 2.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  sox-devel
35 BuildRequires:  swig-python
36 BuildRequires:  which
37 Obsoletes:      mlt++ < %{version}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 MLT is an open source multimedia framework, designed and developed for
42 television broadcasting. It provides a toolkit for broadcasters, video
43 editors, media players, transcoders, web streamers and many more types
44 of applications. The functionality of the system is provided via an
45 assortment of ready to use tools, XML authoring components, and an
46 extendible plug-in based API.
47
48 %description -l pl.UTF-8
49 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
50 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
51 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
52 do udostępniania strumieni przez WWW i wiele innych rodzajów
53 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
54 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
55 rozszerzalne API oparte na wtyczkach.
56
57 %package -n python-mlt
58 Summary:        MLT Python bindings
59 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
60 Group:          Development/Languages/Python
61 Requires:       %{name} = %{version}-%{release}
62
63 %description -n python-mlt
64 Python bindings for MLT - open source multimedia framework.
65
66 %package devel
67 Summary:        Header files for MLT
68 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Obsoletes:      mlt++-devel < %{version}
72
73 %description devel
74 This package contains header files for MLT.
75
76 %description devel -l pl.UTF-8
77 Ten pakiet zawiera pliki nagłówkowe dla MLT.
78
79 %prep
80 %setup -q
81
82 %ifarch ppc ppc64
83 %patch1 -p1
84 %endif
85
86 %build
87 %configure \
88         --enable-gpl \
89 %ifarch %{x8664}
90         --disable-motion-est \
91 %else
92         --enable-motion-est \
93 %endif
94         --disable-debug \
95 %ifarch i586 i686 %{x8664}
96         --disable-mmx \
97 %else
98         --enable-mmx \
99 %endif
100         --disable-sse2 \
101         --avformat-swscale \
102         --qimage-includedir=%{_includedir}/qt \
103         --qimage-libdir=%{_libdir} \
104         --swig-languages=python
105
106 %{__make} \
107         CC="%{__cc}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{py_sitedir}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
117
118 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
119 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
120 %py_postclean
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc ChangeLog README
131 %attr(755,root,root) %{_bindir}/*
132 %attr(755,root,root) %ghost %{_libdir}/*.so.?
133 %attr(755,root,root) %{_libdir}/*.so.*.*
134 %dir %{_libdir}/%{name}
135 %attr(755,root,root) %{_libdir}/%{name}/*
136 %{_datadir}/mlt*
137
138 %files -n python-%{name}
139 %defattr(644,root,root,755)
140 %{py_sitedir}/*.py[co]
141 %attr(755,root,root) %{py_sitedir}/*.so
142
143 %files devel
144 %defattr(644,root,root,755)
145 %{_pkgconfigdir}/*.pc
146 %{_includedir}/mlt*
147 %{_libdir}/*.so
This page took 0.07411 seconds and 4 git commands to generate.