]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
e97c13bf3e482001558f73b22f232a7258d469a6
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #
6 Summary:        MLT - open source multimedia framework
7 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
8 Name:           mlt
9 Version:        0.8.2
10 Release:        2
11 License:        GPL
12 Group:          X11/Applications/Multimedia
13 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
14 # Source0-md5:  c7a8c4ca7485bb615cbcf851d8742a1c
15 URL:            http://www.mltframework.org/
16 Patch0:         %{name}-linuxppc.patch
17 Patch1:         ffmpeg10.patch
18 BuildRequires:  QtGui-devel
19 BuildRequires:  QtSvg-devel
20 BuildRequires:  QtXml-devel
21 BuildRequires:  SDL-devel
22 BuildRequires:  ffmpeg-devel
23 BuildRequires:  gtk+2-devel
24 #BuildRequires: ladspa-devel
25 #BuildRequires: lame-libs-devel
26 BuildRequires:  libdv-devel >= 0.102
27 #BuildRequires: libmad-devel
28 BuildRequires:  libquicktime-devel
29 BuildRequires:  libsamplerate-devel
30 BuildRequires:  libvorbis-devel >= 1:1.0.1
31 BuildRequires:  libxml2-devel >= 2.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  sox-devel
36 BuildRequires:  swig-python
37 BuildRequires:  which
38 Obsoletes:      mlt++ < %{version}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 MLT is an open source multimedia framework, designed and developed for
43 television broadcasting. It provides a toolkit for broadcasters, video
44 editors, media players, transcoders, web streamers and many more types
45 of applications. The functionality of the system is provided via an
46 assortment of ready to use tools, XML authoring components, and an
47 extendible plug-in based API.
48
49 %description -l pl.UTF-8
50 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
51 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
52 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
53 do udostępniania strumieni przez WWW i wiele innych rodzajów
54 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
55 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
56 rozszerzalne API oparte na wtyczkach.
57
58 %package -n python-mlt
59 Summary:        MLT Python bindings
60 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
61 Group:          Development/Languages/Python
62 Requires:       %{name} = %{version}-%{release}
63
64 %description -n python-mlt
65 Python bindings for MLT - open source multimedia framework.
66
67 %package devel
68 Summary:        Header files for MLT
69 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      mlt++-devel < %{version}
73
74 %description devel
75 This package contains header files for MLT.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe dla MLT.
79
80 %prep
81 %setup -q
82 %ifarch ppc ppc64
83 %patch0 -p1
84 %endif
85 %patch1 -p1
86
87 %build
88 %configure \
89         --enable-gpl \
90 %ifarch %{x8664}
91         --disable-motion-est \
92 %else
93         --enable-motion-est \
94 %endif
95         --disable-debug \
96 %ifarch i586 i686 %{x8664}
97         --disable-mmx \
98 %else
99         --enable-mmx \
100 %endif
101         --disable-sse2 \
102         --avformat-swscale \
103         --qimage-includedir=%{_includedir}/qt4 \
104         --qimage-libdir=%{_libdir} \
105         --swig-languages=python
106
107 %{__make} \
108         CC="%{__cc}"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{py_sitedir}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
118
119 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
120 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
121 %py_postclean
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc ChangeLog README
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %ghost %{_libdir}/*.so.?
134 %attr(755,root,root) %{_libdir}/*.so.*.*
135 %dir %{_libdir}/%{name}
136 %attr(755,root,root) %{_libdir}/%{name}/*
137 %{_datadir}/mlt*
138
139 %files -n python-mlt
140 %defattr(644,root,root,755)
141 %{py_sitedir}/*.py[co]
142 %attr(755,root,root) %{py_sitedir}/*.so
143
144 %files devel
145 %defattr(644,root,root,755)
146 %{_pkgconfigdir}/*.pc
147 %{_includedir}/mlt*
148 %{_libdir}/*.so
This page took 0.039774 seconds and 2 git commands to generate.