]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
ce4c73e20cae22587204d91efe97e8cefa422265
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #       - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
6 #
7 Summary:        MLT - open source multimedia framework
8 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
9 Name:           mlt
10 Version:        0.9.2
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
15 # Source0-md5:  f88ead8fcea628a65ebf329cc4470b6d
16 URL:            http://www.mltframework.org/
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtSvg-devel
19 BuildRequires:  QtXml-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  SDL_image-devel
22 BuildRequires:  exiv2-devel
23 BuildRequires:  ffmpeg-devel
24 BuildRequires:  gtk+2-devel
25 #BuildRequires: ladspa-devel
26 #BuildRequires: lame-libs-devel
27 BuildRequires:  libdv-devel >= 0.102
28 #BuildRequires: libmad-devel
29 BuildRequires:  libquicktime-devel
30 BuildRequires:  libsamplerate-devel
31 BuildRequires:  libvorbis-devel >= 1:1.0.1
32 BuildRequires:  libxml2-devel >= 2.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  sox-devel
37 BuildRequires:  swfdec-devel
38 BuildRequires:  swig-python
39 BuildRequires:  which
40 Obsoletes:      mlt++ < %{version}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 MLT is an open source multimedia framework, designed and developed for
45 television broadcasting. It provides a toolkit for broadcasters, video
46 editors, media players, transcoders, web streamers and many more types
47 of applications. The functionality of the system is provided via an
48 assortment of ready to use tools, XML authoring components, and an
49 extendible plug-in based API.
50
51 %description -l pl.UTF-8
52 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
53 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
54 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
55 do udostępniania strumieni przez WWW i wiele innych rodzajów
56 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
57 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
58 rozszerzalne API oparte na wtyczkach.
59
60 %package -n python-mlt
61 Summary:        MLT Python bindings
62 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
63 Group:          Development/Languages/Python
64 Requires:       %{name} = %{version}-%{release}
65
66 %description -n python-mlt
67 Python bindings for MLT - open source multimedia framework.
68
69 %package devel
70 Summary:        Header files for MLT
71 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Obsoletes:      mlt++-devel < %{version}
75
76 %description devel
77 This package contains header files for MLT.
78
79 %description devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe dla MLT.
81
82 %prep
83 %setup -q
84
85 # current
86 sed -i -e 's#/usr/lib/libvdpau.so#%{_libdir}/libvdpau.so.1#g' ./src/modules/avformat/vdpau.c
87 # in case of future changes
88 sed -i -e 's#/usr/local/lib/libvdpau.so#%{_libdir}/libvdpau.so.2#g' ./src/modules/avformat/vdpau.c
89
90 %build
91 %configure \
92         --enable-gpl \
93         --enable-gpl3 \
94 %ifarch %{x8664}
95         --disable-motion-est \
96 %else
97         --enable-motion-est \
98 %endif
99         --disable-debug \
100 %ifarch i586 i686 %{x8664}
101         --enable-mmx \
102 %else
103         --disable-mmx \
104 %endif
105 %ifarch %{x8664}
106         --enable-sse \
107         --enable-sse2 \
108 %else
109         --disable-sse \
110         --disable-sse2 \
111 %endif
112         --avformat-swscale \
113         --avformat-vdpau \
114         --qimage-includedir=%{_includedir}/qt4 \
115         --qimage-libdir=%{_libdir} \
116         --swig-languages=python
117
118 %{__make} \
119         CC="%{__cc}"
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{py_sitedir}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 cp -p src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
129
130 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
131 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
132 %py_postclean
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc ChangeLog README
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %ghost %{_libdir}/*.so.?
145 %attr(755,root,root) %{_libdir}/*.so.*.*
146 %dir %{_libdir}/%{name}
147 %attr(755,root,root) %{_libdir}/%{name}/*
148 %{_datadir}/mlt*
149
150 %files -n python-mlt
151 %defattr(644,root,root,755)
152 %{py_sitedir}/*.py[co]
153 %attr(755,root,root) %{py_sitedir}/*.so
154
155 %files devel
156 %defattr(644,root,root,755)
157 %{_pkgconfigdir}/*.pc
158 %{_includedir}/mlt*
159 %{_libdir}/*.so
This page took 0.07101 seconds and 2 git commands to generate.