]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
- rel 3; libvdpau.so paths
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #       - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
6 #
7 Summary:        MLT - open source multimedia framework
8 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
9 Name:           mlt
10 Version:        0.9.0
11 Release:        3
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
15 # Source0-md5:  1cd2d73f3ffe77a43980e99aaa4ea06c
16 URL:            http://www.mltframework.org/
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtSvg-devel
19 BuildRequires:  QtXml-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  ffmpeg-devel
22 BuildRequires:  gtk+2-devel
23 #BuildRequires: ladspa-devel
24 #BuildRequires: lame-libs-devel
25 BuildRequires:  libdv-devel >= 0.102
26 #BuildRequires: libmad-devel
27 BuildRequires:  libquicktime-devel
28 BuildRequires:  libsamplerate-devel
29 BuildRequires:  libvorbis-devel >= 1:1.0.1
30 BuildRequires:  libxml2-devel >= 2.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  sox-devel
35 BuildRequires:  swig-python
36 BuildRequires:  swfdec-devel
37 BuildRequires:  which
38 Obsoletes:      mlt++ < %{version}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 MLT is an open source multimedia framework, designed and developed for
43 television broadcasting. It provides a toolkit for broadcasters, video
44 editors, media players, transcoders, web streamers and many more types
45 of applications. The functionality of the system is provided via an
46 assortment of ready to use tools, XML authoring components, and an
47 extendible plug-in based API.
48
49 %description -l pl.UTF-8
50 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
51 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
52 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
53 do udostępniania strumieni przez WWW i wiele innych rodzajów
54 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
55 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
56 rozszerzalne API oparte na wtyczkach.
57
58 %package -n python-mlt
59 Summary:        MLT Python bindings
60 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
61 Group:          Development/Languages/Python
62 Requires:       %{name} = %{version}-%{release}
63
64 %description -n python-mlt
65 Python bindings for MLT - open source multimedia framework.
66
67 %package devel
68 Summary:        Header files for MLT
69 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      mlt++-devel < %{version}
73
74 %description devel
75 This package contains header files for MLT.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe dla MLT.
79
80 %prep
81 %setup -q
82
83 # current
84 sed -i -e 's#/usr/lib/libvdpau.so#%{_libdir}/libvdpau.so.1#g' ./src/modules/avformat/vdpau.c
85 # in case of future changes
86 sed -i -e 's#/usr/local/lib/libvdpau.so#%{_libdir}/libvdpau.so.2#g' ./src/modules/avformat/vdpau.c
87
88 %build
89 %configure \
90         --enable-gpl \
91         --enable-gpl3 \
92 %ifarch %{x8664}
93         --disable-motion-est \
94 %else
95         --enable-motion-est \
96 %endif
97         --disable-debug \
98 %ifarch i586 i686 %{x8664}
99         --enable-mmx \
100 %else
101         --disable-mmx \
102 %endif
103 %ifarch %{x8664}
104         --enable-sse \
105         --enable-sse2 \
106 %else
107         --disable-sse \
108         --disable-sse2 \
109 %endif
110         --avformat-swscale \
111         --avformat-vdpau \
112         --qimage-includedir=%{_includedir}/qt4 \
113         --qimage-libdir=%{_libdir} \
114         --swig-languages=python
115
116 %{__make} \
117         CC="%{__cc}"
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{py_sitedir}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 install src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
127
128 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
129 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_postclean
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc ChangeLog README
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %ghost %{_libdir}/*.so.?
143 %attr(755,root,root) %{_libdir}/*.so.*.*
144 %dir %{_libdir}/%{name}
145 %attr(755,root,root) %{_libdir}/%{name}/*
146 %{_datadir}/mlt*
147
148 %files -n python-mlt
149 %defattr(644,root,root,755)
150 %{py_sitedir}/*.py[co]
151 %attr(755,root,root) %{py_sitedir}/*.so
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_pkgconfigdir}/*.pc
156 %{_includedir}/mlt*
157 %{_libdir}/*.so
This page took 0.080696 seconds and 3 git commands to generate.