]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
- rel 2; enable mmx, sse, sse2, avformat vdpau, gpl3 components, swfdec
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #       - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
6 #
7 Summary:        MLT - open source multimedia framework
8 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
9 Name:           mlt
10 Version:        0.9.0
11 Release:        2
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
15 # Source0-md5:  1cd2d73f3ffe77a43980e99aaa4ea06c
16 URL:            http://www.mltframework.org/
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtSvg-devel
19 BuildRequires:  QtXml-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  ffmpeg-devel
22 BuildRequires:  gtk+2-devel
23 #BuildRequires: ladspa-devel
24 #BuildRequires: lame-libs-devel
25 BuildRequires:  libdv-devel >= 0.102
26 #BuildRequires: libmad-devel
27 BuildRequires:  libquicktime-devel
28 BuildRequires:  libsamplerate-devel
29 BuildRequires:  libvorbis-devel >= 1:1.0.1
30 BuildRequires:  libxml2-devel >= 2.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  sox-devel
35 BuildRequires:  swig-python
36 BuildRequires:  swfdec-devel
37 BuildRequires:  which
38 Obsoletes:      mlt++ < %{version}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 MLT is an open source multimedia framework, designed and developed for
43 television broadcasting. It provides a toolkit for broadcasters, video
44 editors, media players, transcoders, web streamers and many more types
45 of applications. The functionality of the system is provided via an
46 assortment of ready to use tools, XML authoring components, and an
47 extendible plug-in based API.
48
49 %description -l pl.UTF-8
50 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
51 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
52 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
53 do udostępniania strumieni przez WWW i wiele innych rodzajów
54 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
55 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
56 rozszerzalne API oparte na wtyczkach.
57
58 %package -n python-mlt
59 Summary:        MLT Python bindings
60 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
61 Group:          Development/Languages/Python
62 Requires:       %{name} = %{version}-%{release}
63
64 %description -n python-mlt
65 Python bindings for MLT - open source multimedia framework.
66
67 %package devel
68 Summary:        Header files for MLT
69 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      mlt++-devel < %{version}
73
74 %description devel
75 This package contains header files for MLT.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe dla MLT.
79
80 %prep
81 %setup -q
82
83 %build
84 %configure \
85         --enable-gpl \
86         --enable-gpl3 \
87 %ifarch %{x8664}
88         --disable-motion-est \
89 %else
90         --enable-motion-est \
91 %endif
92         --disable-debug \
93 %ifarch i586 i686 %{x8664}
94         --enable-mmx \
95 %else
96         --disable-mmx \
97 %endif
98 %ifarch %{x8664}
99         --enable-sse \
100         --enable-sse2 \
101 %else
102         --disable-sse \
103         --disable-sse2 \
104 %endif
105         --avformat-swscale \
106         --avformat-vdpau \
107         --qimage-includedir=%{_includedir}/qt4 \
108         --qimage-libdir=%{_libdir} \
109         --swig-languages=python
110
111 %{__make} \
112         CC="%{__cc}"
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{py_sitedir}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
122
123 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
124 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
125 %py_postclean
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc ChangeLog README
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %ghost %{_libdir}/*.so.?
138 %attr(755,root,root) %{_libdir}/*.so.*.*
139 %dir %{_libdir}/%{name}
140 %attr(755,root,root) %{_libdir}/%{name}/*
141 %{_datadir}/mlt*
142
143 %files -n python-mlt
144 %defattr(644,root,root,755)
145 %{py_sitedir}/*.py[co]
146 %attr(755,root,root) %{py_sitedir}/*.so
147
148 %files devel
149 %defattr(644,root,root,755)
150 %{_pkgconfigdir}/*.pc
151 %{_includedir}/mlt*
152 %{_libdir}/*.so
This page took 0.312868 seconds and 3 git commands to generate.