]> git.pld-linux.org Git - packages/mkvtoolnix.git/blob - mkvtoolnix.spec
- fixes working with Boost 1.50
[packages/mkvtoolnix.git] / mkvtoolnix.spec
1 # TODO:
2 # - make -gui subpackages (wxWidgets and Qt4 deps)
3 # - boost autodetection fails ($BOOSTLIBDIR empty), so all boost libs must be passed --with-boost-xxx=xxxx
4 #
5 # Conditional build
6 %bcond_with     verbose # verbose build (V=1)
7 %bcond_without  qt      # disable GUI build (Qt4 deps)
8 %bcond_without  wx      # disable GUI build (wxWigets deps)
9 #
10 Summary:        Matroska video utilities
11 Summary(pl.UTF-8):      Narzędzia do filmów w formacie Matroska
12 Name:           mkvtoolnix
13 Version:        5.7.0
14 Release:        2
15 License:        GPL v2
16 Group:          Applications/Multimedia
17 Source0:        http://www.bunkus.org/videotools/mkvtoolnix/sources/%{name}-%{version}.tar.bz2
18 # Source0-md5:  99ea44be570412dadafe4ccaee0cfe6e
19 Patch0:         %{name}-init_locales.patch
20 Patch1:         %{name}-boost_1_5.patch
21 URL:            http://www.bunkus.org/videotools/mkvtoolnix/
22 %{?with_qt:BuildRequires:       QtGui-devel}
23 BuildRequires:  boost-devel >= 1.36
24 BuildRequires:  bzip2-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  flac-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  libebml-devel >= 1.2.0
29 BuildRequires:  libmagic-devel
30 BuildRequires:  libmatroska-devel >= 1.1.0
31 BuildRequires:  libogg-devel
32 BuildRequires:  libvorbis-devel
33 BuildRequires:  lzo-devel
34 BuildRequires:  pcre-cxx-devel
35 %if %{with qt}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt4-build >= 4.3.3-3
38 %endif
39 # required by rake
40 BuildRequires:  ruby-modules
41 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
42 BuildRequires:  zlib-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Matroska video utilities.
47
48 %description -l pl.UTF-8
49 Narzędzia do filmów w formacie Matroska.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 %configure \
58         --docdir=%{_datadir}/%{name} \
59         --enable-gui \
60         --%{?with_wx:en}%{!?with_wx:dis}able-wxwidgets \
61         --%{?with_qt:en}%{!?with_qt:dis}able-qt \
62         --with-boost-filesystem=boost_filesystem \
63         --with-boost-regex=boost_regex \
64         --with-boost-system=boost_system \
65         %{?with_qt:--with-moc=/usr/bin/moc-qt4} \
66         %{?with_qt:--with-uic=/usr/bin/uic-qt4} \
67         %{?with_wx:--with-wx-config=/usr/bin/wx-gtk2-unicode-config} \
68         --without-curl
69
70 rake %{?with_verbose:V=1}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 rake install \
76         INSTALL="install -cp" \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %find_lang %{name}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files -f %{name}.lang
85 %defattr(644,root,root,755)
86 %doc AUTHORS ChangeLog README TODO
87 %attr(755,root,root) %{_bindir}/*
88 %dir %{_datadir}/%{name}
89 %dir %{_datadir}/%{name}/guide
90 %{_datadir}/%{name}/guide/en
91 %lang(es) %{_datadir}/%{name}/guide/es
92 %lang(zh_CN) %{_datadir}/%{name}/guide/zh_CN
93 %{_datadir}/mime/packages/mkvtoolnix.xml
94 %{_desktopdir}/mkvinfo.desktop
95 %{_desktopdir}/mkvmergeGUI.desktop
96 %{_iconsdir}/hicolor/*/apps/mkvextract.png
97 %{_iconsdir}/hicolor/*/apps/mkvinfo.png
98 %{_iconsdir}/hicolor/*/apps/mkvmerge.png
99 %{_iconsdir}/hicolor/*/apps/mkvmergeGUI.png
100 %{_iconsdir}/hicolor/*/apps/mkvpropedit.png
101 %{_mandir}/man1/*
102 %lang(ja) %{_mandir}/ja/man1/*
103 %lang(nl) %{_mandir}/nl/man1/*
104 %lang(uk) %{_mandir}/uk/man1/*
105 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
This page took 0.034121 seconds and 4 git commands to generate.