]> git.pld-linux.org Git - packages/mjpegtools.git/blob - mjpegtools.spec
- updated to 2.2.1 (new sonames)
[packages/mjpegtools.git] / mjpegtools.spec
1 #
2 # Conditional build:
3 %bcond_without  quicktime       # without Quicktime playback/recording support
4 %bcond_with     simd            # MMX/SSE/Altivec instructions
5 #
6 %ifarch pentium3 pentium4 %{x8664} x32
7 %define with_simd       1
8 %endif
9 Summary:        Tools for recording, editing, playing back and MPEG-encoding video under Linux
10 Summary(pl.UTF-8):      Narzędzia do nagrywania, edycji, odtwarzania i kodowania do MPEG obrazu
11 Name:           mjpegtools
12 Version:        2.2.1
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications/Graphics
16 Source0:        https://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
17 # Source0-md5:  168e0131c0b8a2e31df7a73eb602fc32
18 Patch0:         %{name}-pthread.patch
19 Patch1:         x32.patch
20 URL:            https://mjpeg.sourceforge.io/
21 BuildRequires:  SDL-devel >= 1.1.3
22 BuildRequires:  SDL_gfx-devel
23 BuildRequires:  autoconf >= 2.57
24 BuildRequires:  automake >= 1:1.7
25 BuildRequires:  gtk+2-devel >= 2:2.4.0
26 BuildRequires:  libdv-devel >= 0.9.5
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel
29 %{?with_quicktime:BuildRequires:        libquicktime-devel >= 0.9.7}
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  xorg-lib-libX11-devel
34 # only checked for, not used for anything
35 #BuildRequires: xorg-lib-libXxf86dga-devel
36 Requires:       %{name}-libs = %{version}-%{release}
37 Obsoletes:      libmjpegtools0 < 2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The MJPEG-tools are a basic set of utilities for recording, editing,
42 playing back and encoding (to MPEG) video under Linux. Recording can
43 be done with Zoran-based MJPEG-boards (LML33, Iomega Buz, Pinnacle
44 DC10(+), Marvel G200/G400), these can also playback video using the
45 hardware. With the rest of the tools, this video can be edited and
46 encoded into MPEG 1/2 or DivX video.
47
48 %description -l pl.UTF-8
49 MJPEG-tools to podstawowy zestaw narzędzi do nagrywania, edycji,
50 odtwarzania i kodowania (do MPEG) obrazu pod Linuksem. Nagrywać można
51 przy użyciu kart MJPEG opartych na Zoranie (LML33, Iomega Buz,
52 Pinnacle DC10(+), Marvel G200/G400), na nich można także odtwarzać
53 obraz ze wsparciem sprzętowym. Przy pomocy pozostałych narzędzi obraz
54 można obrabiać i kodować do formatu MPEG 1/2 lub DivX.
55
56 %package libs
57 Summary:        MJPEG-tools shared libraries
58 Summary(pl.UTF-8):      Biblioteki współdzielone MJPEG-tools
59 Group:          Libraries
60 Requires:       libquicktime >= 0.9.7
61
62 %description libs
63 MJPEG-tools shared libraries.
64
65 %description libs -l pl.UTF-8
66 Biblioteki współdzielone MJPEG-tools.
67
68 %package devel
69 Summary:        Development headers for the mjpegtools
70 Summary(pl.UTF-8):      Pliki nagłówkowe mjpegtools
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Obsoletes:      libmjpegtools0-devel < 2
74 # libmjpegutils has no additional deps
75 # liblavfile R: libquicktime-devel >= 0.9.7 libdv-devel
76 # liblavjpeg R: libjpeg-devel
77 # liblavplay R: SDL-devel xorg-lib-libX11-devel +liblavfile,liblavjpeg
78 # liblavrec R: +liblavfile,liblavjpeg
79 # libmpeg2encpp R: libstdc++-devel
80 # libmplex2 R: libstdc++-devel
81
82 %description devel
83 This package contains C system header files needed to compile
84 applications that use part of the libraries of the mjpegtools package.
85
86 %description devel -l pl.UTF-8
87 Ten pakiet zawiera pliki nagłówkowe C potrzebne do kompilowania
88 aplikacji używających części bibliotek z pakietu mjpegtools.
89
90 %package static
91 Summary:        Static libraries for mjpegtools
92 Summary(pl.UTF-8):      Statyczne biblioteki mjpegtools
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static libraries for mjpegtools.
98
99 %description static -l pl.UTF-8
100 Statyczne biblioteki mjpegtools.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         PTHREAD_LIBS="-lpthread" \
115         %{!?with_quicktime:--without-libquicktime} \
116 %if %{without simd}
117         --disable-simd-accel
118 %endif
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/postshell
134 -/usr/sbin/fix-info-dir -c %{_infodir}
135
136 %postun -p /sbin/postshell
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138
139 %post   libs -p /sbin/ldconfig
140 %postun libs -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc README.lavpipe README.transist
145 %attr(755,root,root) %{_bindir}/anytovcd.sh
146 %attr(755,root,root) %{_bindir}/glav
147 %attr(755,root,root) %{_bindir}/jpeg2yuv
148 %attr(755,root,root) %{_bindir}/lav*
149 %attr(755,root,root) %{_bindir}/matteblend.flt
150 %attr(755,root,root) %{_bindir}/mjpeg_simd_helper
151 %attr(755,root,root) %{_bindir}/mp2enc
152 %attr(755,root,root) %{_bindir}/mpeg2enc
153 %attr(755,root,root) %{_bindir}/mpegtranscode
154 %attr(755,root,root) %{_bindir}/mplex
155 %attr(755,root,root) %{_bindir}/multiblend.flt
156 %attr(755,root,root) %{_bindir}/pgmtoy4m
157 %attr(755,root,root) %{_bindir}/png2yuv
158 %attr(755,root,root) %{_bindir}/pnmtoy4m
159 %attr(755,root,root) %{_bindir}/ppmtoy4m
160 %attr(755,root,root) %{_bindir}/qttoy4m
161 %attr(755,root,root) %{_bindir}/transist.flt
162 %attr(755,root,root) %{_bindir}/y4m*
163 %attr(755,root,root) %{_bindir}/ypipe
164 %attr(755,root,root) %{_bindir}/yuv*
165 %attr(755,root,root) %{_bindir}/yuyvtoy4m
166 %{_mandir}/man1/jpeg2yuv.1*
167 %{_mandir}/man1/lav*.1*
168 %{_mandir}/man1/mjpegtools.1*
169 %{_mandir}/man1/mp2enc.1*
170 %{_mandir}/man1/mpeg2enc.1*
171 %{_mandir}/man1/mplex.1*
172 %{_mandir}/man1/pgmtoy4m.1*
173 %{_mandir}/man1/png2yuv.1*
174 %{_mandir}/man1/pnmtoy4m.1*
175 %{_mandir}/man1/ppmtoy4m.1*
176 %{_mandir}/man1/y4m*.1*
177 %{_mandir}/man1/yuv*.1*
178 %{_infodir}/mjpeg-howto.info*
179
180 %files libs
181 %defattr(644,root,root,755)
182 %doc AUTHORS BUGS CHANGES HINTS PLANS README README.DV README.avilib TODO
183 %attr(755,root,root) %{_libdir}/liblavfile-2.2.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/liblavfile-2.2.so.0
185 %attr(755,root,root) %{_libdir}/liblavjpeg-2.2.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/liblavjpeg-2.2.so.0
187 %attr(755,root,root) %{_libdir}/liblavplay-2.2.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/liblavplay-2.2.so.0
189 %attr(755,root,root) %{_libdir}/libmjpegutils-2.2.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libmjpegutils-2.2.so.0
191 %attr(755,root,root) %{_libdir}/libmpeg2encpp-2.2.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libmpeg2encpp-2.2.so.0
193 %attr(755,root,root) %{_libdir}/libmplex2-2.2.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libmplex2-2.2.so.0
195 %{_mandir}/man5/yuv4mpeg.5*
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/liblavfile.so
200 %attr(755,root,root) %{_libdir}/liblavjpeg.so
201 %attr(755,root,root) %{_libdir}/liblavplay.so
202 %attr(755,root,root) %{_libdir}/libmjpegutils.so
203 %attr(755,root,root) %{_libdir}/libmpeg2encpp.so
204 %attr(755,root,root) %{_libdir}/libmplex2.so
205 %{_libdir}/liblavfile.la
206 %{_libdir}/liblavjpeg.la
207 %{_libdir}/liblavplay.la
208 %{_libdir}/libmjpegutils.la
209 %{_libdir}/libmpeg2encpp.la
210 %{_libdir}/libmplex2.la
211 %{_includedir}/mjpegtools
212 %{_pkgconfigdir}/mjpegtools.pc
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/liblavfile.a
217 %{_libdir}/liblavjpeg.a
218 %{_libdir}/liblavplay.a
219 %{_libdir}/libmjpegutils.a
220 %{_libdir}/libmpeg2encpp.a
221 %{_libdir}/libmplex2.a
This page took 0.11497 seconds and 3 git commands to generate.