]> git.pld-linux.org Git - packages/mirall.git/blob - mirall.spec
- Added mirall-nautilus to include nautilus extension.
[packages/mirall.git] / mirall.spec
1 # TODO:
2 # * Fix ocsync packaging for and fix plugin dependencies here
3 # * Fix and package lang stuff
4 # * Package ruby gem based cli
5 Summary:        Desktop file sync client for directory sharing and syncronization
6 Name:           mirall
7 Version:        1.7.0
8 Release:        0.2
9 License:        GPL v2
10 Group:          Libraries
11 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.bz2
12 # Source0-md5:  f662f4510ef26b5484f754304f8d9295
13 URL:            http://www.owncloud.org
14 BuildRequires:  QtGui-devel
15 BuildRequires:  QtTest-devel
16 BuildRequires:  QtWebKit-devel
17 BuildRequires:  QtKeychain-devel
18 BuildRequires:  check
19 BuildRequires:  cmake
20 BuildRequires:  doxygen
21 BuildRequires:  kde4-icons-oxygen
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  qt4-build
24 BuildRequires:  qt4-linguist
25 Requires:       iproute2
26 Requires:       kde4-icons-oxygen
27 Requires:       net-tools
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Mirall is the the QT baesd frontend desktop client for owncloud using
32 ocsync as a backend.
33
34 %package nautilus
35 Summary:        A nautilus extension for %{name}
36 Group:          Applications
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       nautilus-python
39
40 %description nautilus
41 A mirall extension to nautilus file browser.
42
43 %package devel
44 Summary:        Header files for %{name}
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for %{name}
49
50 %prep
51 %setup -q
52
53 %build
54 if test ! -e "build"; then
55         %{__mkdir} build
56 fi
57
58 cd build
59
60 %cmake \
61         -DCSYNC_INCLUDE_PATH=%{_includedir}/ocsync \
62         -DCMAKE_C_FLAGS:STRING="%{optflags}" \
63         -DCMAKE_CXX_FLAGS:STRING="%{optflags}" \
64         -DCMAKE_SKIP_RPATH=ON \
65         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
66         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
67         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
68         -DPREFIX=%{_prefix} \
69         -DSYSCONFDIR=%{_sysconfdir} \
70         $RPM_BUILD_ROOT/%{name}-%{version} \
71         ..
72
73 %{__make}
74 %{__make} doc
75
76 cd ..
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 cd build
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 mv ${RPM_BUILD_ROOT}/%{_libdir}/owncloud/* ${RPM_BUILD_ROOT}/%{_libdir}/
87 rmdir ${RPM_BUILD_ROOT}/%{_libdir}/owncloud
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.md COPYING ChangeLog
98 %attr(755,root,root) %{_bindir}/owncloud
99 %attr(755,root,root) %{_bindir}/owncloudcmd
100 %dir %{_sysconfdir}/ownCloud
101 %{_sysconfdir}/ownCloud/sync-exclude.lst
102 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
103 %ghost %{_libdir}/libowncloudsync.so.0
104 %attr(755,root,root) %{_libdir}/libocsync.so.*
105 %{_desktopdir}/owncloud.desktop
106 %{_iconsdir}/hicolor/*/apps/own*.png
107 %dir %{_datadir}/owncloud
108 %dir %{_datadir}/owncloud/i18n
109 %{_datadir}/owncloud/i18n/*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libowncloudsync.so
114 %attr(755,root,root) %{_libdir}/libocsync.so
115 %{_libdir}/libhttpbf.a
116 %{_includedir}/httpbf.h
117 %dir %{_includedir}/owncloudsync
118 %dir %{_includedir}/owncloudsync/mirall
119 %dir %{_includedir}/owncloudsync/creds
120 %{_includedir}/owncloudsync/mirall/*
121 %{_includedir}/owncloudsync/creds/*
122
123 %files nautilus
124 %defattr(644,root,root,755)
125 %{_datadir}/nautilus-python/extensions/*.py
126
This page took 0.062502 seconds and 3 git commands to generate.