]> git.pld-linux.org Git - packages/mirall.git/blob - mirall.spec
- Up to 1.4.1
[packages/mirall.git] / mirall.spec
1 # TODO:
2 # * Fix ocsync packaging for and fix plugin dependencies here
3 # * Fix and package lang stuff
4 # * Package ruby gem based cli
5 Summary:        Desktop file sync client for directory sharing and syncronization
6 Name:           mirall
7 Version:        1.4.1
8 Release:        0.1
9 License:        GPL v2
10 Group:          Libraries
11 Source0:        http://download.owncloud.com/download/%{name}-%{version}.tar.bz2
12 # Source0-md5:  d65de66b0387e9c18127d4baeae61e04
13 URL:            http://www.owncloud.org
14 BuildRequires:  QtGui-devel
15 BuildRequires:  QtTest-devel
16 BuildRequires:  QtWebKit-devel
17 BuildRequires:  check
18 BuildRequires:  cmake
19 BuildRequires:  doxygen
20 BuildRequires:  kde4-icons-oxygen
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  ocsync-devel
23 Requires:       PackageKit-gtk-module
24 Requires:       iproute2
25 Requires:       kde4-icons-oxygen
26 Requires:       net-tools
27 Requires:       net-tools
28 Requires:       ocsync
29 #Requires:      ocsync-plugin-sftp
30 #Requires:      ocsync-plugin-smb
31 #Requires:      ruby-owncloud-admin
32 Requires:       sitecopy
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Mirall is the the QT baesd frontend desktop client for owncloud using
37 ocsync as a backend.
38
39 %package -n owncloud-client
40 Summary:        Desktop file sync client for owncloud, a Dropbox-like directory sharing and syncronization tool
41 Group:          Applications
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       ocsync-owncloud
44
45 %description -n owncloud-client
46 Meta package to install the front end client for owncloud, a Dropbox
47 like directory sharing and syncronization tool.
48
49 %package devel
50 Summary:        Header files for %{name}
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{name}
55
56 %prep
57 %setup -q
58
59 %build
60 if test ! -e "build"; then
61         %{__mkdir} build
62 fi
63
64 cd build
65
66 %cmake \
67         -DCSYNC_INCLUDE_PATH=%{_includedir}/ocsync \
68         -DCMAKE_C_FLAGS:STRING="%{optflags}" \
69         -DCMAKE_CXX_FLAGS:STRING="%{optflags}" \
70         -DCMAKE_SKIP_RPATH=ON \
71         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
72         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
73         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
74         -DPREFIX=%{_prefix} \
75         -DSYSCONFDIR=%{_sysconfdir} \
76         $RPM_BUILD_ROOT/%{name}-%{version} \
77         ..
78
79 %{__make}
80 %{__make} doc
81
82 cd ..
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 cd build
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.md COPYING
101 %attr(755,root,root) %{_bindir}/owncloud
102 %dir %{_sysconfdir}/ownCloud
103 %{_sysconfdir}/ownCloud/sync-exclude.lst
104 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
105 %ghost %{_libdir}/libowncloudsync.so.0
106 %{_desktopdir}/owncloud.desktop
107 %{_iconsdir}/hicolor/48x48/apps/owncloud.png
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libowncloudsync.so
112
113 %files -n owncloud-client
114 %defattr(644,root,root,755)
This page took 0.080687 seconds and 3 git commands to generate.