]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- updated to 0.4.3, perl install not finished yet (/usr/lib issue on x86-64).
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Ming - an SWF output library
3 Summary(pl.UTF-8):      Ming - biblioteka do produkcji plików SWF
4 Name:           ming
5 Version:        0.4.3
6 Release:        0.1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/ming/%{name}-%{version}.tar.gz
10 # Source0-md5:  9578ec38d973adabd9e8a534982da0b9
11 Patch0:         %{name}-build.patch
12 Patch1:         %{name}-perl-shared.patch
13 Patch2:         %{name}-libpng.patch
14 URL:            http://ming.sourceforge.net/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  giflib-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  python-devel >= 1:2.4
20 BuildRequires:  rpm-perlprov >= 4.0.2-24
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Ming is a C library for generating SWF ("Flash") format movies, plus a
27 set of wrappers for using the library from c++ and popular scripting
28 languages like PHP, Python, and Ruby.
29
30 %description -l pl.UTF-8
31 Ming jest biblioteką w C do generowania animacji w formacie SWF
32 ("Flash") wraz z zestawem wrapperów do używania jej z C++ i
33 popularnymi językami skryptowymi, takimi jak PHP, Python i Ruby.
34
35 %package devel
36 Summary:        Ming development files
37 Summary(pl.UTF-8):      Pliki dla programistów Ming
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       giflib-devel
41
42 %description devel
43 Header files for ming library (C and C++).
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe dla biblioteki ming (do C i C++).
47
48 %package static
49 Summary:        Ming static library
50 Summary(pl.UTF-8):      Statyczna biblioteka Ming
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Ming library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka Ming.
59
60 %package utils
61 Summary:        Ming utilities
62 Summary(pl.UTF-8):      Narzędzia Ming
63 Group:          Applications/File
64
65 %description utils
66 Ming utilities:
67 - listswf - swf format disassembler
68 - listfdb - show contents of fdb font file
69 - makefdb - rip fdb font definition files out of a generator template
70   file
71 - swftophp - attempt to make a php/ming script out of an swf file
72
73 %description utils -l pl.UTF-8
74 Narzędzia Ming:
75 - listswf - disasembler plików swf
76 - listfdb - pokazuje zawartość plików fontów fdb
77 - makefdb - wyciąga pliki definicji fontów fdb z pliku generatora
78 - swftophp - próbuje zrobić skrypt php/ming z pliku swf
79
80 %package -n perl-ming
81 Summary:        Ming perl module
82 Summary(pl.UTF-8):      Moduł perla Ming
83 Group:          Development/Languages/Perl
84 Requires:       %{name} = %{version}-%{release}
85 Obsoletes:      ming-perl
86
87 %description -n perl-ming
88 Ming perl module - perl wrapper for Ming library.
89
90 %description -n perl-ming -l pl.UTF-8
91 Moduł perla Ming - perlowy wrapper do biblioteki Ming.
92
93 %package -n python-ming
94 Summary:        Ming Python module
95 Summary(pl.UTF-8):      Moduł biblioteki Ming dla języka Python
96 Group:          Development/Languages/Perl
97 Requires:       %{name} = %{version}-%{release}
98 %pyrequires_eq  python-libs
99
100 %description -n python-ming
101 Ming Python module.
102
103 %description -n python-ming -l pl.UTF-8
104 Moduł biblioteki Ming dla języka Python.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 %build
113 %configure \
114         --enable-perl \
115         --enable-python
116
117 %{__make} -j1
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_libdir}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
127 rm $RPM_BUILD_ROOT%{py_sitedir}/ming*.py
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc CREDITS README TODO
138 %attr(755,root,root) %{_libdir}/libming.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libming.so.0
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libming.so
144 %{_includedir}/ming.h
145 %{_includedir}/mingpp.h
146 %{_includedir}/ming_config.h
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libming.a
151
152 %files utils
153 %defattr(644,root,root,755)
154 %doc util/{README,TODO}
155 %attr(755,root,root) %{_bindir}/dbl2png
156 %attr(755,root,root) %{_bindir}/gif2dbl
157 %attr(755,root,root) %{_bindir}/gif2mask
158 %attr(755,root,root) %{_bindir}/listaction
159 %attr(755,root,root) %{_bindir}/listaction_d
160 %attr(755,root,root) %{_bindir}/listfdb
161 %attr(755,root,root) %{_bindir}/listjpeg
162 %attr(755,root,root) %{_bindir}/listmp3
163 %attr(755,root,root) %{_bindir}/listswf
164 %attr(755,root,root) %{_bindir}/listswf_d
165 %attr(755,root,root) %{_bindir}/makefdb
166 %attr(755,root,root) %{_bindir}/makeswf
167 %attr(755,root,root) %{_bindir}/ming-config
168 %attr(755,root,root) %{_bindir}/png2dbl
169 %attr(755,root,root) %{_bindir}/png2swf
170 %attr(755,root,root) %{_bindir}/raw2adpcm
171 %attr(755,root,root) %{_bindir}/swftoperl
172 %attr(755,root,root) %{_bindir}/swftophp
173 %attr(755,root,root) %{_bindir}/swftopython
174 %{_mandir}/man1/makeswf.1*
175
176 %files -n perl-ming
177 %defattr(644,root,root,755)
178 %doc perl_ext/{README,TODO}
179 %{perl_vendorarch}/SWF.pm
180 %{perl_vendorarch}/SWF
181 %dir %{perl_vendorarch}/auto/SWF
182 %{perl_vendorarch}/auto/SWF/SWF.bs
183 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
184 %{_mandir}/man3/SWF*
185
186 %files -n python-ming
187 %defattr(644,root,root,755)
188 %doc py_ext/{README,TODO}
189 %attr(755,root,root) %{py_sitedir}/_mingc.so
190 %{py_sitedir}/ming*.py[co]
191 %if "%{py_ver}" > "2.4"
192 %{py_sitedir}/mingc-*.egg-info
193 %endif
This page took 0.047088 seconds and 4 git commands to generate.