]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- release 7
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Ming - an SWF output library
3 Summary(pl.UTF-8):      Ming - biblioteka do produkcji plików SWF
4 Name:           ming
5 Version:        0.3.0
6 Release:        7
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/ming/%{name}-%{version}.tar.gz
10 # Source0-md5:  56b29eeb4fdd0b98c9ee62e25d14841d
11 Source1:        http://dl.sourceforge.net/ming/%{name}-perl-%{version}.tar.gz
12 # Source1-md5:  506acca9ca42066a97fc0b6abad6d57a
13 Source2:        http://dl.sourceforge.net/ming/%{name}-py-%{version}.tar.gz
14 # Source2-md5:  96d3f42f13d020d907287a640b39ec46
15 Patch0:         %{name}-DESTDIR.patch
16 Patch1:         %{name}-build.patch
17 Patch2:         %{name}-perl-shared.patch
18 URL:            http://ming.sourceforge.net/
19 BuildRequires:  giflib-devel
20 BuildRequires:  python-devel >= 1:2.4
21 BuildRequires:  rpm-perlprov >= 4.0.2-24
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Ming is a C library for generating SWF ("Flash") format movies, plus a
28 set of wrappers for using the library from c++ and popular scripting
29 languages like PHP, Python, and Ruby.
30
31 %description -l pl.UTF-8
32 Ming jest biblioteką w C do generowania animacji w formacie SWF
33 ("Flash") wraz z zestawem wrapperów do używania jej z C++ i
34 popularnymi językami skryptowymi, takimi jak PHP, Python i Ruby.
35
36 %package devel
37 Summary:        Ming development files
38 Summary(pl.UTF-8):      Pliki dla programistów Ming
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       giflib-devel
42
43 %description devel
44 Header files for ming library (C and C++).
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla biblioteki ming (do C i C++).
48
49 %package static
50 Summary:        Ming static library
51 Summary(pl.UTF-8):      Statyczna biblioteka Ming
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static Ming library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka Ming.
60
61 %package utils
62 Summary:        Ming utilities
63 Summary(pl.UTF-8):      Narzędzia Ming
64 Group:          Applications/File
65
66 %description utils
67 Ming utilities:
68 - listswf - swf format disassembler
69 - listfdb - show contents of fdb font file
70 - makefdb - rip fdb font definition files out of a generator template
71   file
72 - swftophp - attempt to make a php/ming script out of an swf file
73
74 %description utils -l pl.UTF-8
75 Narzędzia Ming:
76 - listswf - disasembler plików swf
77 - listfdb - pokazuje zawartość plików fontów fdb
78 - makefdb - wyciąga pliki definicji fontów fdb z pliku generatora
79 - swftophp - próbuje zrobić skrypt php/ming z pliku swf
80
81 %package -n perl-ming
82 Summary:        Ming perl module
83 Summary(pl.UTF-8):      Moduł perla Ming
84 Group:          Development/Languages/Perl
85 Requires:       %{name} = %{version}-%{release}
86 Obsoletes:      ming-perl
87
88 %description -n perl-ming
89 Ming perl module - perl wrapper for Ming library.
90
91 %description -n perl-ming -l pl.UTF-8
92 Moduł perla Ming - perlowy wrapper do biblioteki Ming.
93
94 %package -n python-ming
95 Summary:        Ming Python module
96 Summary(pl.UTF-8):      Moduł biblioteki Ming dla języka Python
97 Group:          Development/Languages/Perl
98 Requires:       %{name} = %{version}-%{release}
99 %pyrequires_eq  python-libs
100
101 %description -n python-ming
102 Ming Python module.
103
104 %description -n python-ming -l pl.UTF-8
105 Moduł biblioteki Ming dla języka Python.
106
107 %prep
108 %setup -q -b1 -b2
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112
113 ln -s src/ming.h
114
115 %build
116 %configure
117 %{__make} -j1
118
119 cd perl_ext
120 %{__perl} Makefile.PL \
121         INSTALLDIRS=vendor
122 %{__make} \
123         CC="%{__cc}" \
124         OPTIMIZE="%{rpmcflags}"
125 cd ..
126
127 %{__make} -C py_ext \
128         CC="%{__cc}" \
129         CFLAGS="%{rpmcflags}" \
130         PYINCDIR=%{py_incdir}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_libdir}
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138 chmod +x $RPM_BUILD_ROOT%{_libdir}/libming.so.0.3.0
139
140 %{__make} -C perl_ext pure_install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %{__make} -C py_ext install \
144         PREFIX="--optimize=2 --root=$RPM_BUILD_ROOT"
145
146 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/SWF/.cvsignore
147 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
148 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/include/libming.a
149 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/include/ming.h
150 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/include/perl_swf.h
151 rm -f $RPM_BUILD_ROOT%{py_sitedir}/ming*.py
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc CREDITS README TODO
162 %attr(755,root,root) %{_libdir}/libming.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libming.so.0
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libming.so
168 %{_includedir}/ming.h
169 %{_includedir}/mingpp.h
170 %{_includedir}/ming_config.h
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libming.a
175
176 %files utils
177 %defattr(644,root,root,755)
178 %doc util/{README,TODO}
179 %attr(755,root,root) %{_bindir}/dbl2png
180 %attr(755,root,root) %{_bindir}/gif2dbl
181 %attr(755,root,root) %{_bindir}/gif2mask
182 %attr(755,root,root) %{_bindir}/listaction
183 %attr(755,root,root) %{_bindir}/listaction_d
184 %attr(755,root,root) %{_bindir}/listfdb
185 %attr(755,root,root) %{_bindir}/listjpeg
186 %attr(755,root,root) %{_bindir}/listmp3
187 %attr(755,root,root) %{_bindir}/listswf
188 %attr(755,root,root) %{_bindir}/listswf_d
189 %attr(755,root,root) %{_bindir}/makefdb
190 %attr(755,root,root) %{_bindir}/makeswf
191 %attr(755,root,root) %{_bindir}/ming-config
192 %attr(755,root,root) %{_bindir}/png2dbl
193 %attr(755,root,root) %{_bindir}/png2swf
194 %attr(755,root,root) %{_bindir}/raw2adpcm
195 %attr(755,root,root) %{_bindir}/swftoperl
196 %attr(755,root,root) %{_bindir}/swftophp
197 %attr(755,root,root) %{_bindir}/swftopython
198 %{_mandir}/man1/makeswf.1*
199
200 %files -n perl-ming
201 %defattr(644,root,root,755)
202 %doc perl_ext/{README,TODO}
203 %{perl_vendorarch}/SWF.pm
204 %{perl_vendorarch}/SWF
205 %dir %{perl_vendorarch}/auto/SWF
206 %{perl_vendorarch}/auto/SWF/SWF.bs
207 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
208 %{_mandir}/man3/SWF*
209
210 %files -n python-ming
211 %defattr(644,root,root,755)
212 %doc py_ext/{README,TODO}
213 %attr(755,root,root) %{py_sitedir}/_mingc.so
214 %{py_sitedir}/ming*.py[co]
215 %if "%{py_ver}" > "2.4"
216 %{py_sitedir}/mingc-*.egg-info
217 %endif
This page took 0.044189 seconds and 4 git commands to generate.