]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- added python module
[packages/ming.git] / ming.spec
1
2 %include        /usr/lib/rpm/macros.perl
3 %include        /usr/lib/rpm/macros.python
4
5 Summary:        Ming - an SWF output library
6 Summary(pl):    Ming - biblioteka do produkcji plików SWF
7 Name:           ming
8 Version:        0.2a
9 Release:        4
10 License:        LGPL
11 Vendor:         Opaque Industries
12 Group:          Libraries
13 Source0:        http://www.opaque.net/ming/%{name}-%{version}.tgz
14 Patch0:         %{name}-dynamic-exts.patch
15 Patch1:         %{name}-soname.patch
16 Patch2:         %{name}-python.patch
17 URL:            http://www.opaque.net/ming/
18 BuildRequires:  python-devel
19 BuildRequires:  zlib-devel
20 BuildRequires:  rpm-perlprov >= 4.0.2-24
21 BuildRequires:  rpm-pythonprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         phpextdir       %(php-config --extension-dir)
25
26 %description
27 Ming is a C library for generating SWF ("Flash") format movies, plus a
28 set of wrappers for using the library from c++ and popular scripting
29 languages like PHP, Python, and Ruby.
30
31 %description -l pl
32 Ming jest bibliotek± w C do generowania animacji w formacie SWF
33 ("Flash") wraz z zestawem wrapperów do u¿ywania jej z C++ i
34 popularnymi jêzykami skryptowymi, takimi jak PHP, Python i Ruby.
35
36 %package devel
37 Summary:        Ming development files
38 Summary(pl):    Pliki dla programistów Ming
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}
41
42 %description devel
43 Header files for ming library (C and C++).
44
45 %description devel -l pl
46 Pliki nag³ówkowe dla biblioteki ming (do C i C++).
47
48 %package -n perl-ming
49 Summary:        Ming perl module
50 Summary(pl):    Modu³ perla Ming
51 Group:          Development/Languages/Perl
52 Requires:       %{name} = %{version}
53 Obsoletes:      ming-perl
54
55 %description -n perl-ming
56 Ming perl module - perl wrapper for Ming library.
57
58 %description -n perl-ming -l pl
59 Modu³ perla Ming - perlowy wrapper do biblioteki Ming.
60
61 %package -n python-ming
62 Summary:        Ming Python module
63 Summary(pl):    Modu³ biblioteki Ming dla jêzyka Python
64 Group:          Development/Languages/Perl
65 Requires:       %{name} = %{version}
66
67 %description -n python-ming
68 Ming Python module.
69
70 %description -n python-ming -l pl
71 Modu³ biblioteki Ming dla jêzyka Python.
72
73 %package utils
74 Summary:        Ming utilities
75 Summary(pl):    Narzêdzia Ming
76 Group:          Applications/File
77
78 %description utils
79 Ming utilities:
80 - listswf - swf format disassembler
81 - listfdb - show contents of fdb font file
82 - makefdb - rip fdb font definition files out of a generator template
83   file
84 - swftophp - attempt to make a php/ming script out of an swf file
85
86 %description utils -l pl
87 Narzêdzia Ming:
88 - listswf - disasembler plików swf
89 - listfdb - pokazuje zawarto¶æ plików fontów fdb
90 - makefdb - wyci±ga pliki definicji fontów fdb z pliku generatora
91 - swftophp - próbuje zrobiæ skrypt php/ming z pliku swf
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 %build
100 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}"
101
102 #%{__make} -C java_ext
103
104 (cd perl_ext
105 perl ./Makefile.PL
106 %{__make} OPTIMIZE="%{rpmcflags}"
107 )
108
109 %{__make} -C py_ext PYINCDIR=%{py_incdir}
110 #%{__make} -C rb_ext
111
112 (cd util
113 %{__make} CC="%{__cc} %{rpmcflags}" \
114         listswf listaction swftophp makefdb
115 %{__cc} %{rpmcflags} -o listfdb listfdb.c
116 )
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_bindir},%{py_sitedir}}
121
122 %{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
123
124 %{__make} -C perl_ext install DESTDIR=$RPM_BUILD_ROOT
125
126 %{__make} -C py_ext install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         PYLIBDIR=$RPM_BUILD_ROOT%{py_libdir}
129 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
131
132 install util/{listswf,listaction,listfdb,makefdb,swftophp} $RPM_BUILD_ROOT%{_bindir}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc CHANGES CREDITS README TODO rb_ext/README
143 %attr(755,root,root) %{_libdir}/libming.so.*.*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libming.so
148 %{_includedir}/ming.h
149 %{_includedir}/mingpp.h
150
151 %files -n perl-ming
152 %defattr(644,root,root,755)
153 %doc perl_ext/{README,TODO}
154 %{perl_sitearch}/SWF.pm
155 %{perl_sitearch}/SWF
156 %dir %{perl_sitearch}/auto/SWF
157 %{perl_sitearch}/auto/SWF/SWF.bs
158 %attr(755,root,root) %{perl_sitearch}/auto/SWF/SWF.so
159 %{_mandir}/man3/SWF*
160
161 %files -n python-ming
162 %defattr(644,root,root,755)
163 %doc py_ext/{README,TODO}
164 %attr(755,root,root) %{py_sitedir}/*.so
165 %{py_sitedir}/*.py[co]
166
167 %files utils
168 %defattr(644,root,root,755)
169 %doc util/{README,TODO}
170 %attr(755,root,root) %{_bindir}/*
This page took 0.045992 seconds and 4 git commands to generate.