]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- fixed python module install requirements
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 %include        /usr/lib/rpm/macros.python
3 Summary:        Ming - an SWF output library
4 Summary(pl):    Ming - biblioteka do produkcji plików SWF
5 Name:           ming
6 Version:        0.2a
7 Release:        7
8 License:        LGPL
9 Vendor:         Opaque Industries
10 Group:          Libraries
11 Source0:        http://www.opaque.net/ming/%{name}-%{version}.tgz
12 # Source0-md5: 72b25da0af28d9cb025c2aaf3fd0185c
13 Patch0:         %{name}-dynamic-exts.patch
14 Patch1:         %{name}-soname.patch
15 Patch2:         %{name}-python.patch
16 Patch3:         %{name}-c++.patch
17 URL:            http://www.opaque.net/ming/
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-perlprov >= 4.0.2-24
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Ming is a C library for generating SWF ("Flash") format movies, plus a
26 set of wrappers for using the library from c++ and popular scripting
27 languages like PHP, Python, and Ruby.
28
29 %description -l pl
30 Ming jest bibliotek± w C do generowania animacji w formacie SWF
31 ("Flash") wraz z zestawem wrapperów do u¿ywania jej z C++ i
32 popularnymi jêzykami skryptowymi, takimi jak PHP, Python i Ruby.
33
34 %package devel
35 Summary:        Ming development files
36 Summary(pl):    Pliki dla programistów Ming
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}
39
40 %description devel
41 Header files for ming library (C and C++).
42
43 %description devel -l pl
44 Pliki nag³ówkowe dla biblioteki ming (do C i C++).
45
46 %package -n perl-ming
47 Summary:        Ming perl module
48 Summary(pl):    Modu³ perla Ming
49 Group:          Development/Languages/Perl
50 Requires:       %{name} = %{version}
51 Obsoletes:      ming-perl
52
53 %description -n perl-ming
54 Ming perl module - perl wrapper for Ming library.
55
56 %description -n perl-ming -l pl
57 Modu³ perla Ming - perlowy wrapper do biblioteki Ming.
58
59 %package -n python-ming
60 Summary:        Ming Python module
61 Summary(pl):    Modu³ biblioteki Ming dla jêzyka Python
62 Group:          Development/Languages/Perl
63 Requires:       %{name} = %{version}
64 %pyrequires_eq  python-libs
65
66 %description -n python-ming
67 Ming Python module.
68
69 %description -n python-ming -l pl
70 Modu³ biblioteki Ming dla jêzyka Python.
71
72 %package utils
73 Summary:        Ming utilities
74 Summary(pl):    Narzêdzia Ming
75 Group:          Applications/File
76
77 %description utils
78 Ming utilities:
79 - listswf - swf format disassembler
80 - listfdb - show contents of fdb font file
81 - makefdb - rip fdb font definition files out of a generator template
82   file
83 - swftophp - attempt to make a php/ming script out of an swf file
84
85 %description utils -l pl
86 Narzêdzia Ming:
87 - listswf - disasembler plików swf
88 - listfdb - pokazuje zawarto¶æ plików fontów fdb
89 - makefdb - wyci±ga pliki definicji fontów fdb z pliku generatora
90 - swftophp - próbuje zrobiæ skrypt php/ming z pliku swf
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 %build
100 %{__make} \
101         CC="%{__cc}" \
102         CFLAGS="%{rpmcflags} -fPIC"
103
104 #%%{__make} -C java_ext
105
106 cd perl_ext
107 %{__perl} Makefile.PL \
108         INSTALLDIRS=vendor
109 %{__make} OPTIMIZE="%{rpmcflags}"
110 cd ..
111
112 %{__make} -C py_ext \
113         CC="%{__cc}" \
114         CFLAGS="%{rpmcflags}" \
115         PYINCDIR=%{py_incdir}
116
117 #%%{__make} -C rb_ext
118
119 cd util
120 %{__make} listswf listaction swftophp makefdb \
121         CC="%{__cc} %{rpmcflags}"
122
123 %{__cc} %{rpmcflags} -o listfdb listfdb.c
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_bindir},%{py_sitedir}}
128
129 %{__make} install \
130         PREFIX=$RPM_BUILD_ROOT%{_prefix}
131
132 %{__make} -C perl_ext install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %{__make} -C py_ext install \
136         DESTDIR=$RPM_BUILD_ROOT \
137         PYLIBDIR=$RPM_BUILD_ROOT%{py_libdir}
138 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
139 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
140
141 install util/{listswf,listaction,listfdb,makefdb,swftophp} $RPM_BUILD_ROOT%{_bindir}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc CHANGES CREDITS README TODO
152 %attr(755,root,root) %{_libdir}/libming.so.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libming.so
157 %{_includedir}/ming.h
158 %{_includedir}/mingpp.h
159
160 %files -n perl-ming
161 %defattr(644,root,root,755)
162 %doc perl_ext/{README,TODO}
163 %{perl_vendorarch}/SWF.pm
164 %{perl_vendorarch}/SWF
165 %dir %{perl_vendorarch}/auto/SWF
166 %{perl_vendorarch}/auto/SWF/SWF.bs
167 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
168 %{_mandir}/man3/SWF*
169
170 %files -n python-ming
171 %defattr(644,root,root,755)
172 %doc py_ext/{README,TODO}
173 %attr(755,root,root) %{py_sitedir}/*.so
174 %{py_sitedir}/*.py[co]
175
176 %files utils
177 %defattr(644,root,root,755)
178 %doc util/{README,TODO}
179 %attr(755,root,root) %{_bindir}/*
This page took 0.040948 seconds and 4 git commands to generate.