]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- release 2
[packages/ming.git] / ming.spec
1 # TODO:
2 # - package tcl and php extensions somewhere
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Ming - an SWF output library
5 Summary(pl.UTF-8):      Ming - biblioteka do produkcji plików SWF
6 Name:           ming
7 Version:        0.4.3
8 Release:        2
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://dl.sourceforge.net/ming/%{name}-%{version}.tar.gz
12 # Source0-md5:  9578ec38d973adabd9e8a534982da0b9
13 Patch0:         %{name}-build.patch
14 Patch1:         %{name}-perl-shared.patch
15 Patch2:         %{name}-libpng.patch
16 URL:            http://ming.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  freetype-devel
22 BuildRequires:  giflib-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 BuildRequires:  php-devel
27 BuildRequires:  php-program
28 BuildRequires:  python-devel >= 1:2.4
29 BuildRequires:  rpm-perlprov >= 4.0.2-24
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  swig
32 BuildRequires:  swig-tcl
33 BuildRequires:  tcl
34 BuildRequires:  tcl-devel
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Ming is a C library for generating SWF ("Flash") format movies, plus a
40 set of wrappers for using the library from c++ and popular scripting
41 languages like PHP, Python, and Ruby.
42
43 %description -l pl.UTF-8
44 Ming jest biblioteką w C do generowania animacji w formacie SWF
45 ("Flash") wraz z zestawem wrapperów do używania jej z C++ i
46 popularnymi językami skryptowymi, takimi jak PHP, Python i Ruby.
47
48 %package devel
49 Summary:        Ming development files
50 Summary(pl.UTF-8):      Pliki dla programistów Ming
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       giflib-devel
54
55 %description devel
56 Header files for ming library (C and C++).
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe dla biblioteki ming (do C i C++).
60
61 %package static
62 Summary:        Ming static library
63 Summary(pl.UTF-8):      Statyczna biblioteka Ming
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static Ming library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka Ming.
72
73 %package utils
74 Summary:        Ming utilities
75 Summary(pl.UTF-8):      Narzędzia Ming
76 Group:          Applications/File
77
78 %description utils
79 Ming utilities:
80 - listswf - swf format disassembler
81 - listfdb - show contents of fdb font file
82 - makefdb - rip fdb font definition files out of a generator template
83   file
84 - swftophp - attempt to make a php/ming script out of an swf file
85
86 %description utils -l pl.UTF-8
87 Narzędzia Ming:
88 - listswf - disasembler plików swf
89 - listfdb - pokazuje zawartość plików fontów fdb
90 - makefdb - wyciąga pliki definicji fontów fdb z pliku generatora
91 - swftophp - próbuje zrobić skrypt php/ming z pliku swf
92
93 %package -n perl-ming
94 Summary:        Ming perl module
95 Summary(pl.UTF-8):      Moduł perla Ming
96 Group:          Development/Languages/Perl
97 Requires:       %{name} = %{version}-%{release}
98 Obsoletes:      ming-perl
99
100 %description -n perl-ming
101 Ming perl module - perl wrapper for Ming library.
102
103 %description -n perl-ming -l pl.UTF-8
104 Moduł perla Ming - perlowy wrapper do biblioteki Ming.
105
106 %package -n python-ming
107 Summary:        Ming Python module
108 Summary(pl.UTF-8):      Moduł biblioteki Ming dla języka Python
109 Group:          Development/Languages/Perl
110 Requires:       %{name} = %{version}-%{release}
111 %pyrequires_eq  python-libs
112
113 %description -n python-ming
114 Ming Python module.
115
116 %description -n python-ming -l pl.UTF-8
117 Moduł biblioteki Ming dla języka Python.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I macros
128 %{__autoconf}
129 %{__automake}
130 %configure \
131         --enable-perl \
132         --enable-php \
133         --enable-python \
134         --enable-tcl
135
136 %{__make} -j1
137
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{_libdir}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
147 rm $RPM_BUILD_ROOT%{py_sitedir}/ming*.py
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc README TODO
158 %attr(755,root,root) %{_libdir}/libming.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libming.so.1
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libming.so
164 %{_libdir}/libming.la
165 %{_includedir}/ming.h
166 %{_includedir}/mingpp.h
167 %{_pkgconfigdir}/libming.pc
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libming.a
172
173 %files utils
174 %defattr(644,root,root,755)
175 %doc util/{README,TODO}
176 %attr(755,root,root) %{_bindir}/dbl2png
177 %attr(755,root,root) %{_bindir}/gif2dbl
178 %attr(755,root,root) %{_bindir}/gif2mask
179 %attr(755,root,root) %{_bindir}/listaction
180 %attr(755,root,root) %{_bindir}/listaction_d
181 %attr(755,root,root) %{_bindir}/listfdb
182 %attr(755,root,root) %{_bindir}/listjpeg
183 %attr(755,root,root) %{_bindir}/listmp3
184 %attr(755,root,root) %{_bindir}/listswf
185 %attr(755,root,root) %{_bindir}/listswf_d
186 %attr(755,root,root) %{_bindir}/makefdb
187 %attr(755,root,root) %{_bindir}/makeswf
188 %attr(755,root,root) %{_bindir}/ming-config
189 %attr(755,root,root) %{_bindir}/png2dbl
190 %attr(755,root,root) %{_bindir}/raw2adpcm
191 %attr(755,root,root) %{_bindir}/swftocxx
192 %attr(755,root,root) %{_bindir}/swftoperl
193 %attr(755,root,root) %{_bindir}/swftophp
194 %attr(755,root,root) %{_bindir}/swftopython
195 %attr(755,root,root) %{_bindir}/swftotcl
196
197 %files -n perl-ming
198 %defattr(644,root,root,755)
199 %doc perl_ext/{README,TODO}
200 %{perl_vendorarch}/SWF.pm
201 %{perl_vendorarch}/SWF
202 %dir %{perl_vendorarch}/auto/SWF
203 %{perl_vendorarch}/auto/SWF/SWF.bs
204 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
205 %{_mandir}/man3/SWF*
206
207 %files -n python-ming
208 %defattr(644,root,root,755)
209 %doc py_ext/{README,TODO}
210 %attr(755,root,root) %{py_sitedir}/_mingc.so
211 %{py_sitedir}/ming*.py[co]
212 %if "%{py_ver}" > "2.4"
213 %{py_sitedir}/mingc-*.egg-info
214 %endif
This page took 0.090065 seconds and 3 git commands to generate.