]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- release 2.
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Ming - an SWF output library
3 Summary(pl):    Ming - biblioteka do produkcji plików SWF
4 Name:           ming
5 Version:        0.2a
6 Release:        2
7 License:        LGPL
8 Vendor:         Opaque Industries
9 Group:          Libraries
10 Group(de):      Libraries
11 Group(es):      Bibliotecas
12 Group(fr):      Librairies
13 Group(pl):      Biblioteki
14 Group(pt_BR):   Bibliotecas
15 Group(ru):      âÉÂÌÉÏÔÅËÉ
16 Group(uk):      â¦Â̦ÏÔÅËÉ
17 Source0:        http://www.opaque.net/ming/%{name}-%{version}.tgz
18 Patch0:         %{name}-dynamic-exts.patch
19 Patch1:         %{name}-soname.patch
20 URL:            http://www.opaque.net/ming/
21 BuildRequires:  zlib-devel
22 BuildRequires:  rpm-perlprov >= 4.0.2-24
23 BuildRequires:  php-devel >= 4.0.6
24 #BuildRequires: python-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         phpextdir       %(php-config --extension-dir)
28
29 %description
30 Ming is a C library for generating SWF ("Flash") format movies, plus a
31 set of wrappers for using the library from c++ and popular scripting
32 languages like PHP, Python, and Ruby.
33
34 %description -l pl
35 Ming jest bibliotek± w C do generowania animacji w formacie SWF
36 ("Flash") wraz z zestawem wrapperów do u¿ywania jej z C++ i
37 popularnymi jêzykami skryptowymi, takimi jak PHP, Python i Ruby.
38
39 %package devel
40 Summary:        Ming development files
41 Summary(pl):    Pliki dla programistów Ming
42 Group:          Development/Libraries
43 Group(de):      Entwicklung/Libraries
44 Group(es):      Desarrollo/Bibliotecas
45 Group(fr):      Development/Librairies
46 Group(pl):      Programowanie/Biblioteki
47 Group(pt_BR):   Desenvolvimento/Bibliotecas
48 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
49 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
50 Requires:       %{name} = %{version}
51
52 %description devel
53 Header files for ming library (C and C++).
54
55 %description devel -l pl
56 Pliki nag³ówkowe dla biblioteki ming (do C i C++).
57
58 %package -n perl-ming
59 Summary:        Ming perl module
60 Summary(pl):    Modu³ perla Ming
61 Group:          Development/Languages/Perl
62 Group(de):      Entwicklung/Sprachen/Perl
63 Group(pl):      Programowanie/Jêzyki/Perl
64 Requires:       %{name} = %{version}
65 Obsoletes:      ming-perl
66
67 %description -n perl-ming
68 Ming perl module - perl wrapper for Ming library.
69
70 %description -n perl-ming -l pl
71 Modu³ perla Ming - perlowy wrapper do biblioteki Ming.
72
73 %package php
74 Summary:        Ming PHP module
75 Summary(pl):    Modu³ PHP Ming
76 Group:          Libraries
77 Group(de):      Libraries
78 Group(es):      Bibliotecas
79 Group(fr):      Librairies
80 Group(pl):      Biblioteki
81 Group(pt_BR):   Bibliotecas
82 Group(ru):      âÉÂÌÉÏÔÅËÉ
83 Group(uk):      â¦Â̦ÏÔÅËÉ
84 Requires:       %{name} = %{version}
85
86 %description php
87 Ming PHP module.
88
89 %description php -l pl
90 Ming jako modu³ PHP.
91
92 %package utils
93 Summary:        Ming utilities
94 Summary(pl):    Narzêdzia Ming
95 Group:          Applications/File
96 Group(de):      Applikationen/Datei
97 Group(pl):      Aplikacje/Pliki
98
99 %description utils
100 Ming utilities:
101 - listswf - swf format disassembler
102 - listfdb - show contents of fdb font file
103 - makefdb - rip fdb font definition files out of a generator template
104   file
105 - swftophp - attempt to make a php/ming script out of an swf file
106
107 %description utils -l pl
108 Narzêdzia Ming:
109 - listswf - disasembler plików swf
110 - listfdb - pokazuje zawarto¶æ plików fontów fdb
111 - makefdb - wyci±ga pliki definicji fontów fdb z pliku generatora
112 - swftophp - próbuje zrobiæ skrypt php/ming z pliku swf
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %patch1 -p1
118
119 %build
120 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}"
121
122 #%{__make} -C java_ext
123
124 (cd perl_ext
125 perl ./Makefile.PL
126 %{__make} OPTIMIZE="%{rpmcflags}"
127 )
128
129 ln -sf ming-4.0.6.c php_ext/ming.c
130 %{__make} CC="%{__cc} %{rpmcflags}" -C php_ext
131
132 #%{__make} -C py_ext
133 #%{__make} -C rb_ext
134
135 (cd util
136 %{__make} CC="%{__cc} %{rpmcflags}" \
137         listswf listaction swftophp makefdb
138 %{__cc} %{rpmcflags} -o listfdb listfdb.c
139 )
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_bindir}
144
145 %{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
146
147 %{__make} -C perl_ext install DESTDIR=$RPM_BUILD_ROOT
148
149 (cd php_ext
150 install -d $RPM_BUILD_ROOT%{phpextdir}
151 install php_ming.so $RPM_BUILD_ROOT%{phpextdir}
152 )
153
154 install util/{listswf,listaction,listfdb,makefdb,swftophp} $RPM_BUILD_ROOT%{_bindir}
155
156 gzip -9nf CHANGES CREDITS README TODO \
157         perl_ext/{README,TODO} \
158         php_ext/README \
159         py_ext/{README,TODO} \
160         rb_ext/README \
161         util/{README,TODO}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc *.gz
172 %attr(755,root,root) %{_libdir}/libming.so.*.*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libming.so
177 %{_includedir}/ming.h
178 %{_includedir}/mingpp.h
179
180 %files -n perl-ming
181 %defattr(644,root,root,755)
182 %doc perl_ext/*.gz
183 %{perl_sitearch}/SWF.pm
184 %{perl_sitearch}/SWF
185 %dir %{perl_sitearch}/auto/SWF
186 %{perl_sitearch}/auto/SWF/SWF.bs
187 %attr(755,root,root) %{perl_sitearch}/auto/SWF/SWF.so
188 %{_mandir}/man3/SWF*
189
190 %files php
191 %defattr(644,root,root,755)
192 %doc php_ext/*.gz
193 %attr(755,root,root) %{phpextdir}/*.so
194
195 %files utils
196 %defattr(644,root,root,755)
197 %doc util/*.gz
198 %attr(755,root,root) %{_bindir}/*
This page took 0.96749 seconds and 3 git commands to generate.