]> git.pld-linux.org Git - packages/metacity.git/blob - metacity.spec
8fc929ccfda115b738f400ded36da38ad8f09c9b
[packages/metacity.git] / metacity.spec
1 #
2 # Conditional build:
3 %bcond_without  vulkan  # Vulkan support
4
5 Summary:        Metacity window manager
6 Summary(pl.UTF-8):      Zarządca okien Metacity
7 Name:           metacity
8 Version:        3.36.1
9 Release:        1
10 Epoch:          2
11 License:        GPL v2+
12 Group:          X11/Window Managers
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/metacity/3.36/%{name}-%{version}.tar.xz
14 # Source0-md5:  d1171705829bbebd42ac08ec49a9a90a
15 URL:            https://wiki.gnome.org/Projects/Metacity
16 %if %{with vulkan}
17 BuildRequires:  Vulkan-Headers
18 BuildRequires:  Vulkan-Loader-devel
19 %endif
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.14
22 BuildRequires:  gettext-tools >= 0.19.4
23 BuildRequires:  glib2-devel >= 1:2.44.0
24 BuildRequires:  gsettings-desktop-schemas-devel >= 3.3.0
25 BuildRequires:  gtk+3-devel >= 3.22.0
26 BuildRequires:  libcanberra-gtk3-devel
27 BuildRequires:  libgtop-devel >= 2.0
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  pango-devel >= 1:1.2.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.197
32 BuildRequires:  startup-notification-devel >= 0.8
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xorg-lib-libSM-devel
35 BuildRequires:  xorg-lib-libX11-devel
36 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
37 BuildRequires:  xorg-lib-libXcursor-devel
38 BuildRequires:  xorg-lib-libXdamage-devel
39 BuildRequires:  xorg-lib-libXext-devel
40 BuildRequires:  xorg-lib-libXfixes-devel
41 BuildRequires:  xorg-lib-libXinerama-devel
42 BuildRequires:  xorg-lib-libXrandr-devel
43 BuildRequires:  xorg-lib-libXrender-devel
44 BuildRequires:  xz >= 1:4.999.7
45 Requires(post,postun):  glib2 >= 1:2.44.0
46 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
47 Requires:       filesystem >= 3.0-20
48 Requires:       gsettings-desktop-schemas >= 3.3.0
49 Requires:       xorg-lib-libXcomposite >= 0.3
50 Requires:       zenity
51 Provides:       gdm-wm = 3.2.1-1
52 Provides:       gnome-wm
53 Obsoletes:      metacity-themes-Adwaita
54 Obsoletes:      metacity-themes-AgingGorilla
55 Obsoletes:      metacity-themes-Atlanta
56 Obsoletes:      metacity-themes-Bright
57 Obsoletes:      metacity-themes-Crux
58 Obsoletes:      metacity-themes-Esco
59 Obsoletes:      metacity-themes-HighContrast
60 Obsoletes:      metacity-themes-Metabox
61 Obsoletes:      metacity-themes-Simple
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 Metacity is a simple window manager that integrates nicely with GNOME.
66
67 %description -l pl.UTF-8
68 Metacity jest prostym zarządcą okien ładnie integrującym się z GNOME.
69
70 %package libs
71 Summary:        Metacity - libraries
72 Summary(pl.UTF-8):      Metacity - biblioteki
73 Group:          X11/Libraries
74 Requires:       glib2 >= 1:2.44.0
75 Requires:       gtk+3 >= 3.22.0
76 Requires:       pango >= 1:1.2.0
77 Conflicts:      metacity <= 2.6.3-4
78
79 %description libs
80 This package contains libraries for Metacity window manager.
81
82 %description libs -l pl.UTF-8
83 Pakiet zawierający biblioteki zarządcy okien Metacity.
84
85 %package devel
86 Summary:        Metacity - header files
87 Summary(pl.UTF-8):      Metacity - pliki nagłówkowe
88 Group:          X11/Development/Libraries
89 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
90 Requires:       glib2-devel >= 1:2.44.0
91 Requires:       gtk+3-devel >= 3.22.0
92
93 %description devel
94 This package contains header files for Metacity window manager.
95
96 %description devel -l pl.UTF-8
97 Pakiet zawierający pliki nagłówkowe zarządcy okien Metacity.
98
99 %package static
100 Summary:        Static Metacity library
101 Summary(pl.UTF-8):      Statyczna biblioteka Metacity
102 Group:          X11/Development/Libraries
103 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
104
105 %description static
106 Static version of Metacity library.
107
108 %description static -l pl.UTF-8
109 Statyczna wersja biblioteki Metacity.
110
111 %prep
112 %setup -q
113
114 %build
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         ZENITY=/usr/bin/zenity \
122         --disable-silent-rules \
123         %{!?with_vulkan:--disable-vulkan}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_datadir}/xml/metacity
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 cp -p doc/metacity-theme.dtd $RPM_BUILD_ROOT%{_datadir}/xml/metacity
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmetacity.la
137
138 # "metacity" gettext domain, "creating-metacity-themes" help
139 %find_lang %{name} --with-gnome --all-name
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %glib_compile_schemas
146
147 %postun
148 %glib_compile_schemas
149
150 %post   libs -p /sbin/ldconfig
151 %postun libs -p /sbin/ldconfig
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS NEWS README rationales.txt doc/theme-format.txt
156 %attr(755,root,root) %{_bindir}/metacity
157 %attr(755,root,root) %{_bindir}/metacity-message
158 %attr(755,root,root) %{_bindir}/metacity-theme-viewer
159 %attr(755,root,root) %{_bindir}/metacity-window-demo
160 %{_datadir}/glib-2.0/schemas/org.gnome.metacity.gschema.xml
161 %{_datadir}/glib-2.0/schemas/org.gnome.metacity.keybindings.gschema.xml
162 %{_datadir}/glib-2.0/schemas/org.gnome.metacity.theme.gschema.xml
163 # package keybindings dir, not to pull optional gnome-control-center dependency
164 %dir %{_datadir}/gnome-control-center
165 %dir %{_datadir}/gnome-control-center/keybindings
166 %{_datadir}/gnome-control-center/keybindings/50-metacity-*.xml
167 %{_datadir}/xml/metacity
168 %{_datadir}/%{name}
169 %{_desktopdir}/metacity.desktop
170 %{_mandir}/man1/metacity*.1*
171
172 %files libs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libmetacity.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libmetacity.so.1
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc ChangeLog HACKING doc/dialogs.txt
180 %attr(755,root,root) %{_libdir}/libmetacity.so
181 %{_includedir}/metacity
182 %{_pkgconfigdir}/libmetacity.pc
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libmetacity.a
This page took 0.051885 seconds and 2 git commands to generate.