]> git.pld-linux.org Git - packages/meson.git/blob - meson.spec
up to 1.3.0
[packages/meson.git] / meson.spec
1 Summary:        High productivity build system
2 Summary(pl.UTF-8):      System budowania o dużej produktywności
3 Name:           meson
4 Version:        1.3.0
5 Release:        1
6 License:        Apache v2.0
7 Group:          Development/Tools
8 #Source0Download: https://github.com/mesonbuild/meson/releases/
9 Source0:        https://github.com/mesonbuild/meson/releases/download/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  35dc15e4f94ca5fd30dbe2d88a672254
11 Patch0:         %{name}-gtkdocdir.patch
12 Patch1:         rust-proc-macro-filter-out-target.patch
13 URL:            https://mesonbuild.com/
14 BuildRequires:  ninja >= 1.8.2
15 BuildRequires:  python3 >= 1:3.7
16 BuildRequires:  python3-modules >= 1:3.7
17 BuildRequires:  python3-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  sed >= 4.0
21 Requires:       python3-devel-tools >= 1:3.7
22 Requires:       python3-libs >= 1:3.7
23 Requires:       python3-modules >= 1:3.7
24 Requires:       python3-setuptools
25 Conflicts:      ninja < 1.8.2
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Meson is a build system designed to optimize programmer productivity.
31 It aims to do this by providing simple, out-of-the-box support for
32 modern software development tools and practices, such as unit tests,
33 coverage reports, Valgrind, CCache and the like.
34
35 %description -l pl.UTF-8
36 Meson to system budowania zaprojektowany z myślą o optymalizacji
37 produktywności programisty. Celem jest dostarczenie prostej, od razu
38 działającej obsługi nowoczesnych narzędzi i praktyk programistycznych,
39 takich jak testy jednostkowe, raporty pokrycia, Valgrind, CCache itp.
40
41 %package polkit
42 Summary:        PolKit integration - handle projects installation via Meson
43 Summary(pl.UTF-8):      Integracja z PolKitem - obsługa instalowania projektów przy użyciu Mesona
44 Group:          Development/Tools
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       polkit
47
48 %description polkit
49 PolKit integration - handle projects installation via Meson.
50
51 %description polkit -l pl.UTF-8
52 Integracja z PolKitem - obsługa instalowania projektów przy użyciu
53 Mesona.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59
60 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
61         meson.py
62
63 %build
64 %py3_build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %py3_install
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README.md
77 %attr(755,root,root) %{_bindir}/meson
78 %{_mandir}/man1/meson.1*
79 %{py3_sitescriptdir}/meson-%{version}-py*.egg-info
80 %{py3_sitescriptdir}/mesonbuild
81
82 %files polkit
83 %defattr(644,root,root,755)
84 %{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
This page took 0.058217 seconds and 3 git commands to generate.