]> git.pld-linux.org Git - packages/mesa-demos.git/blob - mesa-demos.spec
21e06174374992ae7beb7eaa089aeb3b97c90bf4
[packages/mesa-demos.git] / mesa-demos.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL utilities
4 %bcond_without  gles1   # GLESv1 utilities
5 %bcond_without  gles2   # GLESv2 utilities
6 %bcond_with     openvg  # OpenVG utilities
7 %bcond_without  wayland # Wayland support
8
9 Summary:        Mesa Demos source code
10 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
11 Name:           mesa-demos
12 Version:        8.2.0
13 Release:        3
14 License:        various (MIT, SGI, GPL - see copyright notes in sources)
15 Group:          Development/Libraries
16 Source0:        ftp://ftp.freedesktop.org/pub/mesa/demos/%{version}/%{name}-%{version}.tar.bz2
17 # Source0-md5:  72613a2c8c013716db02e3ff59d29061
18 URL:            http://www.mesa3d.org/
19 %{?with_egl:BuildRequires:      EGL-devel}
20 BuildRequires:  Mesa-libgbm-devel
21 %{?with_wayland:BuildRequires:  Mesa-libwayland-egl-devel}
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  OpenGL-glut-devel
25 %{?with_gles1:BuildRequires:    OpenGLESv1-devel}
26 %{?with_gles2:BuildRequires:    OpenGLESv2-devel}
27 %{?with_openvg:BuildRequires:   OpenVG-devel}
28 BuildRequires:  freetype-devel >= 2
29 BuildRequires:  glew-devel >= 1.5.4
30 %{?with_egl:BuildRequires:      libdrm-devel}
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-pythonprov
33 %{?with_wayland:BuildRequires:  wayland-devel}
34 BuildRequires:  xorg-lib-libX11-devel
35 BuildRequires:  xorg-lib-libXext-devel
36 Requires:       OpenGL-devel
37 Requires:       OpenGL-glut-devel
38 Obsoletes:      Mesa-demos
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Demonstration programs for the Mesa libraries in source code form.
43
44 %description -l pl.UTF-8
45 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
46
47 %package -n mesa-utils
48 Summary:        OpenGL utilities from Mesa3D
49 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
50 License:        MIT
51 Group:          X11/Applications/Graphics
52 Obsoletes:      Mesa-utils
53
54 %description -n mesa-utils
55 OpenGL utilities from Mesa3D: glxgears and glxinfo.
56
57 %description -n mesa-utils -l pl.UTF-8
58 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
59
60 %package -n mesa-utils-egl
61 Summary:        EGL utilities from Mesa3D
62 Summary(pl.UTF-8):      Programy narzędziowe EGL z projektu Mesa3D
63 License:        MIT
64 Group:          Applications/Graphics
65
66 %description -n mesa-utils-egl
67 EGL utilities from Mesa3D: eglgears and eglinfo.
68
69 %description -n mesa-utils-egl -l pl.UTF-8
70 Programy narzędziowe EGL z projektu Mesa3D: eglgears i eglinfo.
71
72 %package -n mesa-utils-gles1
73 Summary:        OpenGLESv1 utilities from Mesa3D
74 Summary(pl.UTF-8):      Programy narzędziowe OpenGLESv1 z projektu Mesa3D
75 License:        MIT
76 Group:          Applications/Graphics
77
78 %description -n mesa-utils-gles1
79 OpenGLESv1 utilities from Mesa3D: es1gears and es1_info.
80
81 %description -n mesa-utils-gles1 -l pl.UTF-8
82 Programy narzędziowe OpenGLESv1 z projektu Mesa3D: es1gears i
83 es1_info.
84
85 %package -n mesa-utils-gles2
86 Summary:        OpenGLESv2 utilities from Mesa3D
87 Summary(pl.UTF-8):      Programy narzędziowe OpenGLESv2 z projektu Mesa3D
88 License:        MIT
89 Group:          Applications/Graphics
90
91 %description -n mesa-utils-gles2
92 OpenGLESv2 utilities from Mesa3D: es2gears and es2_info.
93
94 %description -n mesa-utils-gles2 -l pl.UTF-8
95 Programy narzędziowe OpenGLESv2 z projektu Mesa3D: es2gears i
96 es2_info.
97
98 %package -n mesa-utils-openvg
99 Summary:        OpenVG utilities from Mesa3D
100 Summary(pl.UTF-8):      Programy narzędziowe OpenVG z projektu Mesa3D
101 License:        MIT
102 Group:          Applications/Graphics
103
104 %description -n mesa-utils-openvg
105 OpenVG utilities from Mesa3D.
106
107 %description -n mesa-utils-openvg -l pl.UTF-8
108 Programy narzędziowe OpenVG z projektu Mesa3D.
109
110 %prep
111 %setup -q
112
113 %build
114 %configure \
115         %{!?with_egl:--disable-egl} \
116         %{!?with_gles1:--disable-gles1} \
117         %{!?with_gles2:--disable-gles2} \
118         --disable-silent-rules \
119         %{!?with_openvg:--disable-vg} \
120         %{?with_egl:--enable-wayland}
121
122 # we only want glxinfo and glxgears to be built here
123 %{__make} -C src/xdemos
124
125 %if %{with egl}
126 %{__make} -C src/egl
127 %endif
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
132
133 install -p src/xdemos/{glxinfo,glxgears} $RPM_BUILD_ROOT%{_bindir}
134 %if %{with egl}
135 install -p src/egl/opengl/{eglinfo,eglgears_screen,eglgears_x11,peglgears} $RPM_BUILD_ROOT%{_bindir}
136 %if %{with gles1}
137 install -p src/egl/opengles1/es1_info $RPM_BUILD_ROOT%{_bindir}
138 install -p src/egl/opengles1/gears_screen $RPM_BUILD_ROOT%{_bindir}/es1gears_screen
139 install -p src/egl/opengles1/gears_x11 $RPM_BUILD_ROOT%{_bindir}/es1gears_x11
140 %endif
141 %if %{with gles2}
142 install -p src/egl/opengles2/{es2_info,es2gears_screen,es2gears_x11} $RPM_BUILD_ROOT%{_bindir}
143 %if %{with wayland}
144 install -p src/egl/opengles2/es2gears_wayland $RPM_BUILD_ROOT%{_bindir}
145 %endif
146 %endif
147 %if %{with openvg}
148 install -p src/egl/openvg/{lion,sp}_{screen,x11} $RPM_BUILD_ROOT%{_bindir}
149 %endif
150 %endif
151
152 cp -a * $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
153 %{__make} -C $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} distclean
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files
159 %defattr(644,root,root,755)
160 %{_examplesdir}/%{name}-%{version}
161
162 %files -n mesa-utils
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/glxgears
165 %attr(755,root,root) %{_bindir}/glxinfo
166
167 %if %{with egl}
168 %files -n mesa-utils-egl
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/eglgears_screen
171 %attr(755,root,root) %{_bindir}/eglgears_x11
172 %attr(755,root,root) %{_bindir}/eglinfo
173 %attr(755,root,root) %{_bindir}/peglgears
174 %endif
175
176 %if %{with egl} && %{with gles1}
177 %files -n mesa-utils-gles1
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/es1_info
180 %attr(755,root,root) %{_bindir}/es1gears_screen
181 %attr(755,root,root) %{_bindir}/es1gears_x11
182 %endif
183
184 %if %{with egl} && %{with gles2}
185 %files -n mesa-utils-gles2
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/es2_info
188 %attr(755,root,root) %{_bindir}/es2gears_screen
189 %attr(755,root,root) %{_bindir}/es2gears_x11
190 %if %{with wayland}
191 %attr(755,root,root) %{_bindir}/es2gears_wayland
192 %endif
193 %endif
194
195 %if %{with egl} && %{with openvg}
196 %files -n mesa-utils-openvg
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/lion_screen
199 %attr(755,root,root) %{_bindir}/lion_x11
200 %attr(755,root,root) %{_bindir}/sp_screen
201 %attr(755,root,root) %{_bindir}/sp_x11
202 %endif
This page took 0.048388 seconds and 2 git commands to generate.