]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- added matroska support, release 4
[packages/mediastreamer.git] / mediastreamer.spec
1 # TODO:
2 # - dtls (polarssl/mbedtls >= 1.4 with DTLS-SRTP support, not released yet)
3 #
4 # Conditional build:
5 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
6 %bcond_without  srtp            # SRTP (secure RTP) support
7 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
8 %bcond_without  matroska        # Matroska support via libebml2/libmatroska2
9 %bcond_without  opengl          # X11+OpenGL rendering support
10 %bcond_with     pcap            # audio playing from PCAP files
11 # audio I/O
12 %bcond_without  alsa            # ALSA sound I/O support
13 %bcond_with     arts            # aRts sound I/O support
14 %bcond_with     portaudio       # PortAudio sound I/O support
15 %bcond_without  pulseaudio      # PulseAudio sound I/O support
16 #
17 Summary:        Audio/Video real-time streaming
18 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
19 Name:           mediastreamer
20 Version:        2.11.2
21 Release:        4
22 License:        GPL v2+
23 Group:          Libraries
24 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
25 # Source0-md5:  8b654c3e8938d50df9e83d2e353888a6
26 Patch0:         %{name}-imagedir.patch
27 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
28 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
29 BuildRequires:  SDL-devel >= 1.2.0
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake >= 1:1.9
34 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
35 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 1.0.0}
36 BuildRequires:  doxygen
37 # libavcodec >= 51.0.0, libswscale >= 0.7.0
38 BuildRequires:  ffmpeg-devel
39 BuildRequires:  gettext-tools
40 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
41 BuildRequires:  jack-audio-connection-kit-devel
42 BuildRequires:  intltool >= 0.40
43 BuildRequires:  libgsm-devel
44 %{?with_pcap:BuildRequires:     libpcap-devel}
45 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
46 BuildRequires:  libtool >= 2:2
47 BuildRequires:  libupnp-devel >= 1.6
48 BuildRequires:  libupnp-devel < 1.7
49 BuildRequires:  libv4l-devel
50 BuildRequires:  libvpx-devel >= 0.9.6
51 %{?with_matroska:BuildRequires: matroska-foundation-devel}
52 BuildRequires:  opus-devel >= 0.9.0
53 BuildRequires:  ortp-devel >= 0.24.0
54 BuildRequires:  pkgconfig
55 BuildRequires:  polarssl-devel
56 %{?with_portaudio:BuildRequires:        portaudio-devel}
57 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  spandsp-devel >= 0.0.6
60 BuildRequires:  speex-devel >= 1:1.2-beta3
61 BuildRequires:  speexdsp-devel >= 1.2-beta3
62 %{?with_srtp:BuildRequires:     srtp-devel}
63 BuildRequires:  xorg-lib-libX11-devel
64 BuildRequires:  xorg-lib-libXv-devel
65 BuildRequires:  xxd
66 %{?with_bcg729:Requires:        bcg729 >= 1.0}
67 %{?with_zrtp:Requires:  bzrtp >= 1.0.0}
68 %{?with_opengl:Requires:        glew >= 1.5}
69 Requires:       libtheora >= 1.0-0.alpha7
70 Requires:       libupnp >= 1.6
71 Requires:       libvpx >= 0.9.6
72 Requires:       opus >= 0.9.0
73 Requires:       ortp >= 0.24.0
74 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
75 Requires:       spandsp >= 0.0.6
76 Requires:       speex >= 1:1.2-beta3
77 Requires:       speexdsp >= 1.2-beta3
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Mediastreamer2 is a GPL licensed library to make audio and video
82 real-time streaming and processing. Written in pure C, it is based
83 upon the oRTP library.
84
85 %description -l pl.UTF-8
86 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
87 przesyłania i przetwarzania strumieni audio/video w czasie
88 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
89
90 %package devel
91 Summary:        Header files and development documentation for mediastreamer library
92 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 %{?with_opengl:Requires:        OpenGL-devel}
96 %{?with_alsa:Requires:  alsa-lib-devel}
97 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
98 %{?with_zrtp:Requires:  bzrtp-devel >= 1.0.0}
99 Requires:       ffmpeg-devel
100 %{?with_opengl:Requires:        glew-devel >= 1.5}
101 Requires:       libtheora-devel >= 1.0-0.alpha7
102 Requires:       libupnp-devel >= 1.6
103 Requires:       libupnp-devel < 1.7
104 Requires:       libv4l-devel
105 Requires:       libvpx-devel >= 0.9.6
106 %{?with_matroska:Requires:      matroska-foundation-devel}
107 Requires:       opus-devel >= 0.9.0
108 Requires:       ortp-devel >= 0.24.0
109 Requires:       polarssl-devel
110 %{?with_portaudio:Requires:     portaudio-devel}
111 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
112 Requires:       spandsp-devel >= 0.0.6
113 Requires:       speex-devel >= 1:1.2-beta3
114 Requires:       speexdsp-devel >= 1.2-beta3
115 %{?with_srtp:Requires:  srtp-devel}
116 Requires:       xorg-lib-libX11-devel
117 Requires:       xorg-lib-libXv-devel
118
119 %description devel
120 Header files and development documentation for mediastreamer library.
121
122 %description devel -l pl.UTF-8
123 Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer.
124
125 %package static
126 Summary:        Static mediastreamer library
127 Summary(pl.UTF-8):      Statyczna biblioteka mediastreamer
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130
131 %description static
132 Static mediastreamer library.
133
134 %description static -l pl.UTF-8
135 Statyczna biblioteka mediastreamer.
136
137 %prep
138 %setup -q
139 %patch0 -p1
140
141 %build
142 %{__libtoolize}
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 %configure \
148         --enable-alsa%{!?with_alsa:=no} \
149         %{?with_arts:--enable-artsc} \
150         %{?with_bcg729:--enable-bcg729} \
151         --enable-external-ortp \
152         %{!?with_opengl:--disable-glx} \
153         %{!?with_matroska:--disable-matroska} \
154         %{?with_pcap:--enable-pcap} \
155         %{?with_portaudio:--enable-portaudio} \
156         --enable-pulseaudio%{!?with_pulseaudio:=no} \
157         --disable-silent-rules \
158         --enable-static \
159         %{!?with_zrtp:--disable-zrtp} \
160         %{!?with_srtp:--with-srtp=none}
161
162 %{__make}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 # for external plugins
171 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
172
173 # Remove duplicated documentation
174 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
175
176 %find_lang %{name}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files -f %{name}.lang
185 %defattr(644,root,root,755)
186 %doc AUTHORS ChangeLog NEWS README
187 %attr(755,root,root) %{_bindir}/mediastream
188 %attr(755,root,root) %{_bindir}/msaudiocmp
189 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
190 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.4
192 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
193 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.4
194 %dir %{_libdir}/mediastreamer
195 %dir %{_libdir}/mediastreamer/plugins
196 %{_pixmapsdir}/%{name}
197
198 %files devel
199 %defattr(644,root,root,755)
200 %doc help/doc/html
201 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
202 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
203 %{_libdir}/libmediastreamer_base.la
204 %{_libdir}/libmediastreamer_voip.la
205 %{_includedir}/mediastreamer2
206 %{_pkgconfigdir}/mediastreamer.pc
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libmediastreamer_base.a
211 %{_libdir}/libmediastreamer_voip.a
This page took 0.050426 seconds and 4 git commands to generate.