]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- rel 2
[packages/mediastreamer.git] / mediastreamer.spec
1 # TODO:
2 # - libebml2, libmatroska2 (Matroska support)
3 # - dtls (polarssl/mbedtls >= 1.4 when released)
4 #
5 # Conditional build:
6 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
7 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
8 %bcond_without  opengl          # X11+OpenGL rendering support
9 %bcond_with     pcap            # audio playing from PCAP files
10 %bcond_without  srtp            # SRTP (secure RTP) support
11 # audio I/O
12 %bcond_without  alsa            # ALSA sound I/O support
13 %bcond_with     arts            # aRts sound I/O support
14 %bcond_with     portaudio       # PortAudio sound I/O support
15 %bcond_without  pulseaudio      # PulseAudio sound I/O support
16 #
17 Summary:        Audio/Video real-time streaming
18 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
19 Name:           mediastreamer
20 Version:        2.11.2
21 Release:        2
22 License:        GPL v2+
23 Group:          Libraries
24 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
25 # Source0-md5:  8b654c3e8938d50df9e83d2e353888a6
26 Patch0:         %{name}-imagedir.patch
27 URL:            http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
28 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
29 BuildRequires:  SDL-devel >= 1.2.0
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake >= 1:1.9
34 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
35 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 1.0.0}
36 BuildRequires:  doxygen
37 # libavcodec >= 51.0.0, libswscale >= 0.7.0
38 BuildRequires:  ffmpeg-devel
39 BuildRequires:  gettext-tools
40 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
41 BuildRequires:  jack-audio-connection-kit-devel
42 BuildRequires:  intltool >= 0.40
43 BuildRequires:  libgsm-devel
44 %{?with_pcap:BuildRequires:     libpcap-devel}
45 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
46 BuildRequires:  libtool >= 2:2
47 BuildRequires:  libupnp-devel >= 1.6
48 BuildRequires:  libupnp-devel < 1.7
49 BuildRequires:  libv4l-devel
50 BuildRequires:  libvpx-devel >= 0.9.6
51 BuildRequires:  opus-devel >= 0.9.0
52 BuildRequires:  ortp-devel >= 0.24.0
53 BuildRequires:  pkgconfig
54 BuildRequires:  polarssl-devel
55 %{?with_portaudio:BuildRequires:        portaudio-devel}
56 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  spandsp-devel >= 0.0.6
59 BuildRequires:  speex-devel >= 1:1.2-beta3
60 BuildRequires:  speexdsp-devel >= 1.2-beta3
61 %{?with_srtp:BuildRequires:     srtp-devel}
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRequires:  xorg-lib-libXv-devel
64 BuildRequires:  xxd
65 %{?with_bcg729:Requires:        bcg729 >= 1.0}
66 %{?with_zrtp:Requires:  bzrtp >= 1.0.0}
67 %{?with_opengl:Requires:        glew >= 1.5}
68 Requires:       libtheora >= 1.0-0.alpha7
69 Requires:       libupnp >= 1.6
70 Requires:       libvpx >= 0.9.6
71 Requires:       opus >= 0.9.0
72 Requires:       ortp >= 0.24.0
73 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
74 Requires:       spandsp >= 0.0.6
75 Requires:       speex >= 1:1.2-beta3
76 Requires:       speexdsp >= 1.2-beta3
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 Mediastreamer2 is a GPL licensed library to make audio and video
81 real-time streaming and processing. Written in pure C, it is based
82 upon the oRTP library.
83
84 %description -l pl.UTF-8
85 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
86 przesyłania i przetwarzania strumieni audio/video w czasie
87 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
88
89 %package devel
90 Summary:        Header files and development documentation for mediastreamer library
91 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 %{?with_opengl:Requires:        OpenGL-devel}
95 %{?with_alsa:Requires:  alsa-lib-devel}
96 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
97 %{?with_zrtp:Requires:  bzrtp-devel >= 1.0.0}
98 Requires:       ffmpeg-devel
99 %{?with_opengl:Requires:        glew-devel >= 1.5}
100 Requires:       libtheora-devel >= 1.0-0.alpha7
101 Requires:       libupnp-devel >= 1.6
102 Requires:       libupnp-devel < 1.7
103 Requires:       libv4l-devel
104 Requires:       libvpx-devel >= 0.9.6
105 Requires:       opus-devel >= 0.9.0
106 Requires:       ortp-devel >= 0.24.0
107 Requires:       polarssl-devel
108 %{?with_portaudio:Requires:     portaudio-devel}
109 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
110 Requires:       spandsp-devel >= 0.0.6
111 Requires:       speex-devel >= 1:1.2-beta3
112 Requires:       speexdsp-devel >= 1.2-beta3
113 %{?with_srtp:Requires:  srtp-devel}
114 Requires:       xorg-lib-libX11-devel
115 Requires:       xorg-lib-libXv-devel
116
117 %description devel
118 Header files and development documentation for mediastreamer library.
119
120 %description devel -l pl.UTF-8
121 Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer.
122
123 %package static
124 Summary:        Static mediastreamer library
125 Summary(pl.UTF-8):      Statyczna biblioteka mediastreamer
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128
129 %description static
130 Static mediastreamer library.
131
132 %description static -l pl.UTF-8
133 Statyczna biblioteka mediastreamer.
134
135 %prep
136 %setup -q
137 %patch0 -p1
138
139 %build
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoconf}
143 %{__autoheader}
144 %{__automake}
145 %configure \
146         --enable-alsa%{!?with_alsa:=no} \
147         %{?with_arts:--enable-artsc} \
148         %{?with_bcg729:--enable-bcg729} \
149         --enable-external-ortp \
150         %{!?with_opengl:--disable-glx} \
151         %{?with_pcap:--enable-pcap} \
152         %{?with_portaudio:--enable-portaudio} \
153         --enable-pulseaudio%{!?with_pulseaudio:=no} \
154         --disable-silent-rules \
155         --enable-static \
156         %{!?with_zrtp:--disable-zrtp} \
157         %{!?with_srtp:--with-srtp=none}
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 # for external plugins
168 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
169
170 # Remove duplicated documentation
171 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
172
173 %find_lang %{name}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc AUTHORS ChangeLog NEWS README
184 %attr(755,root,root) %{_bindir}/mediastream
185 %attr(755,root,root) %{_bindir}/msaudiocmp
186 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
187 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.4
189 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.4
191 %dir %{_libdir}/mediastreamer
192 %dir %{_libdir}/mediastreamer/plugins
193 %{_pixmapsdir}/%{name}
194
195 %files devel
196 %defattr(644,root,root,755)
197 %doc help/doc/html
198 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
199 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
200 %{_libdir}/libmediastreamer_base.la
201 %{_libdir}/libmediastreamer_voip.la
202 %{_includedir}/mediastreamer2
203 %{_pkgconfigdir}/mediastreamer.pc
204
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/libmediastreamer_base.a
208 %{_libdir}/libmediastreamer_voip.a
This page took 0.068476 seconds and 4 git commands to generate.