]> git.pld-linux.org Git - packages/mdk.git/blob - mdk.spec
rebuild with guile 3.0
[packages/mdk.git] / mdk.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # GUI (gmixvm)
4
5 Summary:        GNU MIX Development Kit
6 Summary(pl.UTF-8):      GNU MIX Development Kit - zestaw programistyczny dla języka MIXAL
7 Name:           mdk
8 Version:        1.2.11
9 Release:        2
10 License:        GPL v2
11 Group:          Applications
12 Source0:        https://ftp.gnu.org/gnu/mdk/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  5598a4c20a0c5c670e25a7bbda6d8f3e
14 Patch0:         %{name}-gettext.patch
15 Patch1:         %{name}-info.patch
16 URL:            http://www.gnu.org/software/mdk/mdk.html
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  flex >= 2.5
20 BuildRequires:  gettext-tools >= 0.14
21 BuildRequires:  glib2-devel >= 1:2.4.0
22 # 2.0, 2.2 or 3.0
23 BuildRequires:  guile-devel >= 2.0
24 BuildRequires:  intltool >= 0.37
25 BuildRequires:  ncurses-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  readline-devel
28 BuildRequires:  texinfo
29 %if %{with gui}
30 BuildRequires:  gtk+2-devel >= 2:2.6.0
31 BuildRequires:  libglade2-devel >= 1:2.4.0
32 BuildRequires:  pango-devel >= 1:1.4
33 %endif
34 Requires:       glib2 >= 1:2.4.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 MDK stands for MIX Development Kit, and provides tools for developing
39 and executing, in a MIX virtual machine, MIXAL programs.
40
41 The MIX is Donald Knuth's mythical computer, described in the first
42 volume of The Art of Computer Programming, which is programmed using
43 MIXAL, the MIX assembly language.
44
45 MDK includes a MIXAL assembler (mixasm) and a MIX virtual machine
46 (mixvm) with a command line interface. In addition, a GTK+ GUI to
47 mixvm, called gmixvm, is provided; and, for Emacs guy, exists emacs
48 mode, which allows running mixvm inside an Emacs GUD buffer.
49
50 %description -l pl.UTF-8
51 MDK oznacza MIX Development Kit (zestaw programistyczny MIX) i
52 dostarcza narzędzia do tworzenia i wykonywania programów w języku
53 MIXAL na wirtualnej maszynie MIX.
54
55 MIX to mityczny komputer Donalda Knutha opisany w pierwszej części
56 "The Art of Computer Programming", którą programuje się w języku
57 asemblera MIXAL (MIX assembly language).
58
59 MDK zawiera asembler MIXAL (mixasm) oraz maszynę wirtualną MIX (mixvm)
60 z interfejsem linii poleceń. Ponadto dostarczony jest graficzny
61 interfejs GTK+ do mixvm o nazwie gmixvm; a dla emacsowców istnieje
62 tryb Emacsa pozwalający na uruchomienie mixvm wewnątrz bufora GUD
63 Emacsa.
64
65 %package gui
66 Summary:        gmixvm - GUI for mixvm (MIX virtual machine)
67 Summary(pl.UTF-8):      gmixvm - GUI do mixvm (maszyny wirtualnej MIX)
68 Group:          X11/Applications
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       gtk+2 >= 2:2.6.0
71 Requires:       libglade2 >= 1:2.4.0
72 Requires:       pango >= 1:1.4
73
74 %description gui
75 gmixvm - GUI for mixvm (MIX virtual machine).
76
77 %description gui -l pl.UTF-8
78 gmixvm - GUI do mixvm (maszyny wirtualnej MIX).
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 %{__intltoolize}
87 %{__libtoolize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         %{!?with_gui:--disable-gui}
94
95 %{__make}
96
97 ln -s doc/img
98 %{__make} -C doc html
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %find_lang %{name}
107 %{__rm} img/Makefile*
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/postshell
113 -/usr/sbin/fix-info-dir -c %{_infodir}
114
115 %postun -p /sbin/postshell
116 -/usr/sbin/fix-info-dir -c %{_infodir}
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README THANKS doc/{img,mdk.html}
121 %attr(755,root,root) %{_bindir}/mixasm
122 %attr(755,root,root) %{_bindir}/mixguile
123 %attr(755,root,root) %{_bindir}/mixvm
124 %dir %{_datadir}/%{name}
125 %{_datadir}/%{name}/mixal-mode.el
126 %{_datadir}/%{name}/mixvm.el
127 %{_datadir}/%{name}/mixguile*.scm
128 %{_infodir}/mdk.info*
129
130 %if %{with gui}
131 %files gui
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/gmixvm
134 %{_datadir}/%{name}/mixgtk.glade
135 %endif
This page took 0.087914 seconds and 3 git commands to generate.