]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
- updated to 0.6.1
[packages/mdds.git] / mdds.spec
1 Summary:        A collection of multi-dimensional data structures and indexing algorithms
2 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
3 Name:           mdds
4 Version:        0.6.1
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 #Source0Download: https://code.google.com/p/multidimalgorithm/downloads/list
9 Source0:        http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
10 # Source0-md5:  9f9e15966b5624834157fe3d748312bc
11 URL:            http://code.google.com/p/multidimalgorithm/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  boost-devel >= 1.39
14 BuildRequires:  sed >= 4.0
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 A collection of multi-dimensional data structures and indexing
20 algorithms.
21
22 It implements the following data structures:
23 - segment tree
24 - flat segment tree
25 - rectangle set
26 - point quad tree
27 - mixed type matrix
28
29 %description -l pl.UTF-8
30 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
31 Zaimplementowane są następujące struktury danych:
32 - drzewo segmentowe
33 - płaskie drzewo segmentowe
34 - zbiór prostokątów
35 - drzewo czwórkowe (quadtree) dla punktów
36 - macierz mieszana
37
38 %package devel
39 Summary:        A collection of multi-dimensional data structures and indexing algorithms
40 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
41 Group:          Development/Libraries
42 Requires:       boost-devel >= 1.39
43
44 %description devel
45 A collection of multi-dimensional data structures and indexing
46 algorithms.
47
48 It implements the following data structures:
49 - segment tree
50 - flat segment tree
51 - rectangle set
52 - point quad tree
53 - mixed type matrix
54
55 %description devel -l pl.UTF-8
56 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
57 Zaimplementowane są następujące struktury danych:
58 - drzewo segmentowe
59 - płaskie drzewo segmentowe
60 - zbiór prostokątów
61 - drzewo czwórkowe (quadtree) dla punktów
62 - macierz mieszana
63
64 %prep
65 %setup -q -n %{name}_%{version}
66
67 # this is only used in tests
68 sed -i -e '/^CPPFLAGS_NODEBUG/s/-Wall -Os -g/%{rpmcflags} -Wall/' configure.ac
69
70 %build
71 %{__autoconf}
72 # we can switch from boost to c++0x (the default) if sufficiently new C++11 compliant g++ is enforced
73 %configure \
74         --with-hash-container=boost
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_includedir}/mdds
80 cp -a include/mdds/* $RPM_BUILD_ROOT%{_includedir}/mdds
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files devel
86 %defattr(644,root,root,755)
87 %doc AUTHORS COPYING NEWS README
88 %{_includedir}/mdds
This page took 0.034309 seconds and 3 git commands to generate.