]> git.pld-linux.org Git - packages/matio.git/blob - matio.spec
b46acdb7243245a4e231573ac9b5cb1e5ce3c037
[packages/matio.git] / matio.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  fortran         # Fortran interface
5 #
6 Summary:        MATIO - Matlab MAT file I/O library
7 Summary(pl.UTF-8):      MATIO - biblioteka wejścia/wyjścia do plików MAT (Matlaba)
8 Name:           matio
9 Version:        1.3.4
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/matio/%{name}-%{version}.tar.gz
14 # Source0-md5:  a91208cf18f2456a5855bc1a9fdb90fd
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-ac.patch
17 Patch2:         %{name}-separate-fortran.patch
18 URL:            http://matio.sourceforge.net/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1:1.8
21 %{?with_apidocs:BuildRequires:  doxygen}
22 %{?with_fortran:BuildRequires:  gcc-fortran}
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 %if %{with apidocs}
27 BuildRequires:  doxygen
28 BuildRequires:  texlive-format-pdflatex
29 BuildRequires:  texlive-latex-ams
30 BuildRequires:  texlive-makeindex
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libmatio is an open-source library for reading/writing Matlab MAT
36 files. This library is designed for use by programs/libraries that do
37 not have access or do not want to rely on Matlab's libmat shared
38 library.
39
40 %description -l pl.UTF-8
41 libmatio to mająca otwarte źródłą biblioteka do odczytu i zapisu
42 plików MAT (z programu Matlab). Jest przeznaczona dla programów i
43 bibliotek nie mających dostępu albo nie chcących polegać na bibliotece
44 współdzielonej libmat z Matlaba.
45
46 %package devel
47 Summary:        Header files for MATIO library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MATIO
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       zlib-devel
52
53 %description devel
54 Header files for MATIO library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki MATIO.
58
59 %package static
60 Summary:        Static MATIO library
61 Summary(pl.UTF-8):      Statyczna biblioteka MATIO
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static MATIO library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka MATIO.
70
71 %package fortran
72 Summary:        Fortran interface for MATIO library
73 Summary(pl.UTF-8):      Interfejs Fortrana do biblioteki MATIO
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description fortran
78 Fortran interface for MATIO library.
79
80 %description fortran -l pl.UTF-8
81 Interfejs Fortrana do biblioteki MATIO.
82
83 %package fortran-devel
84 Summary:        Header file for Fortran interface for MATIO library
85 Summary(pl.UTF-8):      Plik nagłówkowy interfejsu Fortrana do biblioteki MATIO
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       %{name}-fortran = %{version}-%{release}
89
90 %description fortran-devel
91 Header file for Fortran interface for MATIO library.
92
93 %description fortran-devel -l pl.UTF-8
94 Plik nagłówkowy interfejsu Fortrana do biblioteki MATIO.
95
96 %package fortran-static
97 Summary:        Fortran interface for MATIO library - static library
98 Summary(pl.UTF-8):      Interfejs Fortrana do biblioteki MATIO - biblioteka statyczna
99 Group:          Development/Libraries
100 Requires:       %{name}-fortran-devel = %{version}-%{release}
101
102 %description fortran-static
103 Fortran interface for MATIO library - static library.
104
105 %description fortran-static -l pl.UTF-8
106 Interfejs Fortrana do biblioteki MATIO - biblioteka statyczna.
107
108 %package apidocs
109 Summary:        MATIO API documentation
110 Summary(pl.UTF-8):      Dokumentacja API biblioteki MATIO
111 Group:          Documentation
112
113 %description apidocs
114 API and internal documentation for MATIO library.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API biblioteki MATIO.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I config
128 %{__autoconf}
129 %{__automake}
130 %configure \
131         %{?with_apidocs:--enable-docs} \
132         %{?with_fortran:--enable-fortran} \
133         --enable-shared
134
135 # parallel build is broken (matio.mod, docs)
136 %{__make} -j1
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # keep .la - needed for -fortran
145
146 # packaged in -apidocs
147 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/matio
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc ChangeLog NEWS README
158 %attr(755,root,root) %{_libdir}/libmatio.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libmatio.so.0
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libmatio.so
164 %{_libdir}/libmatio.la
165 %{_includedir}/matio*.h
166 %{_pkgconfigdir}/matio.pc
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libmatio.a
171
172 %if %{with fortran}
173 %files fortran
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libmatio-fortran.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libmatio-fortran.so.0
177
178 %files fortran-devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libmatio-fortran.so
181 %{_libdir}/libmatio-fortran.la
182 %{_includedir}/matio.mod
183
184 %files fortran-static
185 %defattr(644,root,root,755)
186 %{_libdir}/libmatio-fortran.a
187 %endif
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %doc doxygen/latex/libmatio.pdf
193 %endif
This page took 0.074875 seconds and 2 git commands to generate.