]> git.pld-linux.org Git - packages/mate-session-manager.git/blob - mate-session-manager.spec
up to 1.5.2; adds systemd support
[packages/mate-session-manager.git] / mate-session-manager.spec
1 #
2 # TODO
3 # - Terminal=true, depends in mate-terminal, but probably should take preferred terminal application
4 # mate-session[4970]: WARNING: Could not launch application 'nvidia-settings.desktop': Unable to start application: Failed to execute child process "xdg-terminal" (No such file or directory)
5
6 # Conditional build:
7 %bcond_with     apidocs         # DocBook docs (incomplete)
8 %bcond_without  systemd # enable systemd support for default (when systemd is not running fallback to ConsoleKit)
9
10 Summary:        MATE Desktop session manager
11 Name:           mate-session-manager
12 Version:        1.5.2
13 Release:        1
14 License:        GPL v2+
15 Group:          X11/Applications
16 Source0:        http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
17 # Source0-md5:  75373b3d5d0d8f5f8f105f34de238a11
18 URL:            http://wiki.mate-desktop.org/mate-session-manager
19 BuildRequires:  dbus-glib-devel
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  glib2-devel >= 1:2.16.0
22 BuildRequires:  gtk+2-devel >= 2:2.14.0
23 BuildRequires:  intltool >= 0.40.0
24 BuildRequires:  mate-common
25 BuildRequires:  pangox-compat-devel
26 %{?with_systemd:BuildRequires:  systemd-devel >= 183}
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  upower-devel >= 0.9.0
29 %{?with_apidocs:BuildRequires:  xmlto}
30 BuildRequires:  xorg-lib-libSM-devel
31 BuildRequires:  xz
32 Requires:       glib2 >= 1:2.26.0
33 Requires:       gsettings-desktop-schemas
34 Requires:       gtk-update-icon-cache
35 Requires:       hicolor-icon-theme
36 Requires:       mate-desktop >= 1.5
37 # needed to satisfy 'filemanager' component (may be changed if alternatives available)
38 Requires:       mate-file-manager
39 # needed to satisfy 'panel' component (may be changed if alternatives available)
40 Requires:       mate-panel
41 # needed to satisfy 'windowmanager' component (may be changed if alternatives available)
42 Requires:       mate-window-manager
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 MATE Desktop session manager.
47
48 %package apidocs
49 Summary:        Session Manager D-Bus API Reference
50 Summary(pl.UTF-8):      Dokumentacja API Session Manager
51 Group:          Documentation
52
53 %description apidocs
54 Session Manager D-Bus API Reference.
55
56 %description apidocs -l pl.UTF-8
57 Dokumentacja API Session Manager.
58
59 %prep
60 %setup -q
61
62 %build
63 NOCONFIGURE=1 ./autogen.sh
64 %configure \
65         --disable-silent-rules \
66         --disable-static \
67         %{!?with_apidocs:--disable-docbook-docs} \
68         %{?with_apidocs:--enable-docbook-docs --docdir=%{_gtkdocdir}/%{name}} \
69         %{__enable_disable systemd systemd} \
70         --enable-ipv6 \
71         --with-gtk=2.0 \
72         --with-gnu-ld \
73         --with-default-wm=marco \
74         --with-x
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
84 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-session.convert
85
86 desktop-file-install \
87         --remove-category="MATE" \
88         --add-category="X-Mate" \
89         --delete-original \
90         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
91 $RPM_BUILD_ROOT%{_desktopdir}/mate-session-properties.desktop
92
93 %find_lang %{name}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 %update_icon_cache hicolor
100 %glib_compile_schemas
101
102 %postun
103 %update_icon_cache hicolor
104 %glib_compile_schemas
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %doc AUTHORS COPYING README
109 %attr(755,root,root) %{_bindir}/mate-session
110 %attr(755,root,root) %{_bindir}/mate-session-properties
111 %attr(755,root,root) %{_bindir}/mate-session-save
112 %attr(755,root,root) %{_bindir}/mate-wm
113 %{_mandir}/man1/mate-session-properties.1*
114 %{_mandir}/man1/mate-session-save.1*
115 %{_mandir}/man1/mate-session.1*
116 %{_mandir}/man1/mate-wm.1*
117 %{_desktopdir}/mate-session-properties.desktop
118 %{_datadir}/mate-session
119 %{_iconsdir}/hicolor/*/apps/*.png
120 %{_iconsdir}/hicolor/scalable/apps/mate-session-properties.svg
121 %{_datadir}/glib-2.0/schemas/org.mate.session.gschema.xml
122 %{_datadir}/xsessions/mate.desktop
123
124 %if %{with apidocs}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %{_gtkdocdir}/%{name}
128 %endif
This page took 0.212824 seconds and 3 git commands to generate.