]> git.pld-linux.org Git - packages/mate-power-manager.git/blob - mate-power-manager.spec
c55c4c43735a741e68e678d41f3feaf9622b8467
[packages/mate-power-manager.git] / mate-power-manager.spec
1 #
2 # Conditional build:
3 %bcond_without  systemd # systemd inhibit service
4
5 Summary:        MATE power management service
6 Summary(pl.UTF-8):      Usługa zarządzania energią dla MATE
7 Name:           mate-power-manager
8 Version:        1.24.3
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications
12 Source0:        https://pub.mate-desktop.org/releases/1.24/%{name}-%{version}.tar.xz
13 # Source0-md5:  d706e8c0cf784a808f06b9a4bfba7473
14 URL:            http://wiki.mate-desktop.org/mate-power-manager
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  cairo-devel >= 1.0.0
18 BuildRequires:  dbus-devel >= 1.0
19 BuildRequires:  dbus-glib-devel >= 0.70
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  docbook-dtd41-sgml
22 BuildRequires:  docbook-utils
23 BuildRequires:  gettext-tools >= 0.19.8
24 BuildRequires:  glib2-devel >= 1:2.50.0
25 BuildRequires:  gtk+3-devel >= 3.22
26 BuildRequires:  libcanberra-gtk3-devel >= 0.10
27 BuildRequires:  libgnome-keyring-devel >= 3.0.0
28 BuildRequires:  libnotify-devel >= 0.7.0
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  mate-common
31 BuildRequires:  mate-panel-devel >= 1.17.0
32 BuildRequires:  pkgconfig
33 BuildRequires:  popt-devel
34 BuildRequires:  rpmbuild(find_lang) >= 1.36
35 %{?with_systemd:BuildRequires:  systemd-devel >= 1:195}
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  upower-devel >= 0.99.8
38 BuildRequires:  xmlto
39 BuildRequires:  xorg-lib-libX11-devel
40 BuildRequires:  xorg-lib-libXext-devel
41 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3.0
42 BuildRequires:  xorg-lib-libXrender-devel
43 BuildRequires:  xorg-proto-xproto-devel >= 7.0.15
44 BuildRequires:  xz
45 BuildRequires:  yelp-tools
46 Requires(post,postun):  gtk-update-icon-cache
47 Requires:       cairo >= 1.0.0
48 Requires:       dbus >= 1.0
49 Requires:       dbus-glib >= 0.70
50 Requires:       glib2 >= 1:2.50.0
51 Requires:       gtk+3 >= 3.22
52 Requires:       hicolor-icon-theme
53 Requires:       libcanberra-gtk3 >= 0.10
54 Requires:       libgnome-keyring >= 3.0.0
55 Requires:       libnotify >= 0.7.0
56 Requires:       mate-panel >= 1.17.0
57 Requires:       upower >= 0.99.8
58 Requires:       xorg-lib-libXrandr >= 1.3.0
59 Suggests:       udisks
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # use the same libexecdir as mate-panel
63 # (better solution: store mate-panel libexecdir in libmatepanelapplet-*.pc and read it here)
64 %define         matepanel_libexecdir    %{_libexecdir}/mate-panel
65
66 %description
67 MATE Power Manager uses the information and facilities provided by
68 UPower displaying icons and handling user callbacks in an interactive
69 MATE session.
70
71 %description -l pl.UTF-8
72 MATE Power Manager wykorzystuje informacje i funkcje udostępniane
73 przez UPower do wyświetlania ikon i obsługi reakcji użytkownika w
74 interaktywnej sesji MATE.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --libexecdir=%{matepanel_libexecdir} \
87         --enable-applets \
88         --disable-silent-rules \
89         --disable-static \
90         %{!?with_systemd:--without-systemdinhibit}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %{__make} install \
97         INSTALL="install -p" \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{es_ES,frp,ie,jv,ku_IQ,pms}
101 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/help/{es_ES,frp,ie,jv,ku_IQ,zh-Hans}
102
103 %find_lang %{name} --with-mate
104
105 desktop-file-install \
106         --delete-original \
107         --remove-category=MATE \
108         --add-category=X-Mate \
109         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
110         $RPM_BUILD_ROOT%{_desktopdir}/*.desktop
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 %update_icon_cache hicolor
117 %glib_compile_schemas
118
119 %postun
120 %update_icon_cache hicolor
121 %glib_compile_schemas
122
123 %files  -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README
126 /etc/xdg/autostart/mate-power-manager.desktop
127 %attr(755,root,root) %{_bindir}/mate-power-manager
128 %attr(755,root,root) %{_bindir}/mate-power-preferences
129 %attr(755,root,root) %{_bindir}/mate-power-statistics
130 %attr(755,root,root) %{_sbindir}/mate-power-backlight-helper
131 %attr(755,root,root) %{matepanel_libexecdir}/mate-brightness-applet
132 %attr(755,root,root) %{matepanel_libexecdir}/mate-inhibit-applet
133 %{_mandir}/man1/mate-power-backlight-helper.1*
134 %{_mandir}/man1/mate-power-manager.1*
135 %{_mandir}/man1/mate-power-preferences.1*
136 %{_mandir}/man1/mate-power-statistics.1*
137 %{_datadir}/%{name}
138 %{_datadir}/mate-panel/applets/org.mate.BrightnessApplet.mate-panel-applet
139 %{_datadir}/mate-panel/applets/org.mate.InhibitApplet.mate-panel-applet
140 %{_datadir}/dbus-1/services/org.mate.PowerManager.service
141 %{_datadir}/dbus-1/services/org.mate.panel.applet.BrightnessAppletFactory.service
142 %{_datadir}/dbus-1/services/org.mate.panel.applet.InhibitAppletFactory.service
143 %{_datadir}/glib-2.0/schemas/org.mate.power-manager.gschema.xml
144 %{_datadir}/polkit-1/actions/org.mate.power.policy
145 %{_desktopdir}/mate-power-preferences.desktop
146 %{_desktopdir}/mate-power-statistics.desktop
147 %{_iconsdir}/hicolor/*/apps/mate-brightness-applet.*
148 %{_iconsdir}/hicolor/*/apps/mate-inhibit-applet.*
149 %{_iconsdir}/hicolor/*/apps/mate-power-manager.*
150 %{_iconsdir}/hicolor/*/apps/mate-power-statistics.*
This page took 0.062998 seconds and 2 git commands to generate.