]> git.pld-linux.org Git - packages/mate-power-manager.git/blob - mate-power-manager.spec
up to 1.10.1
[packages/mate-power-manager.git] / mate-power-manager.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3    # use GTK+ 3.x instead of 2.x
4 %bcond_without  systemd # systemd inhibit service
5
6 Summary:        MATE power management service
7 Summary(pl.UTF-8):      Usługa zarządzania energią dla MATE
8 Name:           mate-power-manager
9 Version:        1.10.1
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications
13 Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
14 # Source0-md5:  a0cc921742c0a51c8a9e661c10c9eb75
15 URL:            http://wiki.mate-desktop.org/mate-power-manager
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairo-devel >= 1.0.0
19 BuildRequires:  dbus-devel >= 1.0
20 BuildRequires:  dbus-glib-devel >= 0.70
21 BuildRequires:  desktop-file-utils
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  docbook-utils
24 BuildRequires:  gettext-tools >= 0.10.40
25 BuildRequires:  glib2-devel >= 1:2.36.0
26 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
27 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
28 BuildRequires:  intltool >= 0.35.0
29 %{!?with_gtk3:BuildRequires:    libcanberra-gtk-devel >= 0.10}
30 %{?with_gtk3:BuildRequires:     libcanberra-gtk3-devel >= 0.10}
31 BuildRequires:  libgnome-keyring-devel >= 3.0.0
32 BuildRequires:  libnotify-devel >= 0.7.0
33 BuildRequires:  libtool >= 2:2
34 %{!?with_gtk3:BuildRequires:    libunique-devel >= 0.9.4}
35 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
36 BuildRequires:  mate-common
37 BuildRequires:  mate-desktop-devel >= 1.9.0
38 BuildRequires:  mate-panel-devel >= 1.5.0
39 BuildRequires:  pkgconfig
40 BuildRequires:  popt-devel
41 BuildRequires:  rpmbuild(find_lang) >= 1.36
42 %{?with_systemd:BuildRequires:  systemd-devel >= 1:195}
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  upower-devel >= 0.9.5
45 BuildRequires:  xorg-lib-libXext-devel
46 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3
47 BuildRequires:  xorg-lib-libXrender-devel
48 BuildRequires:  xorg-proto-xproto-devel >= 7.0.15
49 BuildRequires:  xz
50 BuildRequires:  yelp-tools
51 Requires:       cairo >= 1.0.0
52 Requires:       dbus >= 1.0
53 Requires:       dbus-glib >= 0.70
54 Requires:       glib2 >= 1:2.36.0
55 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
56 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
57 Requires:       gtk-update-icon-cache
58 Requires:       hicolor-icon-theme
59 Requires:       libcanberra-gtk >= 0.10
60 Requires:       libgnome-keyring >= 0.6.0
61 Requires:       libnotify >= 0.7.0
62 %{!?with_gtk3:Requires: libunique >= 0.9.4}
63 %{?with_gtk3:Requires:  libunique3 >= 3.0}
64 Requires:       mate-desktop-libs >= 1.9.0
65 Requires:       mate-panel >= 1.5.0
66 Requires:       upower >= 0.9.5
67 Requires:       xorg-lib-libXrandr >= 1.3
68 Suggests:       udisks
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _libexecdir     %{_libdir}/mate-panel
72
73 %description
74 MATE Power Manager uses the information and facilities provided by
75 UPower displaying icons and handling user callbacks in an interactive
76 MATE session.
77
78 %description -l pl.UTF-8
79 MATE Power Manager wykorzystuje informacje i funkcje udostępniane
80 przez UPower do wyświetlania ikon i obsługi reakcji użytkownika w
81 interaktywnej sesji MATE.
82
83 %prep
84 %setup -q
85
86 %build
87 %{__intltoolize}
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --enable-applets \
95         --disable-silent-rules \
96         --disable-static \
97         %{?with_gtk3:--with-gtk=3.0} \
98         %{!?with_systemd:--without-systemdinhibit}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 %{__make} install \
105         INSTALL="install -p" \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
109 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-power-manager.convert
110
111 %find_lang %{name} --with-mate
112
113 desktop-file-install \
114         --delete-original \
115         --remove-category=MATE \
116         --add-category=X-Mate \
117         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
118         $RPM_BUILD_ROOT%{_desktopdir}/*.desktop
119
120 # utility removed, drop man pages
121 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mate-power-manager-bugreport.1
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %update_icon_cache hicolor
128 %glib_compile_schemas
129
130 %postun
131 %update_icon_cache hicolor
132 %glib_compile_schemas
133
134 %files  -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog NEWS README
137 /etc/xdg/autostart/mate-power-manager.desktop
138 %attr(755,root,root) %{_bindir}/mate-power-manager
139 %attr(755,root,root) %{_bindir}/mate-power-preferences
140 %attr(755,root,root) %{_bindir}/mate-power-statistics
141 %attr(755,root,root) %{_sbindir}/mate-power-backlight-helper
142 %attr(755,root,root) %{_libexecdir}/mate-brightness-applet
143 %attr(755,root,root) %{_libexecdir}/mate-inhibit-applet
144 %{_mandir}/man1/mate-power-backlight-helper.1*
145 %{_mandir}/man1/mate-power-manager.1*
146 %{_mandir}/man1/mate-power-preferences.1*
147 %{_mandir}/man1/mate-power-statistics.1*
148 %{_datadir}/%{name}
149 %{_datadir}/mate-panel/applets/org.mate.BrightnessApplet.mate-panel-applet
150 %{_datadir}/mate-panel/applets/org.mate.InhibitApplet.mate-panel-applet
151 %{_datadir}/dbus-1/services/org.mate.PowerManager.service
152 %{_datadir}/dbus-1/services/org.mate.panel.applet.BrightnessAppletFactory.service
153 %{_datadir}/dbus-1/services/org.mate.panel.applet.InhibitAppletFactory.service
154 %{_datadir}/glib-2.0/schemas/org.mate.power-manager.gschema.xml
155 %{_datadir}/polkit-1/actions/org.mate.power.policy
156 %{_desktopdir}/mate-power-preferences.desktop
157 %{_desktopdir}/mate-power-statistics.desktop
158 %{_iconsdir}/hicolor/*/apps/mate-brightness-applet.*
159 %{_iconsdir}/hicolor/*/apps/mate-inhibit-applet.*
160 %{_iconsdir}/hicolor/*/apps/mate-power-manager.*
161 %{_iconsdir}/hicolor/*/apps/mate-power-statistics.*
This page took 0.098438 seconds and 3 git commands to generate.