]> git.pld-linux.org Git - packages/mate-panel.git/blob - mate-panel.spec
use package deps, more specific url
[packages/mate-panel.git] / mate-panel.spec
1 # TODO
2 # - check direct deps:
3 #mate-panel-1.5.3-0.1.i686 marks mate-menus-libs-1.5.0-1.i686 (cap libmate-menu.so.2)
4 #mate-panel-1.5.3-0.1.i686 marks mate-panel-libs-1.5.3-0.1.i686 (cap libmate-panel-applet-4.so.1)
5 #mate-panel-1.5.3-0.1.i686 marks libmateweather-1.5.0-1.i686 (cap libmateweather.so.1)
6 #mate-panel-1.5.3-0.1.i686 marks libmatewnck-1.5.0-1.i686 (cap libmatewnck.so.0)
7
8 # Conditional build:
9 %bcond_without  apidocs         # disable gtk-doc
10
11 Summary:        MATE Desktop panel applets
12 Name:           mate-panel
13 Version:        1.5.3
14 Release:        1
15 # libs are LGPLv2+ applications GPLv2+
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
19 # Source0-md5:  72029cbcd38bee447df92c8774452bf3
20 URL:            http://wiki.mate-desktop.org/mate-panel
21 BuildRequires:  NetworkManager-gtk-lib-devel
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  dconf-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  glib2-devel >= 1:2.25.12
26 BuildRequires:  gobject-introspection-devel
27 BuildRequires:  gsettings-desktop-schemas-devel
28 BuildRequires:  gtk+2-devel >= 2:2.19.7
29 BuildRequires:  icon-naming-utils
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libmateweather-devel
33 BuildRequires:  libmatewnck-devel
34 BuildRequires:  librsvg-devel
35 BuildRequires:  mate-common
36 BuildRequires:  mate-desktop-devel
37 %{?with_apidocs:BuildRequires:  mate-doc-utils}
38 BuildRequires:  mate-menus-devel
39 BuildRequires:  pango-devel >= 1:1.15.4
40 BuildRequires:  popt-devel
41 BuildRequires:  rpmbuild(find_lang) >= 1.36
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  xorg-lib-libICE-devel
44 BuildRequires:  xorg-lib-libSM-devel
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xz
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       glib2 >= 1:2.26.0
49 Requires:       gsettings-desktop-schemas
50 # needed as nothing else requires it
51 Requires:       desktop-file-utils
52 Requires:       gtk-update-icon-cache
53 Requires:       mate-session-manager
54 Suggests:       mate-settings-daemon
55 # for fish
56 Requires:       fortune-mod
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 MATE Desktop panel applets
61
62 %package libs
63 Summary:        Shared libraries for mate-panel
64 License:        LGPL v2+
65 Group:          Libraries
66
67 %description libs
68 Shared libraries for libmate-desktop
69
70 %package devel
71 Summary:        Development files for mate-panel
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74
75 %description devel
76 Development files for mate-panel
77
78 %package apidocs
79 Summary:        mate-panel API documentation
80 Summary(pl.UTF-8):      Dokumentacja API mate-panel
81 Group:          Documentation
82 Requires:       gtk-doc-common
83
84 %description apidocs
85 mate-panel API documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API mate-panel.
89
90 %prep
91 %setup -q
92
93 %build
94 NOCONFIGURE=1 ./autogen.sh
95 # libexecdir needed for gnome conflicts
96 %configure \
97         --disable-scrollkeeper \
98         --disable-static \
99         --disable-schemas-compile \
100         --with-x \
101         --enable-network-manager \
102         --libexecdir=%{_libexecdir}/mate-panel \
103         --with-html-dir=%{_gtkdocdir}
104
105 %{__make} \
106         V=1
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
114
115 desktop-file-install \
116         --remove-category="MATE" \
117         --add-category="X-Mate" \
118         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
119 $RPM_BUILD_ROOT%{_desktopdir}/mate-panel.desktop
120
121 %find_lang %{name} --with-mate --with-omf --all-name
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %update_icon_cache hicolor
128 %update_desktop_database
129 %glib_compile_schemas
130
131 %postun
132 %update_icon_cache hicolor
133 %update_desktop_database
134 %glib_compile_schemas
135
136 %post   libs -p /sbin/ldconfig
137 %postun libs -p /sbin/ldconfig
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS COPYING README
142 %attr(755,root,root) %{_bindir}/mate-desktop-item-edit
143 %attr(755,root,root) %{_bindir}/mate-panel
144 %attr(755,root,root) %{_bindir}/mate-panel-test-applets
145 %{_mandir}/man1/mate-panel.1*
146 %dir %{_libdir}/mate-panel
147 %attr(755,root,root) %{_libdir}/mate-panel/clock-applet
148 %attr(755,root,root) %{_libdir}/mate-panel/fish-applet
149 %attr(755,root,root) %{_libdir}/mate-panel/mate-panel-add
150 %attr(755,root,root) %{_libdir}/mate-panel/notification-area-applet
151 %attr(755,root,root) %{_libdir}/mate-panel/wnck-applet
152 %{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
153 %{_datadir}/glib-2.0/schemas/org.mate.panel.*.xml
154 %{_datadir}/dbus-1/services/org.mate.panel.*.service
155 %{_datadir}/mate-panel
156 %{_datadir}/mate-panelrc
157 %{_iconsdir}/hicolor/*/*/*
158 %{_desktopdir}/mate-panel.desktop
159
160 %files libs
161 %defattr(644,root,root,755)
162 %doc COPYING.LIB
163 %attr(755,root,root) %{_libdir}/libmate-panel-applet-4.so.*.*.*
164 %ghost %{_libdir}/libmate-panel-applet-4.so.1
165
166 %files devel
167 %defattr(644,root,root,755)
168 %{_libdir}/libmate-panel-applet-4.so
169 %{_includedir}/mate-panel-4.0
170 %{_pkgconfigdir}/libmatepanelapplet-4.0.pc
171 %{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
172
173 %if %{with apidocs}
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/mate-panel-applet
177 %endif
This page took 0.146333 seconds and 4 git commands to generate.