]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
use updated xdg-user-dirs-gtk package
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4
5 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc
6 Name:           mate-desktop
7 Version:        1.5.7
8 Release:        2
9 License:        GPL v2+ and LGPL v2+ and MIT
10 Group:          X11/Applications
11 Source0:        http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
12 # Source0-md5:  539cb021d6384e83c0af7d41d1152d6b
13 URL:            http://wiki.mate-desktop.org/mate-desktop
14 BuildRequires:  desktop-file-utils
15 BuildRequires:  docbook-dtd412-xml
16 BuildRequires:  gettext-devel
17 BuildRequires:  intltool >= 0.40.0
18 BuildRequires:  libunique-devel
19 BuildRequires:  mate-common
20 %{?with_apidocs:BuildRequires:  mate-doc-utils >= 1.1.0}
21 BuildRequires:  rpmbuild(find_lang) >= 1.36
22 BuildRequires:  startup-notification-devel
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       %{name}-libs = %{version}-%{release}
26 Requires:       glib2 >= 1:2.26.0
27 #Requires:      python-pygtk-gtk
28 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
29 Requires:       hwdata >= 0.243-6
30 #Requires:      redhat-menus
31 Requires:       xdg-user-dirs-gtk >= 0.10-2
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The mate-desktop package contains an internal library (libmatedesktop)
36 used to implement some portions of the MATE desktop, and also some
37 data files and other shared components of the MATE user environment.
38
39 %package libs
40 Summary:        Shared libraries for libmate-desktop
41 License:        LGPL v2+
42 Group:          Libraries
43
44 %description libs
45 Shared libraries for libmate-desktop
46
47 %package devel
48 Summary:        Libraries and headers for libmate-desktop
49 License:        LGPL v2+
50 Group:          Development/Libraries
51 Requires:       %{name}-libs = %{version}-%{release}
52
53 %description devel
54 Libraries and header files for the MATE-internal private library
55 libmatedesktop.
56
57 %package apidocs
58 Summary:        mate-desktop API documentation
59 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
60 Group:          Documentation
61 Requires:       gtk-doc-common
62
63 %description apidocs
64 mate-desktop API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API mate-desktop.
68
69 %prep
70 %setup -q
71
72 %build
73 NOCONFIGURE=1 ./autogen.sh
74 %configure \
75         --disable-silent-rules \
76         --enable-gnucat \
77         --disable-scrollkeeper \
78         --disable-static \
79         --disable-schemas-compile \
80         --with-pnp-ids-path=/lib/hwdata/pnp.ids \
81         --enable-unique \
82         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
83         --with-omf-dir=%{_datadir}/omf/%{name}
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
93
94 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
95 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
96
97 desktop-file-install \
98         --remove-category="MATE" \
99         --add-category="X-Mate" \
100         --delete-original \
101         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
102 $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
103
104 %find_lang %{name} --with-mate --with-omf --all-name
105
106 %post   libs -p /sbin/ldconfig
107 %postun libs -p /sbin/ldconfig
108
109 %post
110 %glib_compile_schemas
111
112 %postun
113 %glib_compile_schemas
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING COPYING.LIB NEWS README
121 %attr(755,root,root) %{_bindir}/mate-about
122 %{_mandir}/man1/mate-about.1*
123 %{_pixmapsdir}/gnu-cat*
124 %{_desktopdir}/mate-about.desktop
125 %dir %{_datadir}/omf/%{name}/fdl
126 %dir %{_datadir}/omf/%{name}/gpl
127 %dir %{_datadir}/omf/%{name}/lgpl
128 %{_datadir}/mate-about
129 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
130
131 %files libs
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
134 %ghost %{_libdir}/libmate-desktop-2.so.17
135
136 %files devel
137 %defattr(644,root,root,755)
138 %{_libdir}/libmate-desktop-2.so
139 %{_pkgconfigdir}/mate-desktop-2.0.pc
140 %{_includedir}/mate-desktop-2.0
141
142 %if %{with apidocs}
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_gtkdocdir}/mate-desktop
146 %endif
This page took 0.070432 seconds and 4 git commands to generate.