]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
- typo
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gtk3            # use GTK+ 3.x instead of GTK+ 2.x
5
6 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
7 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
8 Name:           mate-desktop
9 Version:        1.8.1
10 Release:        1
11 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
12 Group:          X11/Applications
13 Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  985c9396685bf31217f5322a6e3cbaff
15 Patch0:         %{name}-help_prefix.patch
16 URL:            http://wiki.mate-desktop.org/mate-desktop
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dconf-devel >= 0.13.4
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 1:2.26.0
25 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
26 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
27 BuildRequires:  gtk-doc >= 1.4
28 BuildRequires:  intltool >= 0.40.0
29 BuildRequires:  libtool
30 %{!?with_gtk3:BuildRequires:    libunique-devel >= 1.0}
31 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
32 BuildRequires:  mate-common
33 BuildRequires:  rpmbuild(find_lang) >= 1.36
34 BuildRequires:  startup-notification-devel >= 0.5
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xorg-lib-libX11-devel
37 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
38 BuildRequires:  xz
39 BuildRequires:  yelp-tools
40 Requires:       %{name}-libs = %{version}-%{release}
41 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
42 Requires:       hwdata >= 0.243-6
43 Requires:       xdg-user-dirs-gtk >= 0.10-2
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The mate-desktop package contains an internal library (libmatedesktop)
48 used to implement some portions of the MATE desktop, and also some
49 data files and other shared components of the MATE user environment.
50
51 %description -l pl.UTF-8
52 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
53 służącą do implementacji niektórych elementów środowiska MATE, trochę
54 plików z danymi oraz inne współdzielone komponenty środowiska
55 użytkownika MATE.
56
57 %package libs
58 Summary:        Shared libmate-desktop library
59 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
60 License:        LGPL v2+
61 Group:          Libraries
62 Requires:       gdk-pixbuf2 >= 2.4.0
63 Requires:       glib2 >= 1:2.26.0
64 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
65 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
66 Requires:       startup-notification >= 0.5
67 Requires:       xorg-lib-libXrandr >= 1.2
68
69 %description libs
70 Shared libmate-desktop library.
71
72 %description libs -l pl.UTF-8
73 Biblioteka współdzielona libmate-desktop.
74
75 %package devel
76 Summary:        Header files for libmate-desktop
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
78 License:        LGPL v2+
79 Group:          Development/Libraries
80 Requires:       %{name}-libs = %{version}-%{release}
81 Requires:       gdk-pixbuf2-devel >= 2.4.0
82 Requires:       glib2-devel >= 1:2.26.0
83 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.24.0}
84 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
85 Requires:       startup-notification-devel >= 0.5
86
87 %description devel
88 Header files for the MATE-internal private library libmate-desktop.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
92 libmate-desktop.
93
94 %package apidocs
95 Summary:        mate-desktop API documentation
96 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
97 Group:          Documentation
98 Requires:       gtk-doc-common
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 mate-desktop API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API mate-desktop.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %{__gtkdocize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
122         --disable-schemas-compile \
123         --disable-silent-rules \
124         --disable-static \
125         --enable-unique \
126         --enable-mpaste \
127         %{?with_gtk3:--with-gtk=3.0} \
128         --with-pnp-ids-path=/lib/hwdata/pnp.ids
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
138 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cmn
139
140 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
141 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
142
143 desktop-file-install \
144         --remove-category="MATE" \
145         --add-category="X-Mate" \
146         --delete-original \
147         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
148         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
149
150 %find_lang %{name} --with-mate --with-omf --all-name
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %glib_compile_schemas
157
158 %postun
159 %glib_compile_schemas
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
167 %attr(755,root,root) %{_bindir}/mate-about
168 %attr(755,root,root) %{_bindir}/mate-gsettings-toggle
169 %attr(755,root,root) %{_bindir}/mpaste
170 %{_mandir}/man1/mate-about.1*
171 %{_mandir}/man1/mate-gsettings-toggle.1*
172 %{_desktopdir}/mate-about.desktop
173 %{_desktopdir}/mate-user-guide.desktop
174 %{_datadir}/mate-about
175 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
176
177 %files libs
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
185 %{_includedir}/mate-desktop-2.0
186 %{_pkgconfigdir}/mate-desktop-2.0.pc
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/mate-desktop
192 %endif
This page took 0.066212 seconds and 4 git commands to generate.