]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
- updated to 1.10.0 (1.8.x left on MATE-1.8 branch)
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gtk3            # use GTK+ 3.x instead of GTK+ 2.x
5
6 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
7 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
8 Name:           mate-desktop
9 Version:        1.10.0
10 Release:        1
11 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
12 Group:          X11/Applications
13 Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
14 # Source0-md5:  af952debca4d979107681e8b7d085fe8
15 URL:            http://wiki.mate-desktop.org/mate-desktop
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  dconf-devel >= 0.13.4
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
22 BuildRequires:  gettext-tools
23 BuildRequires:  glib2-devel >= 1:2.36.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.7
25 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
26 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
27 BuildRequires:  gtk-doc >= 1.4
28 BuildRequires:  intltool >= 0.40.0
29 BuildRequires:  libtool
30 %{!?with_gtk3:BuildRequires:    libunique-devel >= 1.0}
31 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
32 BuildRequires:  mate-common
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(find_lang) >= 1.36
35 BuildRequires:  startup-notification-devel >= 0.5
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
39 BuildRequires:  xz
40 BuildRequires:  yelp-tools
41 Requires:       %{name}-libs = %{version}-%{release}
42 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
43 Requires:       hwdata >= 0.243-6
44 Requires:       xdg-user-dirs-gtk >= 0.10-2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 The mate-desktop package contains an internal library (libmatedesktop)
49 used to implement some portions of the MATE desktop, and also some
50 data files and other shared components of the MATE user environment.
51
52 %description -l pl.UTF-8
53 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
54 służącą do implementacji niektórych elementów środowiska MATE, trochę
55 plików z danymi oraz inne współdzielone komponenty środowiska
56 użytkownika MATE.
57
58 %package libs
59 Summary:        Shared libmate-desktop library
60 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
61 License:        LGPL v2+
62 Group:          Libraries
63 Requires:       gdk-pixbuf2 >= 2.4.0
64 Requires:       glib2 >= 1:2.36.0
65 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
66 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
67 Requires:       startup-notification >= 0.5
68 Requires:       xorg-lib-libXrandr >= 1.2
69
70 %description libs
71 Shared libmate-desktop library.
72
73 %description libs -l pl.UTF-8
74 Biblioteka współdzielona libmate-desktop.
75
76 %package devel
77 Summary:        Header files for libmate-desktop
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
79 License:        LGPL v2+
80 Group:          Development/Libraries
81 Requires:       %{name}-libs = %{version}-%{release}
82 Requires:       gdk-pixbuf2-devel >= 2.4.0
83 Requires:       glib2-devel >= 1:2.36.0
84 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.24.0}
85 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
86 Requires:       startup-notification-devel >= 0.5
87
88 %description devel
89 Header files for the MATE-internal private library libmate-desktop.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
93 libmate-desktop.
94
95 %package apidocs
96 Summary:        mate-desktop API documentation
97 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
98 Group:          Documentation
99 Requires:       gtk-doc-common
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description apidocs
105 mate-desktop API documentation.
106
107 %description apidocs -l pl.UTF-8
108 Dokumentacja API mate-desktop.
109
110 %prep
111 %setup -q
112
113 %build
114 %{__gtkdocize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
122         --disable-schemas-compile \
123         --disable-silent-rules \
124         --disable-static \
125         --enable-unique \
126         --enable-mpaste \
127         %{?with_gtk3:--with-gtk=3.0} \
128         --with-pnp-ids-path=/lib/hwdata/pnp.ids
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
138 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cmn
139
140 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
141 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
142
143 desktop-file-install \
144         --remove-category="MATE" \
145         --add-category="X-Mate" \
146         --delete-original \
147         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
148         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
149
150 %find_lang %{name} --with-mate --with-omf --all-name
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %glib_compile_schemas
157
158 %postun
159 %glib_compile_schemas
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
167 %attr(755,root,root) %{_bindir}/mate-about
168 %attr(755,root,root) %{_bindir}/mate-color-select
169 %attr(755,root,root) %{_bindir}/mpaste
170 %{_mandir}/man1/mate-about.1*
171 %{_desktopdir}/mate-about.desktop
172 %{_desktopdir}/mate-color-select.desktop
173 %{_datadir}/mate-about
174 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
175
176 %files libs
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
180 %{_libdir}/girepository-1.0/MateDesktop-2.0.typelib
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
185 %{_includedir}/mate-desktop-2.0
186 %{_datadir}/gir-1.0/MateDesktop-2.0.gir
187 %{_pkgconfigdir}/mate-desktop-2.0.pc
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/mate-desktop
193 %endif
This page took 0.076925 seconds and 4 git commands to generate.