]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
- up to 1.8.0
[packages/mate-desktop.git] / mate-desktop.spec
1 # # Conditional build:
2 %bcond_without  apidocs         # disable gtk-doc
3 %bcond_with     gtk3            # use GTK+ 3.x instead of GTK+ 2.x
4
5 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
6 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
7 Name:           mate-desktop
8 Version:        1.8.0
9 Release:        1
10 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
11 Group:          X11/Applications
12 Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
13 # Source0-md5:  d808e7dd6445991bc41b65982144df00
14 Patch0:         %{name}-help_prefix.patch
15 URL:            http://wiki.mate-desktop.org/mate-desktop
16 BuildRequires:  autoconf
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  dconf-devel >= 0.13.4
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 1:2.26.0
24 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
25 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
26 BuildRequires:  gtk-doc >= 1.4
27 BuildRequires:  intltool >= 0.40.0
28 BuildRequires:  libtool
29 %{!?with_gtk3:BuildRequires:    libunique-devel >= 1.0}
30 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
31 BuildRequires:  mate-common
32 BuildRequires:  rpmbuild(find_lang) >= 1.36
33 BuildRequires:  startup-notification-devel >= 0.5
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xorg-lib-libX11-devel
36 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
37 BuildRequires:  xz
38 BuildRequires:  yelp-tools
39 Requires:       %{name}-libs = %{version}-%{release}
40 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
41 Requires:       hwdata >= 0.243-6
42 Requires:       xdg-user-dirs-gtk >= 0.10-2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The mate-desktop package contains an internal library (libmatedesktop)
47 used to implement some portions of the MATE desktop, and also some
48 data files and other shared components of the MATE user environment.
49
50 %description -l pl.UTF-8
51 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
52 służącą do implementacji niektórych elementów środowiska MATE, trochę
53 plików z danymi oraz inne współdzielone komponenty środowiska
54 użytkownika MATE.
55
56 %package libs
57 Summary:        Shared libmate-desktop library
58 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
59 License:        LGPL v2+
60 Group:          Libraries
61 Requires:       gdk-pixbuf2 >= 2.4.0
62 Requires:       glib2 >= 1:2.26.0
63 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
64 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
65 Requires:       startup-notification >= 0.5
66 Requires:       xorg-lib-libXrandr >= 1.2
67
68 %description libs
69 Shared libmate-desktop library.
70
71 %description libs -l pl.UTF_8
72 Biblioteka współdzielona libmate-desktop.
73
74 %package devel
75 Summary:        Header files for libmate-desktop
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
77 License:        LGPL v2+
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       glib2-devel >= 1:2.26.0
81 Requires:       gdk-pixbuf2-devel >= 2.4.0
82 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.24.0}
83 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
84 Requires:       startup-notification-devel >= 0.5
85
86 %description devel
87 Header files for the MATE-internal private library libmate-desktop.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
91 libmate-desktop.
92
93 %package apidocs
94 Summary:        mate-desktop API documentation
95 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
96 Group:          Documentation
97 Requires:       gtk-doc-common
98
99 %description apidocs
100 mate-desktop API documentation.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API mate-desktop.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %{__gtkdocize}
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
118         --disable-schemas-compile \
119         --disable-scrollkeeper \
120         --disable-silent-rules \
121         --disable-static \
122         --enable-unique \
123         %{?with_gtk3:--with-gtk=3.0} \
124         --with-omf-dir=%{_datadir}/omf/%{name} \
125         --with-pnp-ids-path=/lib/hwdata/pnp.ids
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
135 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cmn
136
137 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
138 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
139
140 desktop-file-install \
141         --remove-category="MATE" \
142         --add-category="X-Mate" \
143         --delete-original \
144         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
145         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
146
147 %find_lang %{name} --with-mate --with-omf --all-name
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %glib_compile_schemas
154
155 %postun
156 %glib_compile_schemas
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
164 %attr(755,root,root) %{_bindir}/mate-about
165 %attr(755,root,root) %{_bindir}/mate-gsettings-toggle
166 %{_mandir}/man1/mate-about.1*
167 %{_mandir}/man1/mate-gsettings-toggle.1*
168 %{_desktopdir}/mate-about.desktop
169 %{_desktopdir}/mate-user-guide.desktop
170 %{_datadir}/mate-about
171 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
172
173 %files libs
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
181 %{_includedir}/mate-desktop-2.0
182 %{_pkgconfigdir}/mate-desktop-2.0.pc
183
184 %if %{with apidocs}
185 %files apidocs
186 %defattr(644,root,root,755)
187 %{_gtkdocdir}/mate-desktop
188 %endif
This page took 0.072594 seconds and 4 git commands to generate.