]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
- release 2 (by relup.sh)
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gtk3            # use GTK+ 3.x instead of GTK+ 2.x
5
6 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
7 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
8 Name:           mate-desktop
9 Version:        1.8.0
10 Release:        2
11 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
12 Group:          X11/Applications
13 Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  d808e7dd6445991bc41b65982144df00
15 Patch0:         %{name}-help_prefix.patch
16 URL:            http://wiki.mate-desktop.org/mate-desktop
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dconf-devel >= 0.13.4
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 1:2.26.0
25 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
26 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
27 BuildRequires:  gtk-doc >= 1.4
28 BuildRequires:  intltool >= 0.40.0
29 BuildRequires:  libtool
30 %{!?with_gtk3:BuildRequires:    libunique-devel >= 1.0}
31 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
32 BuildRequires:  mate-common
33 BuildRequires:  rpmbuild(find_lang) >= 1.36
34 BuildRequires:  startup-notification-devel >= 0.5
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xorg-lib-libX11-devel
37 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
38 BuildRequires:  xz
39 BuildRequires:  yelp-tools
40 Requires:       %{name}-libs = %{version}-%{release}
41 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
42 Requires:       hwdata >= 0.243-6
43 Requires:       xdg-user-dirs-gtk >= 0.10-2
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The mate-desktop package contains an internal library (libmatedesktop)
48 used to implement some portions of the MATE desktop, and also some
49 data files and other shared components of the MATE user environment.
50
51 %description -l pl.UTF-8
52 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
53 służącą do implementacji niektórych elementów środowiska MATE, trochę
54 plików z danymi oraz inne współdzielone komponenty środowiska
55 użytkownika MATE.
56
57 %package libs
58 Summary:        Shared libmate-desktop library
59 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
60 License:        LGPL v2+
61 Group:          Libraries
62 Requires:       gdk-pixbuf2 >= 2.4.0
63 Requires:       glib2 >= 1:2.26.0
64 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
65 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
66 Requires:       startup-notification >= 0.5
67 Requires:       xorg-lib-libXrandr >= 1.2
68
69 %description libs
70 Shared libmate-desktop library.
71
72 %description libs -l pl.UTF_8
73 Biblioteka współdzielona libmate-desktop.
74
75 %package devel
76 Summary:        Header files for libmate-desktop
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
78 License:        LGPL v2+
79 Group:          Development/Libraries
80 Requires:       %{name}-libs = %{version}-%{release}
81 Requires:       gdk-pixbuf2-devel >= 2.4.0
82 Requires:       glib2-devel >= 1:2.26.0
83 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.24.0}
84 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
85 Requires:       startup-notification-devel >= 0.5
86
87 %description devel
88 Header files for the MATE-internal private library libmate-desktop.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
92 libmate-desktop.
93
94 %package apidocs
95 Summary:        mate-desktop API documentation
96 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
97 Group:          Documentation
98 Requires:       gtk-doc-common
99
100 %description apidocs
101 mate-desktop API documentation.
102
103 %description apidocs -l pl.UTF-8
104 Dokumentacja API mate-desktop.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 %build
111 %{__gtkdocize}
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
119         --disable-schemas-compile \
120         --disable-silent-rules \
121         --disable-static \
122         --enable-unique \
123         --enable-mpaste \
124         %{?with_gtk3:--with-gtk=3.0} \
125         --with-pnp-ids-path=/lib/hwdata/pnp.ids
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
135 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cmn
136
137 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
138 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
139
140 desktop-file-install \
141         --remove-category="MATE" \
142         --add-category="X-Mate" \
143         --delete-original \
144         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
145         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
146
147 %find_lang %{name} --with-mate --with-omf --all-name
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %glib_compile_schemas
154
155 %postun
156 %glib_compile_schemas
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
164 %attr(755,root,root) %{_bindir}/mate-about
165 %attr(755,root,root) %{_bindir}/mate-gsettings-toggle
166 %attr(755,root,root) %{_bindir}/mpaste
167 %{_mandir}/man1/mate-about.1*
168 %{_mandir}/man1/mate-gsettings-toggle.1*
169 %{_desktopdir}/mate-about.desktop
170 %{_desktopdir}/mate-user-guide.desktop
171 %{_datadir}/mate-about
172 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
173
174 %files libs
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
182 %{_includedir}/mate-desktop-2.0
183 %{_pkgconfigdir}/mate-desktop-2.0.pc
184
185 %if %{with apidocs}
186 %files apidocs
187 %defattr(644,root,root,755)
188 %{_gtkdocdir}/mate-desktop
189 %endif
This page took 0.087205 seconds and 4 git commands to generate.