]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
cdb719481b833a3edc4ab5aaa629228f4e55eb45
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4
5 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
6 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
7 Name:           mate-desktop
8 Version:        1.22.1
9 Release:        1
10 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
11 Group:          X11/Applications
12 Source0:        http://pub.mate-desktop.org/releases/1.22/%{name}-%{version}.tar.xz
13 # Source0-md5:  1232abca80bcb94095ff1d9db623325b
14 URL:            http://wiki.mate-desktop.org/mate-desktop
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  dconf-devel >= 0.13.4
18 BuildRequires:  desktop-file-utils
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.50.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.7
24 BuildRequires:  gtk+3-devel >= 3.22
25 BuildRequires:  gtk-doc >= 1.4
26 BuildRequires:  intltool >= 0.50.1
27 BuildRequires:  libtool
28 BuildRequires:  mate-common
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(find_lang) >= 1.36
31 BuildRequires:  startup-notification-devel >= 0.5
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3
35 BuildRequires:  xz
36 BuildRequires:  yelp-tools
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires(post,postun):  hicolor-icon-theme
39 Requires:       %{name}-libs = %{version}-%{release}
40 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
41 Requires:       hwdata >= 0.243-6
42 Requires:       xdg-user-dirs-gtk >= 0.10-2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The mate-desktop package contains an internal library (libmatedesktop)
47 used to implement some portions of the MATE desktop, and also some
48 data files and other shared components of the MATE user environment.
49
50 %description -l pl.UTF-8
51 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
52 służącą do implementacji niektórych elementów środowiska MATE, trochę
53 plików z danymi oraz inne współdzielone komponenty środowiska
54 użytkownika MATE.
55
56 %package libs
57 Summary:        Shared libmate-desktop library
58 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
59 License:        LGPL v2+
60 Group:          Libraries
61 Requires:       dconf >= 0.13.4
62 Requires:       gdk-pixbuf2 >= 2.4.0
63 Requires:       glib2 >= 1:2.50.0
64 Requires:       gtk+3 >= 3.22
65 Requires:       startup-notification >= 0.5
66 Requires:       xorg-lib-libXrandr >= 1.3
67
68 %description libs
69 Shared libmate-desktop library.
70
71 %description libs -l pl.UTF-8
72 Biblioteka współdzielona libmate-desktop.
73
74 %package devel
75 Summary:        Header files for libmate-desktop
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
77 License:        LGPL v2+
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       dconf-devel >= 0.13.4
81 Requires:       gdk-pixbuf2-devel >= 2.4.0
82 Requires:       glib2-devel >= 1:2.50.0
83 Requires:       gtk+3-devel >= 3.22
84 Requires:       startup-notification-devel >= 0.5
85
86 %description devel
87 Header files for the MATE-internal private library libmate-desktop.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
91 libmate-desktop.
92
93 %package apidocs
94 Summary:        mate-desktop API documentation
95 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
96 Group:          Documentation
97 Requires:       gtk-doc-common
98 %if "%{_rpmversion}" >= "5"
99 BuildArch:      noarch
100 %endif
101
102 %description apidocs
103 mate-desktop API documentation.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API mate-desktop.
107
108 %prep
109 %setup -q
110
111 %build
112 %{__gtkdocize}
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
120         --disable-schemas-compile \
121         --disable-silent-rules \
122         --disable-static \
123         --with-pnp-ids-path=/lib/hwdata/pnp.ids
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
133
134 desktop-file-install \
135         --remove-category="MATE" \
136         --add-category="X-Mate" \
137         --delete-original \
138         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
139         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
140
141 # frp,jv,ku_IQ not supported yet by glibc
142 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,jv,ku_IQ}
143
144 %find_lang %{name} --with-mate
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %glib_compile_schemas
151 %update_icon_cache hicolor
152
153 %postun
154 %glib_compile_schemas
155 %update_icon_cache hicolor
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README
163 %attr(755,root,root) %{_bindir}/mate-about
164 %attr(755,root,root) %{_bindir}/mate-color-select
165 %{_mandir}/man1/mate-about.1*
166 %{_mandir}/man1/mate-color-select.1*
167 %{_desktopdir}/mate-about.desktop
168 %{_desktopdir}/mate-color-select.desktop
169 %{_iconsdir}/hicolor/*/apps/mate-desktop.png
170 %{_iconsdir}/hicolor/scalable/apps/mate-desktop-symbolic.svg
171 %{_iconsdir}/hicolor/scalable/apps/mate-desktop.svg
172 %{_datadir}/mate-about
173 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
174
175 %files libs
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
179 %{_libdir}/girepository-1.0/MateDesktop-2.0.typelib
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
184 %{_includedir}/mate-desktop-2.0
185 %{_datadir}/gir-1.0/MateDesktop-2.0.gir
186 %{_pkgconfigdir}/mate-desktop-2.0.pc
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/mate-desktop
192 %endif
This page took 0.057993 seconds and 2 git commands to generate.